2621 Router IOS - Need your Urgent HELP

Unanswered Question
Oct 7th, 2008

Hi All,

I was trying to upgrade my IOS from 12.2-15T to 12.3-26. After reload my router got Crashed. Its not booting up saying not enf memory. Attaching the Error Log. What should i do next. Can any one help me to load an IOS through Xmodem or any other option please.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
jacobsamuel2021 Tue, 10/07/2008 - 03:12

Hi Andrew,

Thanks a lot for the Link and information. I managed to make it up through tftpdnld from rommon.

But i need your kind help on this. The whole exercise i did for my DSL Link at my office. The router was used to connect to the dsl link we have at our office, it was working perfectly all right with the image c2600-ik9o3s3-mz.122-15.T15.bin for more than last 3 - 4 yeras i believe. All of a sudden the DSL link got disconnected. When we check with the Telco it was a Cable cut by mistake from the Telco side. They apologized and connect the link back but this time the DSL was keep on flapping... coming up for few seconds and going down, there was no config change or any thing. I put a normal dsl modem, it is working perfectly fine. I post the case and i got the suggestion that the link got degraded due to the cable cut may be you can try to upgrade the FW by upgrading the IOS. It may or may not work. what i should do in this case? what could be the problem in the router?

please your kind help required.

Thanks & Regards

jacobsamuel2021 Tue, 10/07/2008 - 03:20

HI Andrew,

Now the Router is OK. I put the old IOS which was working fine. Now i can see the ADSL Cards on the WAN interface is detected. I did not get any latest IOS which i can try.



What version are you running now? what is the image file name?

Regarding your DSL - if you are having issues, after a cable cut, do you know where the cable cut was?

Sadly when your provider fixed it, they could have created the issue you are seeing now. DSL is very sensitive to noise and loss on the line, normally this is caused in cabling. You can configure your router to be more - tolerant of noise.


jacobsamuel2021 Tue, 10/07/2008 - 21:55

HI Anderew

The current image is the same one which was running before the cable cut and was showing problem after the cable cut;

c2600-ik9o3s3-mz.122-15.T15.bin. The Router is offline now.

Cable got cut from the Junction Box of the Telco at our Bldg. The problem Telco is saying there is no problem, when i said there is a problem they come with a normal DSL modem showed as that it is working fine from their side. Like that it is working as of now, but if i put the link on cisco router it will not come up, will do flapping.

I can not find this IOS (122-15.T15) in the ADSL feature support IOS List of Cisco, but it is detecting the ADSL Cards and was working fine also. I may need the information of the next series IOS of 122-15.T15, which support the adsl cards.

By the way can i ask you one mroe question Andrew? what is FirmWare upgrade? i think when we upgrade the IOS that will upgrade the firm ware also. Or is it some thing other than IOS upgrade? If YES, what we have to do for the FW upgrade?




This Discussion