DR Site with two different Voice VLANS

Answered Question
Oct 7th, 2008

Hi all,

We have a DR hosting site and their voice VLAN is 800 and our Voice VLAN is 100.

What I am trying to do it to get the phones on the DR Site (VLAN800) to register with the phone on the main network (VLAN100).

interface FastEthernet0/1

description *****Link To 6509C (Port 1/42)*****

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 100

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast trunk

!

interface FastEthernet0/24

description *****Link to Switch in DR Room*****

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust cos

auto qos voip trust

I don't have VLAN 800 setup on our switch and I was wondering if anyone could help me configure routing between VLAN100 and VLAN800 so the phone will register with Call Manager.

I hope I have enough info in here.

Thanks

Anthony

I have this problem too.
0 votes
Correct Answer by Marwan ALshawi about 8 years 1 month ago

ok i will give a brief background regaeding ur case

if u have multiple voice vlans

and here in ur case 100 and 800

lets say site one users use voice vlan as 100

and ur callmanager is in site1 in vlan 100 too

remote site use vlan 800 as voice vlan

what u need to do is just enble routeing between those two vlans in other words make the bother vlans reachable between each other

and the helper address need to point to callmanager or any dhcp server or IOS dhcp server but the dhcp server need to have address space for that vlan

the only thing u need is the TFTP for ciscp IP phones if the TFTP is the same to callmanager which is mostly the case then

u need to creat a dhcp pool for vlan 100 les say on the call manager and put the call manager ip as the tftp server

on the remote site lets say on the L3 switch u created a DHCP pool for vlan 800 give then ip pool in that vlan rnage or u can creat a pool with vlan 800 rnage on the callmanager on the L3 switch interface for vlan 800 make the helper address as the callmanger ip

and tftp should be the callmanager ip as well

if u used the cisco switch IOS dhcp server serivce u just need to put the callmanager IP in the dhcp otipn 150 for TFTP

and all the above need routing communication between those vlans i mean 100 and 800

good luck

if helpful Rate

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (3 ratings)
Loading.
Anthony O'Reilly Tue, 10/07/2008 - 06:33

Hi, Please see outputs below. Many Thanks.

DRSANTRYSWITCH1#sh int fa0/1 trunk

Port Mode Encapsulation Status Native vlan

Fa0/1 on 802.1q trunking 1

Port Vlans allowed on trunk

Fa0/1 1-4094

Port Vlans allowed and active in management domain

Fa0/1 1-2,10-16,19-20,40,100,120,130-131,140,251-254,300,500-501,600

Port Vlans in spanning tree forwarding state and not pruned

Fa0/1 1-2,10-16,19-20,40,100,120,130-131,140,251-254,300,500-501,600

DRSANTRYSWITCH1#sh int fa0/24 trunk

Port Mode Encapsulation Status Native vlan

Fa0/24 on 802.1q trunking 1

Port Vlans allowed on trunk

Fa0/24 1,100,800

Port Vlans allowed and active in management domain

Fa0/24 1,100

Port Vlans in spanning tree forwarding state and not pruned

Fa0/24 1,100

DRSANTRYSWITCH1#

dominic.caron Tue, 10/07/2008 - 06:57

In your switch, can you verify that vlan 800 exist. You can do that by issuing a sh spanning vlan 800.

If it not there, create it.

Now, if you want to do routing with the 6509c, you need to create a vlan interface for vlan 800. You can base your config on the one you've got for vlan 100. It should work if you dont have any ACL in the way(but from a security standpoint, I hope you do...)

Anthony O'Reilly Tue, 10/07/2008 - 07:04

Hi,

Output from the spanning command:

DRSANTRYSWITCH1#sh spanning vlan 800

Spanning tree instance(s) for vlan 800 does not exist.

DRSANTRYSWITCH1#

VLAN100 is created on the 6509C like this:

interface Vlan100

ip address 10.100.1.5 255.255.0.0

ip pim sparse-dense-mode

standby 4 ip 10.100.1.4

standby 4 timers 1 3

standby 4 priority 10

standby 4 preempt

If I add the following to the 6509C:

interface Vlan800

ip address 10.1.180.1 255.255.0.0

ip pim sparse-dense-mode

standby 4 ip 10.1.180.1

standby 4 timers 1 3

standby 4 priority 10

standby 4 preempt

What do I need to add to the switch to get the phone to register with the Call Manager?

Thanks

Anthony

dominic.caron Tue, 10/07/2008 - 07:56

first create the vlan on the switch:

conf t

vlan 800

after that, if you do a sh int f*/* trunk, you should se that your vlan forwarded on the trunk.

Since you dont have any ip helper configure on your vlan 100 interface, I guest that the Call manager is in the same vlan as the phone. You need to configure a ip helper adress on your vlan 800 interface to relay dhcp message to your dhcp server.

You will need to configure your DHCP(probably on your call manager server)

Anthony O'Reilly Wed, 10/08/2008 - 00:53

Hi,

Here is what I have done so far:

On 6509C

interface Vlan100

ip address 10.100.1.5 255.255.0.0

ip pim sparse-dense-mode

standby 4 ip 10.100.1.4

standby 4 timers 1 3

standby 4 priority 10

standby 4 preempt

!

interface Vlan800

description DR SANTRY VOICE VLAN

ip address 10.180.1.1 255.255.0.0

ip pim sparse-dense-mode

!

Putput from fa0/1 and fa0/24 on DR Switch:

DRSANTRYSWITCH1#sh int fa0/1 trunk

Port Mode Encapsulation Status Native vlan

Fa0/1 on 802.1q trunking 1

Port Vlans allowed on trunk

Fa0/1 1-4094

Port Vlans allowed and active in management domain

Fa0/1 1-2,10-16,19-20,40,100,120,130-131,140,251-254,300,500-501,600,800

Port Vlans in spanning tree forwarding state and not pruned

Fa0/1 1-2,10-16,19-20,40,100,120,130-131,140,251-254,300,500-501,600,800

DRSANTRYSWITCH1#sh int fa0/24 trunk

Port Mode Encapsulation Status Native vlan

Fa0/24 on 802.1q trunking 1

Port Vlans allowed on trunk

Fa0/24 1-4094

Port Vlans allowed and active in management domain

Fa0/24 1-2,10-16,19-20,40,100,120,130-131,140,251-254,300,500-501,600,800

Port Vlans in spanning tree forwarding state and not pruned

Fa0/24 1-2,10-16,19-20,40,100,120,130-131,140,251-254,300,500-501,600,800

DRSANTRYSWITCH1#sh spanning vlan 800

VLAN0800

Spanning tree enabled protocol ieee

Root ID Priority 8192

Address 00d0.0016.e320

Cost 23

Port 3 (FastEthernet0/1)

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 33568 (priority 32768 sys-id-ext 800)

Address 0019.aaca.b100

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa0/1 Root FWD 19 128.3 Shr

Fa0/24 Desg FWD 19 128.26 P2p

Where do I put the helper address, is the helper address the ip address of the call manager, the ip address of vlan 100 (voice vlan)?

Thanks

Anthony

Correct Answer
Marwan ALshawi Wed, 10/08/2008 - 04:00

ok i will give a brief background regaeding ur case

if u have multiple voice vlans

and here in ur case 100 and 800

lets say site one users use voice vlan as 100

and ur callmanager is in site1 in vlan 100 too

remote site use vlan 800 as voice vlan

what u need to do is just enble routeing between those two vlans in other words make the bother vlans reachable between each other

and the helper address need to point to callmanager or any dhcp server or IOS dhcp server but the dhcp server need to have address space for that vlan

the only thing u need is the TFTP for ciscp IP phones if the TFTP is the same to callmanager which is mostly the case then

u need to creat a dhcp pool for vlan 100 les say on the call manager and put the call manager ip as the tftp server

on the remote site lets say on the L3 switch u created a DHCP pool for vlan 800 give then ip pool in that vlan rnage or u can creat a pool with vlan 800 rnage on the callmanager on the L3 switch interface for vlan 800 make the helper address as the callmanger ip

and tftp should be the callmanager ip as well

if u used the cisco switch IOS dhcp server serivce u just need to put the callmanager IP in the dhcp otipn 150 for TFTP

and all the above need routing communication between those vlans i mean 100 and 800

good luck

if helpful Rate

Actions

This Discussion