Polycom DTMF Problem on VG224 / SCCP

Unanswered Question
Oct 7th, 2008


I am having a problem with DTMF through our polycoms hooked up to our VG224's... need to dial pretty fast to get it to recognize the right tones..

SCCP, Version 12.4(15)T5

Any ideas/bugs/suggestions?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
testeven Tue, 10/07/2008 - 08:19


This seems to be similar to bug CSCsg85602:

DTMF tones not recognised on calls to PSTN from VG224 due to tone leakage

This bug was introduced in DSPware 9.4.5 and seems to be causing the problem. One case was solved by downgrading the DSPware on the VG224 (while leaving the IOS at 12.4(15)T5) from 9.4.5 to 9.4.4. After running several tests there was not DTMF issue. So you can try staying with IOS 12.4(15)T5, but downgrade to the previous DSPware to avoid this problem.

HTH, if it does, please rate :)

Chad Stachowicz Tue, 10/07/2008 - 10:48

This looks aweswome... where is this DSPware, I have never heard of this! Can you please let me know

A.) How to check the current version.

B.) How I do this magical upgrade? :)

You rock!


testeven Tue, 10/07/2008 - 11:23

Hi Chad!

Although the DSPware is embedded in the Cisco IOS Software image, I believe there's a procedure to downgrade it without modifying

the IOS.

To downgrade the DSPware simply tftp the file to slot0: on the VG224, save config, and reload. When it comes back up issue

"show voice dsp group all" and confirm the new DSPware version. However to get the DSPware version you will need to contact TAC, I'm pretty sure that's not available for download on CCO. I think TAC can provide it or maybe they can recommend an IOS change. On the other hand, I see that you have IOS 12.4(15)T5 which

should have the fix for this bug. You can try using IOS 12.4(15)T7 too, but I mean this will be up to you, I can't make an IOS

recommendation :). If you feel more comfortable try opening a TAC case and see why is the bug not fixed on your version although

it should. Sounds weird though!

Have a nice day!




Chad Stachowicz Tue, 10/07/2008 - 11:39


I verified that the DSPWare version is 9.4.5... is there anywhere that shows what the IOS 12.4.15(T7) has for a DSPWare Version?



testeven Tue, 10/07/2008 - 11:46

Hi Chad,

Here's another bug I found: CSCso92891 versions affected are 12.4(15)T, 12.4(15)T05.

I did some research and it appears that DSPware version 9.4.6 has the fix and it is part of IOS 12.4(15)T7. So you can give it a try if you want to.



DTMF Digits not properly detected


DSPs improperly detect DTMF Digits that contain leakage.


Using DSPware 9.4.3 or later on 5510 DSPs. Leakages of 18msec either are not detected or are detected as duplicate digits.


Problem does not exist in the 4.4.x dspware. Use an IOS Version that contains this train of DSPware.

Cheers ;-)


Chad Stachowicz Tue, 10/07/2008 - 11:54


Your the man.. If it works I will come back and rate and resolve your post... change control scheduled for midnight..


testeven Tue, 10/07/2008 - 11:58

Cool, btw I'm the girl :) Hope this works I'll cross my fingers!

Chad Stachowicz Tue, 10/07/2008 - 23:53


While it was a problem with the DSPWare the bug we were hitting is not fixed in any IOS or DSPWare until the upcoming 12.4(15)T8 expected to be released in November. The TAC Engineer was able to give us a DSPWare 9.4.5 Engineering Special 3 that fixed the problem in the meantime. This only affects SCCP...and its only when a call is already up and its tried to pass DTMF.




This Discussion