Inconsistent results making international calls

Answered Question
Oct 7th, 2008
User Badges:

Issue: Inconsistent results making international calls (able to make a call to Zurich, but not London). Assumed it was a carrier issue. Carrier (MCI) took a d-chan capture on calls to the UK -- tech indicated he was seeing call type "Int'l ISDN with 011" and explained that the NI2 is sending the 011 and our PBX is sending the 011 - causing the failed call. I am not sure I follow the "NI2 is sending". The tech then took a d-chan capture of a call to Switzerland and indicated he was seeing call type "unknown with 011" and further indicated call is successful because there is only one 011 sent. Both calls take place on the same PRI facility. Including all relevant config lines below.


- After some Internet reading, I came across a suggestion indicating -- navigate to 'Call Type' and change the International Call Types to 'Unknown'. This seemed relevant, but unfortunately the post did not reference a Cisco gateway. Does anyone know of a similar config parameter on a Cisco router?


- Can I issue a command that will allow the router to make a call (so I do not have to bother the local clients)?

Router#isdn test call interface Serial0/0/0:22 19145551212

the first few messages appear like this would work, but then the first hint that this is not correct:

Oct 8 03:25:48.721: ISDN Se0/0/0:23 **ERROR**: call_setup_ack_proceeding: NO HDLC available b channel 22 call id 0x838B

Oct 8 03:25:48.721: ISDN Se0/0/0:23 Q931: TX -> DISCONNECT pd = 8 callref = 0x040A

Cause i = 0x80A2 - No circuit/channel available

What do I have wrong?


- I assume a next step would be to capture the calls from the CME's perspective. What are the appropriate debugs to run to determine why calls do not complete (debug isdn q931, debug voice dialpeer)?

The site is new, extremely low key, has only 15 phones and the site is generally < 50% occupied. Are there any debug concerns with respect to router load?


Relevant system info:

System CUCME running on C2821 ISR

Cisco IOS Software C2800NM-ADVENTERPRISEK9-M

Software Version 12.4(20)T / CME 7.0(0)


Relevant carrier Info:

Product: PRI (1) with 40 new numbers

CDDD: 8/11/2008

Signaling: 23 B Channels + Primary D

Framing/Coding: B8ZS/ESF

Protocol: NI2

Outpulsing Digits: 4

Hunting: Aseq/Dseq

Pic: 0222 (MCI) for Local, LD, and International


Relevant configuration:

!

!

isdn switch-type primary-ni

!

!

voice translation-rule 1

rule 1 /^\(21..\)$/ /781xxx\1/

!

!

voice translation-profile ANI

translate calling 1

!

!

controller T1 0/0/0

framing esf

linecode b8zs

cablelength long 0db

pri-group timeslots 1-24

!

!

interface Serial0/0/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

no cdp enable

!

!

voice-port 0/0/0:23

translation-profile outgoing ANI

!

!

dial-peer voice 5 pots

description International dialing

destination-pattern 9011.T

port 0/0/0:23

prefix 011 <--- is it possible that using forward-digits as opposed to prefix would result in a different outcome?


Correct Answer by fcavallaro about 8 years 9 months ago

Had a similar problem recently. Needed to stop CME from sending International signal and 011 simultaneously as it confused the carrier:


interface Serial0/0/0:23

isdn map address 011.* plan unknown type unknown


My dial peer looks the same as yours except the destination-pattern is 9011T


Try the csim command to make calls from the IOS:


csim start 9011

(enable isdn debug logging first)

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Marwan ALshawi Tue, 10/07/2008 - 21:06
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

can u make it explicit matching i mean ur dial-peer liek :


if u send 11 digit with 011 make it like



dial-peer voice 5 pots

description International dialing

destination-pattern 9011.......

port 0/0/0:23

forward-digits 11



Correct Answer
fcavallaro Wed, 10/08/2008 - 06:52
User Badges:

Had a similar problem recently. Needed to stop CME from sending International signal and 011 simultaneously as it confused the carrier:


interface Serial0/0/0:23

isdn map address 011.* plan unknown type unknown


My dial peer looks the same as yours except the destination-pattern is 9011T


Try the csim command to make calls from the IOS:


csim start 9011

(enable isdn debug logging first)

jeanne.cooney Thu, 10/09/2008 - 14:45
User Badges:

Hi Frank....


Thanks very much for the feedback. Your recommendation worked. However, I was curious if you also had the issue of inconsistency -- I am confused why some calls used Unknown/Unknown while others used the ISDN/International -- not sure if you know why or did not go deeper once you had a solution.


With regard to making the call from the router, I tried the command you provided and it looks more or less like what I get with the command I had tried. I think my misunderstanding was that it would actually make a call to my phone. Is this possible? I used to be able to do this on a legacy Nortel.


....jeanne


PS - For anyone else interested in the link that explains the isdn map command, the link is:

http://www.cisco.com/en/US/docs/ios/12_3t/dial/command/reference/dia_i2gt.html#wp1212108

wplantier Fri, 10/10/2008 - 09:37
User Badges:

I am having the same issue I think. I have a US ip phone-cme-vpn-cme-ip phone london and this works fine. I added nortel PBX--US CME--VPN--CME--London and it shows plan Private type unknown but the Cisco shows unknown and unknown (which calls work) our Nortel vendor doensnt know how to get it configured for unknown unknown.

jeanne.cooney Fri, 10/10/2008 - 10:04
User Badges:

I think it might be these parameters in the RDB (LD 16):


OGNP a...a Outgoing Numbering Plan (a...a = (UKWN), PUB, or PRV)

OGNT a...a Outgoing Numbering Type (a...a = (UKWN), INTL, NTN, LCL,

LOC, CDP or SPN)



jeanne.cooney Fri, 10/10/2008 - 10:15
User Badges:

Yes. Sorry for my assumption on your being familiar with the Nortel "LD 16 - RDB" lingo. RDB is route data block and where you would set the ISDN PRI parameters on the Nortel PBX.

Actions

This Discussion