2821 TFTP problem

Unanswered Question

Hello guys,

I have a 2821 router that I need to upgrade. I want to copy new IOS from TFTP on my computer which I am doing all the time. I have enough flash space I have connection to the TFTP server but I am getting this:

Accessing tftp://192.168.x.x/c2800nm-advsecurityk9-mz.124-15.XZ1.bin...

%Error opening tftp://192.168.x.x/c2800nm-advsecurityk9-mz.124-15.XZ1.bin (No such file

or directory)

I tried to copy from 2 different TFTP servers but I am getting the same result.

The IOS exists in TFTP root dir, I have net connetion, I have enough space in flash, I dont see the problem. Please help! And another question same router tris to boot from tftp, how can I change it not to look for tftp and to set just normal boot.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Richard Burts Wed, 10/08/2008 - 04:51


It appears that the router believes that the image file is in the root directory. Can you verify that the TFTP server is configured to look in the right place for the image file?



massimiliano.se... Wed, 10/08/2008 - 04:56


Whati is the version of TFTP server, that is the software you use in order to do TFTP?

In order to change the boot you can use the command:

boot system flash file_name_ios

I hope this helps.

Best regards.


mlund Thu, 10/09/2008 - 00:17


In the past (11.0) there was a command "service config" that was used to load config from tftp. It can be disabled with "no service config". Try if it still works



This Discussion