Cisco 851 and PPPoE

Unanswered Question
Oct 9th, 2008

I have a Cisco 851 and try to configure PPPoE to my provider. IOS 12.4(15)T7. And there are no interface command 'pppoe enable' in this IOS. What can I do? Without this command nothing is working (see the attachement).

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Collin Clark Thu, 10/09/2008 - 06:31

Here's is a working config for PPPoE.

interface FastEthernet4

description Physical Connection to Internet

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 1

no cdp enable

interface Dialer0

description OUTSIDE

ip address 75.x.x.x 255.255.255.248

ip mtu 1452

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip route-cache flow

dialer pool 1

dialer-group 1

ntp disable

no cdp enable

ppp authentication pap callin

ppp pap sent-username [email protected] password 0 MySeCrEt

Hope that helps.

kondratev Thu, 10/09/2008 - 18:05

I can't enter the command 'pppoe enable group global'. There are no this command in my IOS!

Scott Cannon Mon, 10/13/2008 - 20:18

remove the group global part of the command and just use pppoe enable.

eg:

int fa0/0

pppoe enable

pppoe-client dial-pool-number 1

int dail0

ip address negotiated

ip mtu 1492

dial pool 1

yaminqureshi Wed, 10/15/2008 - 02:20

I am having the same problem with the version Cisco IOS Software, C850 Software (C850-ADVSECURITYK9-M), Version 12.4(15)T7, RELEASE SOFTWARE (fc3) on the other hand this command is showing up fine in the version Cisco IOS Software, C850 Software (C850-ADVSECURITYK9-M), Version 12.4(11)T2, RELEASE SOFTWARE (fc4).

Is that relate to the problem with the version of IOS?

Thank you

Yamin

Actions

This Discussion