Unity Blind Transfer via PIMG problem

Answered Question
Oct 9th, 2008

I have a Unity 5.0(1) server we've just setup to replace our existing system. I have it connected to one of our NEC NEAX 2000 IPS PBXs via a Dialogic PIMG 1008LS with serial integration through the PIMG.

I have integration working and most everything seems fine. But if I call Unity and enter an extension the blind transfer fails.

If I watch on the port status monitor is shows it tries a xfer then plays the subscriber greeting then hangs up and the caller ends up getting the opening greeting. During all that the caller only hears MOH with a brief cut out and the subscriber extension never rings.

I'm hoping I'm just missing something easy.

I have this problem too.
0 votes
Correct Answer by eschulz about 8 years 1 month ago

Traces from the PIMG might tells us more but my initial guess would be that the PBX is sending a special (stutter?) dialtone when PIMG does the hookflash to initiate the transfer. PIMG could see this as an error tone rather than dialtone, which would cause the transfer to fail.

-Eric

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
Correct Answer
eschulz Thu, 10/09/2008 - 07:23

Traces from the PIMG might tells us more but my initial guess would be that the PBX is sending a special (stutter?) dialtone when PIMG does the hookflash to initiate the transfer. PIMG could see this as an error tone rather than dialtone, which would cause the transfer to fail.

-Eric

nweddle Thu, 10/09/2008 - 09:01

I looked at the PIMG config page again and there is a "Wait for dialtone after flash hook" setting. It's not mentioned in the setup manual. I set it to "No" and now it works. So it looks like your guess was right.

Thanks for the help,

Nathan

Actions

This Discussion