Port Channel issue on 10 GigE interfaces

Unanswered Question
Oct 10th, 2008

I am trying to bind two 10 GigE interfaces through a port-channel to my upstream router. It seems that the link keep flapping. Has anyone seen or know what maybe the reason for it happening?

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Fri, 10/10/2008 - 11:43

Hello Mehdi,

what are the platforms involved ?

I don't see so many router platforms capable to do 10GE bundling I hope it is a C7609 with Sup720 or more.

I'm not sure a GSR can do bundling on 10 GE links.

and the versions ?

Are you trying to use LACP or PAGP ?

If you like you should provide more details in order to get better help.

My personal idea is that etherchannel on routers is not the best way to manage redundancy I would think of two L3 parallel links using a dynamic routing protocol

Hope to help

Giuseppe

mehsulsss Sun, 10/12/2008 - 04:57

Hi Giuseppe,

It is between a 7604 with sup 720 and 6509 with sup 32. Th ether channel on gig link stays stable but the 10gigE flaps. I am using mode on.

Hope this helps.

Thanks

Giuseppe Larosa Sun, 10/12/2008 - 05:19

Hello Mehdi,

I suppose you have two etherchannel one made of two GE and one made of two 10GE.

To understand if you have an issue with etherchannel or with physical layer I would suggest the following:

unconfigure the 10GE bundle and use each 10GE link in standalone: STP will block one link.

If the scenario doesn't change and you still see the 10GE links flapping you are facing a physical layer problem otherwise the problem in on the etherchannel and I would turn to the switch with sup32 that is less powerful.

If you are using 8 10GE linecards on c7604 with sup720 check the IOS version we had to move from 12.2(18)SXF8 to 12.2(33)SXH to correctly support these linecards (we had had a couple of strange problems before solved with IOS upgrade)

Hope to help

Giuseppe

mehsulsss Sun, 10/12/2008 - 05:41

Hi Giuseppe,

Thank you for the answer. I am not trunking between the router and the switch. I am doing L3 with eigrp (kind of staying away from the stp scenerio). The reason to bundle them was for redundancy and more up stream bandwidth.

My version is s3223-advipservicesk9_wan-mz.122-18.SXF15

Regards.

Giuseppe Larosa Sun, 10/12/2008 - 11:21

Hello Mehdi,

>> I am doing L3 with eigrp (kind of staying away from the stp scenerio). The reason to bundle them was for redundancy and more up stream bandwidth.

I would use two L3 parallel links that EIGRP can manage by default using its very fast convergence: if you use an etherchannel the EIGRP hello packet will go out a single link on every side.

In the past I've seen different problems with etherchannel and routers: problems with netflow on GSR, poor load-balancing results (on a software based router like C7200)

Hope to help

Giuseppe

mehsulsss Sun, 10/12/2008 - 12:14

Guiseppe,

Thank you. One more Q, Can I have one etherchannel of 2 -1Gig links and one 1 direct 10GigE link? Will it still be ok to with Eigrp? This way I can test the 10gig E link .

Thanks again.

Giuseppe Larosa Sun, 10/12/2008 - 12:29

Hello Mehdi,

no: all etherchannel member links must be of the same speed and with similar setup.

to test the 10GE :

int ten4/1

no channel-group x on

no switchport

ip address 10.1.1.1 255.255.255.252

! add net statement in eigrp

router eigrp 100

network 10.1.1.0 0.0.0.3

no auto-summary

to make a link not preferred by EIGRP increase delay

int type x/y

delay

Hope to help

Giuseppe

mehsulsss Sun, 10/12/2008 - 12:34

Yes. I will have a ether Channel of 2 x1GigE and then the 10 GigE will not be a part of Etherchannel just the stand alone.

This way I will have the two connections to the upstream router. Ether channel and 10GigE. With this I will achieve two goals.

a) Redundancy

b)Fast convergence

Will this work.

Sorry and thank you again.

Amit Singh Sun, 10/12/2008 - 21:17

Hi Mehndi,

This should work as suggested by the previous poster. You will be able to achieve both A) and B). As the interface bandwidth is different you might need to play with some metrics settings in order for both the links to be included as Feasible successor. This all will depend on the final metric that EIGRP will calculate.

HTH,

-amit singh

tasho_shukerski Wed, 03/04/2009 - 03:34

Hello Giuseppe,

Can you give me some details about the strange problems with the 8 10GE linecards etherchannel. What about the 4 10GE card (WS-X6704-10GE) - are the problems existing also.

From your post I assume that when you have upgraded to 12.2(33)SXH these strange problems have disappeared. Is that correct?

Thanks in advance.

Tasho

Actions

This Discussion