CCM-PBX weird integration problem

Unanswered Question
Oct 11th, 2008

Hello everyone....

I have this very weird problem.

I have a site with a callmanager integrated with a legacy PBX through four FXO ports. It was workingn earlier and its configuration was pretty straight forward and it was working fine.

I have the gateway configured as an H323 gateway and I had a route pattern pointing to this gateway. A pots dial-peer points to the FXO ports.

WHile i also have a "connection plar opx XXXX" on the voice ports then a voip dial-peer pointing to the call-manager's ip.

However, all of a sudden, the integration failed and now calls cann't be made.

For example, when an analog phone from the PBX side calls an IP Phone, the IP Phone does ring, however, it cannot pick up the call!!!, Meanwhile the analog phones can hear a ringback and I can see the FXo port move from Alerting to Ringing then to guardout then to onhook and this process repeats forever.

And when an IP Phone calls an analog phone, the analog phone does ring but he cannot hear anything at all on the line, while the IP Phone doesn't hear a ringback tone and see connected on the ip phone screen, but after about 10 seconds, the IP phone would get a busy tone!!!!

what is that? I checked the configuration a thousand of times and i also checked the PBX side and it was fine as well.

the only thing i couldn't do was a restart since the router has a couple of E1s and they are use by the employees.

Out of desperation, I even tweaked with the signaling on the port, changing the timout values but still no progress.

Any idea what am i doing wrong

Really appreciate the response.

Thanks,

Ahmed El-Eraky

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
AhmedEl-Eraky Sat, 10/11/2008 - 06:23

Hello Marwan,

Thanks for the response.

IP Phones can make and recieve calls no prblem from the PSTN using the E1.

The PBX still has direct connections to the PSTN and are also going fine.

PBX callers doesn't go out of the voice gateway when making PSTN calls, but only when making calls to IP Phones.

thanks,

Ahmed El-Eraky

Md. Mijanur Rahman Sat, 10/11/2008 - 09:57

Hi, did you changed anything in signaling parameters in FXO configuration? or at the PBX side?

Follow these step by step procedures, hope this will help to figure out.

First, put an analog phone at each of the FXS ports of the PBX where the gateway FXO ports are connected. Check whether calls are successful in the PBX internally. If not successful then the problem is at PBX side, change the ports of the PBX to connect with gateway. If successful then,

Second, shut/no shut your FXO ports at gateway. Connect a PSTN Analog line (two wire) at one of the FXO ports if you have. Try to call from IP phone and check whether is it successful. If not successful then the problem is at your FXO port configuration or at those FXO ports physically itselves.

Keep in mind, reloading the gateway resolves such issue sometimes, but that's the last end solution. Always issue 'copy run start' before reloading. Try these troubleshooting and keep posting your updates.

Please rate if helpful.

AhmedEl-Eraky Sun, 10/12/2008 - 03:50

Hello..

Thanks for your response.

Actually, I have previously done that.

I took out the cable out from the FXO port and into a "working" analog phone. I was able to dial a PBX number and complete the call. I was also able to fully recieve an incoming call.

I further connected the FXO port to the PSTN directly. However inthis case, the same exact problem occured once again with the same making/recieving problem behavior appearing.

This isolates the problem away from the PBX or any special signaling between both GW and PBX.

From what i see now, it's a hardware problem in the FXO card itself since i have not changed any parameters or any other configuration under the voice port at all.

Also I know that the configuration is correct, since the correct phones ring and the FXO ports correctly open as well, but the call-setup seems flawed.

In fact, i recopied the working configuration back to the router this morning, and did a reload as well, however still no luck.

I will attempt to replace the card as my final resort.

will keep you updated.

Thanks,

Ahmed El-Eraky

AhmedEl-Eraky Tue, 10/14/2008 - 07:24

okay.. it is NOT the hardware.

I replaced the FXO with another and still no progress whatsoever.

could it be signaling of some sort?

really appreciate the help...

thanks,

Ahmed El-Eraky

Md. Mijanur Rahman Tue, 10/14/2008 - 07:49

Hello Ahmed,

Which model of router are you using? Do you have any extra module to replug the VIC? You can check it if you have option; the problem might be at router side also.

AhmedEl-Eraky Tue, 10/14/2008 - 15:54

It's a 2821.

Actually, the only thing left now would be probably using another slot. i will see if i can do that next, although i don't think this is the problem.

but are there any other reasons?... concerning the fact that the ip phone can see the incoming call but can not pick it. The port state shows "connected" at this point.

thanks,

Ahmed El-Eraky

AhmedEl-Eraky Tue, 11/11/2008 - 02:57

After long troubleshooting and using another router.

I discovered that there is something wrong with the CallManager itself!!

I had to restart the server itself or the callmanager service whenever I change anything on the callmanager.

What I was doing was changing in the route pattern to point to the correct gateway, I would have to do the restart.

or sometimes, the configuration just hangs by itself without any changes in the callmanager, and i would have to do the restart anyways....

thanks for the support.

Ahmed El-Eraky

Actions

This Discussion