Transferred calls to IPIVR failing

Unanswered Question
Oct 11th, 2008

I've got a strange issue occurring. When an agent transfers a call to a route point for a different queue the IPIVR repeats the same wav file over and over, even though it should be playing different wave files. The IVR script also contains a Get Digit String which passes the collected digit back to ICM for further routing and the CED is not passed back to ICM. It works correctly if you call the route point directly so the ICM logic and IPIVR logic are correct I know. No matter what is set in the IPIVR to pass back to ICM, ICM doesn't see it. The RCD and TCD records contain no data in the peripheral variables on the transferred call. As I mentioned it shows up and works fine if you call the RP directly. Has anyone else run into this? I'm running ICM 7.1.5 and IPIVR 4.5. I've got a TAC case open too but wanted to check here alos

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jpsweeney77 Sun, 10/12/2008 - 06:19

Start with this bug (CSCsh68404). I ran into this same issue last year. (ICM 7.1.4, IPIVR 4.5) I need to check with the customer to see if they ever came to a resolution on the matter. TAC had the customer update all patches on IPIVR which didn't work. They also updated to all the latest SR's for ICM. No luck there either. They were running 7.1.4 so apparently the issue has not been corrected in 7.1.5. Also, the bug stated to use a consult transfer as a workaround. That did not work.

Bottom line is IPIVR never receives the ICM data on the transferred call. They had to build 'static' IPIVR scripts as a workaround for transferred calls.

PATRICK WILD Thu, 10/23/2008 - 21:08

Did you try to disable "network transfer preferred" in ICM regarding the Callmanager and IPIVR peripherals?

Ran into an issue with ICM7.2.2/CVP 4.1.1/UCM 4.2.3 which required disabling "network transfer preferred"

Actions

This Discussion