outgoing call problem

Unanswered Question
Oct 12th, 2008

hi,

im not able to make call from CME to PSTN network .. while calling the result of debug isdn q931 is

" Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98382

Exclusive, Channel 2

Progress Ind i = 0x8183 - Origination address is non-ISDN

Calling Party Number i = 0x0180, '17317400'

Plan:ISDN, Type:Unknown

Called Party Number i = 0x81, '39325303'

Plan:ISDN, Type:Unknown

Oct 12 15:10:17.655: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8 callref =

0x0092

Cause i = 0x80E6 - Recovery on timer expiry

Oct 12 15:10:17.655: ISDN Se0/0/0:15 **ERROR**: CCPCC_CallOrigination: SETUP tim

ed-out (2nd T303) to NETWORK. The SETUP failed.

Oct 12 15:10:18.423: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8 callref =

0x0093

Cause i = 0x80E6 - Recovery on timer expiry

Oct 12 15:10:18.423: ISDN Se0/0/0:15 **ERROR**: CCPCC_CallOrigination: SETUP tim

ed-out (2nd T303) to NETWORK. The SETUP failed."

this is my first installation, i have done configuration on CME according to docs, i dont know either its my prob or from service provider ... can any one help me out please

thanks in advance

REgards

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Fernando Rivas ... Sun, 10/12/2008 - 10:27

Looking at the logs problem looks to be in the Service Provider side. (Although i am missing part of the logs...).

Assuming that the SETUP is sent by the CME, there is no reply from the SP side, and thus the call is released after the timer expired, probably after 4 seconds. T303 timer.

craig.corbett Sun, 10/12/2008 - 11:00

For us to help you, post some more info.

Result of 'show isdn status'

What country?

Relevant parts of the Running config

Ahmed Nasry Abd... Mon, 10/13/2008 - 00:31

result of show isdn status is

UNDP-CCME#sh isdn status

Global ISDN Switchtype = primary-net5

ISDN Serial0/0/0:15 interface

dsl 0, interface ISDN Switchtype = primary-net5

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 0 CCBs = 0

The Free Channel Mask: 0x80000FFF

Number of L2 Discards = 0, L2 Session ID = 2

Total Allocated ISDN CCBs = 0

UNDP-CCME#

and the result of debug isdn q921 is

UNDP-CCME#

Oct 13 08:58:38.367: ISDN Se0/0/0:15 Q921: User TX -> RRp sapi=0 tei=0 nr=0

Oct 13 08:58:38.367: ISDN Se0/0/0:15 Q921: User RX <- RRp sapi=0 tei=0 nr=9

Oct 13 08:58:38.367: ISDN Se0/0/0:15 Q921: User TX -> RRf sapi=0 tei=0 nr=0

Oct 13 08:58:38.375: ISDN Se0/0/0:15 Q921: User RX <- RRf sapi=0 tei=0 nr=9

Oct 13 08:58:41.075: ISDN Se0/0/0:15 Q921: User TX -> INFO sapi=0 tei=0, ns=9 nr

=0

Oct 13 08:58:41.087: ISDN Se0/0/0:15 Q921: User RX <- RR sapi=0 tei=0 nr=10

Oct 13 08:58:45.071: ISDN Se0/0/0:15 Q921: User TX -> INFO sapi=0 tei=0, ns=10 n

r=0

Oct 13 08:58:45.083: ISDN Se0/0/0:15 Q921: User RX <- RR sapi=0 tei=0 nr=11

Oct 13 08:58:49.071: ISDN Se0/0/0:15 Q921: User TX -> INFO sapi=0 tei=0, ns=11 n

r=0

Oct 13 08:58:49.071: ISDN Se0/0/0:15 **ERROR**: CCPCC_CallOrigination: SETUP tim

ed-out (2nd T303) to NETWORK. The SETUP failed.

Oct 13 08:58:49.079: ISDN Se0/0/0:15 Q921: User RX <- RR sapi=0 tei=0 nr=12

UNDP-CCME#

UNDP-CCME#

my running config is

"controller E1 0/0/0

framing NO-CRC4

pri-group timeslots 1-10,16 (bcoz the customer has 10channels in 1 PRI)"

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bchan-number-order ascending

no cdp enable

voice-port 0/0/0:15

translation-profile incoming IncomingPSTN

translation-profile outgoing DIDOUT

dial-peer voice 21 pots

destination-pattern 9[1-8].......

direct-inward-dial

port 0/0/0:15

forward-digits 8

im doing this project in Bahrain and my provider name is Batelco ...

if any more info required then tell me ..

thanks for reply

Regards

Marwan ALshawi Mon, 10/13/2008 - 01:13

is 17317400 a valid number to be send to pstn as ur number i mean calling number ?

were u looking to call '39325303' as called number?

can u post ur config

Ahmed Nasry Abd... Mon, 10/13/2008 - 08:03

the calling number 17371400 that should be valid,because my customer has got this number from service provide...and according to the communication between customer and provider,provider have fix this number on there side.and called number 39325303,this is my mobile number.so i am trying to call from that ip phone with extension 400 to my mobile number..well my running config is

UNDP-CCME#sh run

Building configuration...

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname UNDP-CCME

!

boot-start-marker

boot-end-marker

!

card type e1 0 0

logging buffered 51200 warnings

!

clock timezone GMT 3

network-clock-participate wic 0

!

!

ip cef

!

!

ip domain name undp.org.bh

ip name-server 192.168.1.3

!

isdn switch-type primary-net5

!

voice-card 0

dspfarm

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

supplementary-service h450.12

h323

sip

registrar server expires max 3600 min 3600

!

!

voice class codec 1

codec preference 1 g711ulaw

!

voice register global

max-dn 192

max-pool 48

!

voice translation-rule 100

rule 1 /^17317/ //

!

voice translation-rule 200

rule 1 // //

!

!

voice translation-profile DIDOUT

translate calling 200

!

voice translation-profile IncomingPSTN

translate called 100

!

controller E1 0/0/0

framing NO-CRC4

pri-group timeslots 1-10,16

!

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.10

description ** Voice VLAN **

encapsulation dot1Q 10

ip address 192.168.10.2 255.255.255.0

!

interface GigabitEthernet0/0.100

description ** Data VLAN **

encapsulation dot1Q 100

ip address 192.168.1.14 255.255.255.0

!

interface Service-Engine0/0

ip unnumbered Loopback0

service-module ip address 10.1.10.1 255.255.255.0

service-module ip default-gateway 10.1.10.2

!

interface GigabitEthernet0/1

ip address 10.0.0.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bchan-number-order ascending

no cdp enable

!

ip route 0.0.0.0 0.0.0.0 192.168.10.1 permanent

ip route 10.1.10.1 255.255.255.255 Service-Engine0/0

!

!

ip http server

ip http access-class 23

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip http path flash:

!

voice-port 0/0/0:15

translation-profile incoming IncomingPSTN

translation-profile outgoing DIDOUT

!

dial-peer voice 10 voip

description ** cue voicemail pilot number **

translation-profile outgoing PSTN_CallForwarding

destination-pattern 600

session protocol sipv2

session target ipv4:10.1.10.1

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 11 voip

description ** cue auto attendant number **

translation-profile outgoing PSTN_CallForwarding

destination-pattern 601

session protocol sipv2

session target ipv4:10.1.10.1

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 21 pots

destination-pattern 9[1-8].......

no digit-strip

direct-inward-dial

port 0/0/0:15

forward-digits 8

!

!

dial-peer voice 22 pots

description Internation Access

destination-pattern 900T

direct-inward-dial

port 0/0/0:15

prefix 00

!

telephony-service

load 7960-7940 P00308000500

load 7914 S00104000100

load 7970 term70.default

max-ephones 48

max-dn 96

ip source-address 192.168.10.2 port 2000

calling-number initiator

system message UNDP

time-zone 31

date-format dd-mm-yy

voicemail 600

max-conferences 8 gain -6

call-forward pattern .T

moh music-on-hold.au

multicast moh 239.10.16.4 port 2000

dn-webedit

time-webedit

transfer-system full-consult dss

transfer-pattern 9.T

secondary-dialtone 9

login timeout 5

create cnf-files version-stamp 7960 Oct 13 2008 10:06:40

thanks for reply.

Regards

Marwan ALshawi Mon, 10/13/2008 - 18:44

can u apply the translation profile on the dial-peers instead of the voice port

remove it from the voice port then apply it as following

dial-peer voice 21 pots

incoming-called number .

translation-profile incoming IncomingPSTN

translation-profile outgoing DIDOUT

dial-peer voice 22 pots

translation-profile outgoing DIDOUT

and can u tell me if if u use dial-plan pattren or not i cant see anyway

and do all ur internal phones have DID number ?

can u describe the following to me ?

voice translation-rule 200

rule 1 // //

thenk you and good luck

Ahmed Nasry Abd... Mon, 10/13/2008 - 23:07

hi marwan .. thanks for reply bro ....about the testing for translation profile in dial peer i will check out by today .... and about translation rule which was in my config that was fake (i make that rule because of limited characters on post) well my translation rule is simple

voice translation-rule 100

rule 1 /^17317400/ /400/

voice translation-rule 200

rule 1 /^400/ /17317400/

about DID, as i told the customer has got 10Channels from 1 PRI so i think customer can get 10 DID at a time .....but DID i have to configure it is into scope of my work ...

Thanks,

Regards

Ahmed Nasry Abd... Tue, 10/14/2008 - 04:27

Hi all,

this issue has been fixed ... the problem was from service provider side ... they people had block outgoing from there side ... thats why i was not able to call ... well thank you so much for all and for there time ... this was my first post on netpro and got perfect suggestion from all of you guyz ... thanks once again ...

will see you with some other issue ;)

Regards,

Actions

This Discussion