URN_NOT_FOUND :urn "JRM" : not found!!

Answered Question
Oct 12th, 2008

Hi, Please help. We have a LMS2.6 with RME 4.0.5. When I launched Netconfig Jobs, this window appeared <Error occured while processing. Possible Cause:URN_NOT_FOUND :urn "JRM" : not found!!>

Thanks in advance.

I have this problem too.
0 votes
Correct Answer by Joe Clarke about 7 years 12 months ago

Shutdown Daemon Manager, and then try delete delete D:\PROGRA~1\CSCOpx\www\classpath\gatekeeper.ior as a local Administrator. If this works, try restarting Daemon Manager. If jrm still doesn't come up, try a reboot.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Joe Clarke Wed, 10/15/2008 - 20:34

Please post the jrm.log. Has the hostname of this LMS server been changed? Is this LMS server integrated with ACS?

jose.mendoza Wed, 10/15/2008 - 21:49

We haven't changed the hostname since it was built and it's not integrated with ACS. We installed IPM 2.6, but uninstalled it when we discovered the problem and related that it may have been the cause. Thanks.

Joe Clarke Wed, 10/15/2008 - 21:54

Check the permissions on D:\PROGRA~1\CSCOpx\www\classpath\gatekeeper.ior and D:\PROGRA~1\CSCOpx\www\classpath. Make sure casusers has full control over both this file and its parent directory. If the permissions are wrong, correct them, then restart Daemon Manager.

jose.mendoza Wed, 10/15/2008 - 22:15

Hi, How do I open the gatekeeper.ior file to check the permissions? What's the other file to check in D:\PROGRA~1\CSCOpx\www\classpath? Thanks.

Joe Clarke Thu, 10/16/2008 - 06:25

Right-click on the file and the directory, and select the Properties > Security. Make sure the casusers group has full control.

jose.mendoza Thu, 10/16/2008 - 13:16

Hi, the casuser had full control when I looked at permissions but is not an owner when I looked at Advanced. Do I need to make it an owner as well? How do I restart the daemon manager? Thanks.

Joe Clarke Thu, 10/16/2008 - 14:18

Casuser should be the owner of this file, and the casusers group should have full control. If casuser is not the owner, set casuser to be the owner, and check your Services control panel. Make sure the Daemon Manager, TFTP, RSH/RCP, and syslog CiscoWorks services are the only CiscoWorks services to be started automatically. The rest MUST be started manually. If any service is not set correctly, fix its startup type, then reboot.

To restart Daemon Manager run:

net stop crmdmgtd

net start crmdmgtd

jose.mendoza Thu, 10/16/2008 - 19:41

Hi, I stop and start CiscoWorks Daemon Manager using ...Control Panel>Services and a Services window appeared with this message-- "Could not stop the CiscoWorks Daemon Manager Service of Local Computer. Error 1053: The service did not respond to the start or control request in a timely fashion." The status column was blank and I had to press the start button to have the word start back on the status column. Thanks.

Joe Clarke Thu, 10/16/2008 - 20:10

You can't stop Daemon Manager from the control panel. You need to stop is from the command line using the command I already mentioned. This command can be run from any directory.

jose.mendoza Fri, 10/17/2008 - 11:35

Hi, I did the stop and start from command line and still received the error when I went to netconfig. I noticed that in gatekeeper.ior, it was casusers, I changed it to casuser and repeated the procedure but still got the error. I attached pdshow and jrm logs, shpould this help. Thanks.

Joe Clarke Fri, 10/17/2008 - 12:17

The error still points to an access problem on D:\PROGRA~1\CSCOpx\www\classpath\gatekeeper.ior. What do you service startup parameters look like?

jose.mendoza Fri, 10/17/2008 - 19:55

Hi, The startup parameters looks the same as what you've indicated in the earlier posts. But I've attached a screenshot of the services window so that you may have a better look. Thanks.

Joe Clarke Fri, 10/17/2008 - 20:16

Check the permissions on the directories up to D:\. For all directories under D:\PROGRA~1\CSCOpx, the permissions should grant the casusers group full control. For D:\PROGRA~1, the Users group should have Read & Execute, List Folder Contents, and Read. For D:\, Everyone should have Read & Execute.

jose.mendoza Fri, 10/17/2008 - 22:27

Hi, The permissions are what you indicated except for D:\. In D:\PROGRA~1\CSCOpx, Casusers group has full control together with the Administrators. In D:\PROGRA~1, Casusers and Administrators have full control and Everyone has Read and Execute. However, in D:\, Everyone has full control but casusers and Administrators are not in the list of permissions. Thanks.

Joe Clarke Sat, 10/18/2008 - 08:14

While this would not be an ideal solution, try adding casuser to the Administrators group on this server, then restart Daemon Manager. See if jrm will come up.

jose.mendoza Sat, 10/18/2008 - 13:54

Hi, Unfortunately, jrm still did not come up. The jrm.log is still saying that access is denied. Thanks.

Correct Answer
Joe Clarke Sun, 10/19/2008 - 16:10

Shutdown Daemon Manager, and then try delete delete D:\PROGRA~1\CSCOpx\www\classpath\gatekeeper.ior as a local Administrator. If this works, try restarting Daemon Manager. If jrm still doesn't come up, try a reboot.

jose.mendoza Mon, 10/20/2008 - 19:45

Hi, is it ok if I use a domain account with admin rights? Or do I need to use the account when CW was being built? Thanks.

Joe Clarke Mon, 10/20/2008 - 20:07

You must use a LOCAL Administrator account to install and administer LMS.


This Discussion