MGCP E1 PRI CM 6.1

Answered Question
Oct 13th, 2008

Hi Guys,

I have CM 6.1 connected to a gateway with MGCP enabled.

The problem is that the E1 port is not registering. I looped back the E1 using a physical connector.

the show mgcp is up, the show ccm-manager is registered and the show mgcp endpoints are showing.

I have this problem too.
0 votes
Correct Answer by allan.thomas about 8 years 1 month ago

Certainly is self explanatory, the question why are the controllers showing as 1/0 and 1/1?

When you specified the card type did you reload gateway as this is recommended.

Also whilst validating the IOS the The current IOS certainly support the NM-HDV2, the software advisor also indicates that the VWIC2 is not supported?

There were no open caveats which I could identify in relation to the symptoms that you are seeing.

Can you possibly try configuring one of the slots in CUCM with a VWIC-2MFT-E1 instead of VWIC2? Does endpoint identifier change to 1/0?

Rgds

Allan.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
allan.thomas Mon, 10/13/2008 - 02:31

Three aspects which you can initially check:-

First verify that the pri-group under the controller is configured with service mgcp, and secondly verify that the command 'isdn bind-l3 ccm-manager is under the Serial interface.

The commands should have been automically configured when you entered ccm-manager config.

If the later is not the case run 'no ccm-manager config' and then add it back, does this resolve the issue?

Please can you confirm the hostname of your gateway, and also whether you have additionally specified a ip domain-name ???.

For example if your gateway hostname is VG1 and ip domain-name is domain.com, then your MGCP domain name should be VG1.domain.com and this should be the name you have configured for your MGCP endpoint in CCM.

If you have configured an IP address, then ensure that CCM is able to resolve VG1.domain.com.

If this still fail to resolve your issue trying re-initialising mgcp by removeing it and then re-applying 'no mgcp' then 'mgcp'

After the above, please can you post the outout from a show ccm-manager.

HTH.

Rgds

Allan.

Nicolas Mansour Mon, 10/13/2008 - 03:56

Hi Allan,

I tried what you mentioned above.

I saw the port registered for but i refreshed again it unregistered again.

Here is the show ccm-manager: the Pub is the 11, Sub 12

(Thanks in advance.)

MGCP Domain Name: VG-Vivacell-CM

Priority Status Host

============================================================

Primary Registered X.X.X.12

First Backup Backup Ready X.X.X.11

Second Backup None

Current active Call Manager: X.X.X.12

Backhaul/Redundant link port: 2428

Failover Interval: 30 seconds

Keepalive Interval: 15 seconds

Last keepalive sent: 11:52:54 UTC Oct 13 2008 (elapsed time: 00:00:27)

Last MGCP traffic time: 11:53:07 UTC Oct 13 2008 (elapsed time: 00:00:14)

Last failover time: 11:44:57 UTC Oct 13 2008 from (X.X.X.12)

Last switchback time: 11:45:42 UTC Oct 13 2008 from (X.X.X.11)

Switchback mode: Graceful

MGCP Fallback mode: Enabled/OFF

Last MGCP Fallback start time: None

Last MGCP Fallback end time: None

MGCP Download Tones: Disabled

TFTP retry count to shut Ports: 2

Backhaul Link info:

Link Protocol: TCP

Remote Port Number: 2428

Remote IP Address: X.X.X.12

Current Link State: OPEN

Statistics:

Packets recvd: 2

Recv failures: 0

Packets xmitted: 2

Xmit failures: 0

PRI Ports being backhauled:

Slot 1, port 0

Configuration Auto-Download Information

=======================================

No configurations downloaded

Current state: Waiting for commands

Configuration Download statistics:

Download Attempted : 2

Download Successful : 2

Download Failed : 0

TFTP Download Failed : 0

Configuration Attempted : 1

Configuration Successful : 0

Configuration Failed(Parsing): 0

Configuration Failed(config) : 1

Last config download command:

Configuration Error History:

controller E1 1/0/0

no shut

controller E1 1/0/0

linecode hdb3

controller E1 1/0/0

no pri-group timeslots 1-31

controller E1 1/0/0

shut

FAX mode: cisco

allan.thomas Mon, 10/13/2008 - 04:24

Verify IP connectivity from your gateway to both Primary and Backup CallManager, the output from show ccm-manager suggests that the endpoint was unable to communicate with the Primary.

The gateway un-registering can be attributed to a number of reasons, and depends on how you have deployed the MGCP gateway. For example, is the MGCP gateway within a remote branch providing local PSTN breakout or is it within central office? Thus QoS will be a pre-requisite in order to guarantee Signalling?

I have noticed that there is a failed configuration, this could be due to an incorrect source-address being used on the gateway for TFTP.

Can you post the configuration of the gateway.

Thanks

Allan.

Nicolas Mansour Mon, 10/13/2008 - 07:26

Hi ,

They are in the same site and the same VLAN and subnet. Connectivity is good.

Here is the show mgcp stat, there are a lot of failed attempts here in the AuditEndpoint :

RTR#show mgcp statistics

UDP pkts rx 2122, tx 2161

Unrecognized rx pkts 0, MGCP message parsing errors 0

Duplicate MGCP ack tx 0, Invalid versions count 0

CreateConn rx 0, successful 0, failed 0

DeleteConn rx 0, successful 0, failed 0

ModifyConn rx 0, successful 0, failed 0

DeleteConn tx 0, successful 0, failed 0

NotifyRequest rx 0, successful 0, failed 0

AuditConnection rx 0, successful 0, failed 0

AuditEndpoint rx 753, successful 0, failed 753

RestartInProgress tx 30, successful 30, failed 0

Notify tx 1342, successful 1342, failed 0

ACK tx 0, NACK tx 753

ACK rx 1367, NACK rx 2

IP address based Call Agents statistics:

IP address X.X.X.11, Total msg rx 70,

successful 7, failed 63

IP address X.X.X.12, Total msg rx 863,

successful 772, failed 91

System resource check is DISABLED. No available statistic

DS0 Resource Statistics

-----------------------

Utilization: 0.00 percent

Total channels: 60

Addressable channels: 0

Inuse channels: 0

Disabled channels: 60

Free channels: 0

allan.thomas Mon, 10/13/2008 - 07:58

Can you provide the configuration? I would like to establish what configuration has been auto-generated or downloaded specifically under the controller(s)

I noticed from the output that there are 60 disabled channels? If you run a 'show voice port summary' does show the number of ports you would expect?

If there are insufficient timeslot configured, or there is none at all, there there no DSPs available.

Thanks

Allan.

Nicolas Mansour Mon, 10/13/2008 - 08:07

Hi Allan,

Here is the output of the port summary and the config (i.e.: the voice port for the first E1 is being shut by itself)

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname VG-Vivacell-CM

!

boot-start-marker

boot-end-marker

!

card type e1 1 1

card type e1 2 1

!

no aaa new-model

network-clock-participate slot 1

network-clock-participate slot 2

ip cef

!

!

!

!

no ip domain lookup

isdn switch-type primary-net5

voice-card 0

no dspfarm

!

voice-card 1

no dspfarm

!

voice-card 2

no dspfarm

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

--More-- !

controller E1 1/0

pri-group timeslots 1-31 service mgcp

!

controller E1 1/1

pri-group timeslots 1-31 service mgcp

!

controller E1 2/0

!

controller E1 2/1

!

!

!

!

interface GigabitEthernet0/0

ip address X.X.X.10 255.255.255.0

duplex auto

speed auto

media-type rj45

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

media-type rj45

!

interface Serial1/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

interface Serial1/1:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 X.X.X.254

!

!

ip http server

no ip http secure-server

!

!

--More-- !

!

control-plane

!

!

!

voice-port 1/0:15

shutdown

!

voice-port 1/1:15

!

ccm-manager fallback-mgcp

ccm-manager redundant-host X.X.X.11

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server X.X.X.12

ccm-manager config

!

mgcp

mgcp call-agent X.X.X.12 2427 service-type mgcp version 0.1

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface GigabitEthernet0/0

mgcp bind media source-interface GigabitEthernet0/0

!

mgcp profile default

!

!

!

dial-peer voice 9 pots

service mgcp

direct-inward-dial

port 1/0:15

!

dial-peer voice 10 pots

service mgcp

direct-inward-dial

port 1/1:15

!

!

!

--More-- line con 0

password cisco

login

line aux 0

password cisco

login

line vty 0 4

password cisco

login

!

scheduler allocate 20000 1000

!

end

allan.thomas Mon, 10/13/2008 - 08:21

Firstly can you verify that the endpoint device name in CUCM is exactly 'VG-Vivacell-CM' with no domain suffix.

Also remove both your post dial-peers 9 and 10, these are not required as the serial interface is already bound to CallManager with 'isdn bind-l3 ccm-manager'.

Which incidentally I noticed is missing from Serial1/1:15, this command is auto-generated by ccm-manager config, exactly how it appear of serial1/0:15.

Also is it possible to fix the speed and duplex on the gigabit interface? Are there errors on the port?

Once you have made the changes can initiate a 'no ccm-manager config' and then 'ccm-manager config'. Then restart MGCP, 'no mgcp' and then 'mgcp' as before.

Allan.

Nicolas Mansour Mon, 10/13/2008 - 08:34

Hi Allan,

I did that but no luck.

The "'isdn bind-l3 ccm-manager" was no generated by CM, I entered it myself.

allan.thomas Mon, 10/13/2008 - 08:55

When you added the command manually on the serial interfaces does the gateway endpoint then register with CUCM?

Please post the 'show ccm-manager'.

Can also capture the following debug 'debug ccm conf eve'. Remove the 'ccm-manager config' command and then enable the debug. After the debug is enable re-apply the the 'ccm-manager config' command.

The debug should provide a clearer picture as to what is happening when the config is downloaded.

Allan.

Nicolas Mansour Mon, 10/13/2008 - 08:56

Hi Allan,

I did that but no luck.

The "'isdn bind-l3 ccm-manager" was no generated by CM, I entered it myself.

allan.thomas Mon, 10/13/2008 - 09:17

It would appear from the debug that the issue is that CUCM is try to configure the incorrect controller?

According to the running-config both your E1 controller are in 1/0 and 2/0, whereas CUCM is attempting to configure 1/0/0 and 2/0/0?

Can provide a 'show inv', I assume you are using dual VIC2-MFTE1 modules? Either way, have you correctly specified the modules for the Gateway endpoints in CUCM?

Can you also post screen shot of the gateway config detailing the module configuration.

Allan.

allan.thomas Mon, 10/13/2008 - 09:37

Can you advise what CUCM version you are running, the 'sh ver' from the gateway, and if possible capture the screen shot of the gateway device again, so that is displays the top of screen and the slots?

Allan.

allan.thomas Tue, 10/14/2008 - 00:16

Further to my previous post, this information will assist in whether you are running into an IOS or CUCM compatibility issue. Which is what it would appear as CUCM is trying to configure a slot that does not exist.

Also for your information the NM-HDV2 when the configured for E1 it is possible that the E1 controllers may not come up properly when connected to reliable E1 circuits.

The output of the show controllers E1 command can indicate large accumulations of Line Code Violations (LCVs) and Path Code Violations (PCVs). The problem can be the result of how the E1 line has been provisioned by the Telco; specifically whether Wet Current is provided or not. On the NM-HDV2 product there are two jumper blocks which control whether the onboard T1/E1 controllers support Wet Current or not. These jumpers are identified on the Printed Circuit Board (PCB) of the Network Module as J6 and J7 (see photograph). J6 is the jumper block for onboard controller 1 while J7 is the jumper block for onboard controller 0. The pin count for each jumper block is from 1 to 3. Pin 1 is the rightmost pin and Pin 3 is the leftmost pin. When Pins 1 and 2 are short-circuited (Right Jumper Setting) the onboard controller is set for "Wet Current Mode", and when Pins 2 and 3 are short-circuited (Left Jumper Setting) the onboard controller is set for "Normal Mode". Early production NM-HDV2s shipped with the jumper blocks set to expect Wet Current to be supplied by the Telco, and this causes problems for some E1 users. When you move the setting to Normal Mode, it typically clears up the problem. Current production NM-HDV2s now ship with the jumper blocks set for Normal Mode.

Please refer to the following URL:-

http://www.cisco.com/en/US/tech/tk652/tk653/technologies_tech_note09186a008039c333.shtml

Rgds

Allan

allan.thomas Tue, 10/14/2008 - 03:15

Can you post the screen shot when you open the drop down option for selecting the sub-unit on the gateway configuration.

I would like to verify what module options are available for selection, and confirm that correct one is selected.

Rgds

Allan.

allan.thomas Tue, 10/14/2008 - 04:30

Under the card type e1 1 1 command on the gateway, do you other options after specifying card type e1 1 ?

When you specify the card type it creates the E1 controllers accordingly, and within CUCM the endpoints have been added as 1/0/0 and 1/0/1 which do not correspond to gateway configuration.

Unfortunately all the NM-HDV2 documentation and specifications do not list the VWIC2 as a supported module? I suspect that the documentation has not been updated to reflect that it does, else why would you have the option to select it.

I believe the issue is probably due to the incorrect card type being set, thus the controllers have been inappropriate set.

Rgds

Allan.

Nicolas Mansour Tue, 10/14/2008 - 04:36

Hi Allan,

Here is the available config under the card:

VG-Vivacell-CM(config)#card type e1 ?

<0-4> Card slot number (always 0 for 1800 series & 2801 routers)

VG-Vivacell-CM(config)#card type e1 1 ?

<0-1> WIC slot number (0:WIC, 1:Onboard for NM-HDV2)

Correct Answer
allan.thomas Tue, 10/14/2008 - 05:02

Certainly is self explanatory, the question why are the controllers showing as 1/0 and 1/1?

When you specified the card type did you reload gateway as this is recommended.

Also whilst validating the IOS the The current IOS certainly support the NM-HDV2, the software advisor also indicates that the VWIC2 is not supported?

There were no open caveats which I could identify in relation to the symptoms that you are seeing.

Can you possibly try configuring one of the slots in CUCM with a VWIC-2MFT-E1 instead of VWIC2? Does endpoint identifier change to 1/0?

Rgds

Allan.

Nicolas Mansour Tue, 10/14/2008 - 05:22

Well your right it turned out that i should have selected the second "subunit 1" which clearly states NM-HV2-ONBOARD-E1. After that the ports registered quickly. Thank you for all your efforts.

Can you guide me to a document that compares the MGCP "isdn bind-l3 ccm-manager" method with the other one with the dial-peers ?

Tommer Catlin Fri, 11/14/2008 - 12:54

I may have the same issue. I have a 3825 with 4 VWIC2-2MFT-T1/E1

The only option I get on CUCM screen for MGCP on this router is NM-4VIWC-MBRD.

So what you are saying I should be using the VWIC cards, not the VWIC2 cards? Or ?

Thanks!

allan.thomas Fri, 11/14/2008 - 13:20

Hi Tommer,

The previous problem was that the incorrect module was selected for the particular slot, the NM-HV has onboard E1 which I can only assume is a vwic not vwic2 as the documentation does not list vwic2 as a supported module.

When you select the NM-4VWIC-MBRD and then update, you should then see sub-slot drop down options, here you should be able to select the VWIC2-2MFT-T1/E1 modules.

Hope this helps.

Allan.

Pls rate helpful posts.

Actions

This Discussion