Switchport problem

Unanswered Question

Hi, I am trying to make 1 port,part of vlan230.its a 3750 switch.when i am adding switchport access vlan 230 it is thowing me with this error "Command rejected: Gi3/0/21 not a switching port".

I did a no sw,once again did a sw and tried doing it but still the same error. tried shut,no shut but still the same.also tried waiting some time after i issue a no sw command.then i issued sw command to make it a l2 port.Then again i tried ading this port in vlan 230 but still the same error.any help will be appriciated?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
smothuku Mon, 10/13/2008 - 04:20

Hi ,

Have you created Vlan 230 on 3750 switch with the help of

config )# vlan 230

after that

config)# int g3/0/21

config-if )# switchport

switchport mode access

switchport access vlan 230

Make sure that no ip address is configured for G3/0/21 interface and it must be a switchport to assign vlan to that particular port.

if it not working and switch is not in production reboot the switch once...



Calin Chiorean Tue, 10/14/2008 - 02:42


This switch is part of a stack or how come you have there gi3/x/y?

Can you do a "show version" and "show switch" and paste the output here?




Giuseppe Larosa Tue, 10/14/2008 - 20:58

Hello Raja,

I would verify if the port is not involved in any span session.

to check this do

show monitor session all

if so use another port or change the monitor session config

Hope to help


allan.thomas Tue, 10/14/2008 - 12:44

Further to the good information provided by Satish, making the port a dedicated switchport should stop you received the error about that it is not a switchingport.

Have you tried another switchport on the same switch? You mentioned that you were able to configure it successfully on another 3750, are these running the same IOS?

Initially try configuring another port on the same switch to see if it takes the config.



graemeporter Wed, 10/15/2008 - 01:24

Also, can you type

"show run interface GigabitEthernet 3/0/21"


"show interface GigabitEthernet 3/0/21"

and paste the output here, so we can see how the port is configured, and what the status of the port is?

Kind regards


chris.williamsEP Wed, 10/15/2008 - 07:07

You may also want to make sure that the port wasn't inadvertently added to an EtherChannel previously. This can be verified by issuing the command:

sho etherchannel summary

You would also see a channel-group interface configuration command under the interface configuration. If the port has been added to an etherchannel, the Port Channel interface command will override anything issued diectly to the interface itself.


Dear All,


sorry for late reply ,I was messed up with an accident,but back to ok by god's grace.

The o/p req from you al is attached. I still cant get through this.I did this with another port on the same switch and it work out perfectly.

appriciate all suggestions in this regards.is there anything else that can be look into?this seems kinda a weird prob?has someone encountered this before?

allan.thomas Fri, 10/17/2008 - 09:58

What is perculiar about the output of 'show int GigabitEthernet 3/0/21 is that output shows the status of GigabitEthernet 3/0/29?

I would strongly suggest a reset of this switch in the stack to see if it clears the problem.

Configuring the port as a switchport as you have mentioned in earlier post should have worked, but clearly there is an underlying issue with this port:-

Cisco-123-AS-002#sh int gigabitEthernet 3/0/21

GigabitEthernet3/0/29 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet, address is 001b.2aee.c495 (bia 001b.2aee.c495)

MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec.



Richard Postmus Fri, 10/17/2008 - 10:14

1) you said you did a shut/no-shut, but did you try changing the config while in shut mode?

2) assuming interface 3/0/21 is actually up -please post that output. And, if it is up, what is it connected to? Another switch, router, node? does the node do trunking?

3) h/w problem ?

Dear Allan,

Definately the switch seems to be behaving abnormal,i didnt read the o/p properly.I powered off the switch.after about 10 mins ( as there were no users online for this time being) i did a start.i was sucessful !!!but where lies the problem??still a question ?also can some you brief me for cascading/stacking/span?(Any links)

Thanks all for your efforts put in.


allan.thomas Sat, 10/18/2008 - 08:17

The underlying issue could be attributed to a known defect within the IOS? Confirm what IOS is currently running against what is available.

I assume that your switches/stacks are running the same IOS, if they are then have you experience similar issues with these?

If this is not the case, then this could be an isolated issue, monitor the situation as see if it re-occurs. If you have come across this problem before then I suspect you are looking at IOS defect. Check the version of IOS you are running against the what is available?

Essentially the concept of switch stacks for either Cisco or Nortel in the sense that both aggregrate switches to provide a single management entity and highly resilient system.

Both solutions are fully looped, so that a switch failure does not affect the integrity of the stack.

With Cisco C3750s it is possible to stack a maximum of 9 switches, with a 32Gbps interconnection.

With Nortel it is only possible to stack a maximum of 8 units in stack.

Below is a link about the creation and management of switch stacks on the C3750:-


This document link is the 3750 product guide at-a-glance:-


Information about Nortel 450t:-

You can connect up to eight BayStack 450 switches into a redundant stack

configuration. BayStack 450 switches use a fail-safe cascade stacking architecture

which, in the unlikely event of a switch failure, maintains the integrity of the

remaining stack: All signals are looped back at the point of failure. Because each

unit in the stack has a full copy of the stack configuration, operation of the stack

continues without affecting application connectivity.

Any mix of up to eight BayStack 450 switches and BayStack 410-24T switches

can be stacked to provide a total of 224 ports (when all MDA slots are configured

with the maximum port availability).

Installation instructions are provided with each BayStack 400-ST1 Cascade

Module (see Installing the BayStack 400-ST1 Cascade Module).

Nortel Cascade installation Information URL:-


Using the Nortel Baystack 450 Series switch guide:-


Hope you find this information useful.



Pls rate helpful posts..

Thanks Allan for clarifying about the issue and brefing about stacking and cascading.the link have the required knowledge to know about stackwise and cascading.

The available IOS is 12.2(25)SEB,the runnig one is 12.2(25)see2.i did not experience this kind of prob before.let see i wil monitor this for sometime as more new clients have to add up in this production switch within this week.Thankyou one's again




This Discussion