DID extension Dial Out Problem

Unanswered Question
Oct 13th, 2008

We are using Call Manager business Ed.6.1 , Cisco3845 E1PRI gateway and have 500 DID. The problem is when we dial from DID extension to outside PSTN users the extension number not displayed on the end user phone onlu the first number displayed for every call

DID 5000-5499, ext. 5200 calls to 3456780 pst number , the number displayed on the PSTN user phone is 5000 not 5200.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
allan.thomas Mon, 10/13/2008 - 05:08

Verify with your Telco that CLIP is enabled, if CLIP is not enabled that the default billing number for the circuit will advised in most cases.

Verify that your gateway endpoint does not have CLI presentation set to restricted. By default it is set to allowed.

Incidentally, have you configure an external phone mask on yur DNs?

If you have, then also verify that you have either set the use users external phone mask to ON within the route-list and in the particular route-group details or alternatively on the specific route-pattern?

If left to the system default within the route-list/group details, CUCM will use the route-pattern preference instead. The simplest option would be to change route-list/group details to ON.

Rgds

Allan.

jerome.lopez Mon, 10/13/2008 - 05:26

Thanks ,..

I have done this. In the Voice Gateway when i debug ISDN Q931 , Voice CCAPI out.

It is showing called number = 5200

calling number = 3654566

But when the call lands in End user it shows 5000 pilot number. Also in the debug information it says Transform number is blank

allan.thomas Mon, 10/13/2008 - 05:33

Incidentally, I initially assumed your gateway was MGCP, or are you are using H323?

If the later is the case, have you applied any outgoing voice translation rule to your POTs dial-peer.

Please post your configuration.

Thanks

Allan.

jerome.lopez Mon, 10/13/2008 - 05:44

ontroller E1 0/0/0

pri-group timeslots 1-31 service mgcp

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-4ess

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

control-plane

!

!

!

voice-port 0/0/0:15

!

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.190.10.2

ccm-manager config

!

mgcp

mgcp call-agent 10.190.10.2 2427 service-t

mgcp dtmf-relay voip codec all mode out-of

mgcp rtp unreachable timeout 1000 action n

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

!

!

dial-peer voice 1999 pots

service mgcpapp

incoming called-number 30705...

direct-inward-dial

port 0/0/0:15

!

dial-peer voice 1 voip

destination-pattern 5...

session target ipv4:10.190.10.2

codec g711alaw

jamieparr Mon, 10/13/2008 - 06:04

We have the same issue on some of our sites. Turned out to be our service provider

Actions

This Discussion