Cisco Network Assistant

Unanswered Question
Oct 13th, 2008
User Badges:

I installed and was able to use the Cisco Network Assistant. But when I setup the enable and vty passwords I get a dialog windows stating "Please enter your username and password for realm 'level_15_access' on xxx.xxx.xxx.xxx"


what username and password is it asking for? I know this is linked to setting up the enable and vty passwords but I can't figure out why.



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Jon Marshall Mon, 10/13/2008 - 10:20
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Cedric


If you haven't set up a local username then try


1) no username/password = enable secret password


2) username = cisco/password = enable secret password


Jon

jtphilies Wed, 10/22/2008 - 04:47
User Badges:

cedric, on the device your trying to access, you can,


config t

ip http server enable (to use the enable password to login


or


ip http server local (to use login of an account setup locally on the device)


then try to connect using CNA



svillardi Wed, 10/22/2008 - 07:44
User Badges:

I'm having the same issue. I am comparing the configs from 2 switches. One works with CNA, the other doesn't. Same model switch.


Goal: set up CNA using the same user/enable passwords as telnetting into the switch.


A few questions:


I looked at the vty settings for the working switch:

ip default-gateway 111.222.333.444

ip classless

ip http server

ip http secure-server


the non-working:

ip default-gateway 111.222.333.444

ip classless

ip http server

ip http authentication local


The working VTY:

ine con 0

stopbits 1

line vty 0 3

password 7 blahblahblah

login

length 0

line vty 4

password 7 blahblahblah

login

length 0

line vty 5 14

password 7 blahblahblah

login

transport input telnet

line vty 15

password 7 blahblahblah

login

transport input telnet


the NON working:

line con 0

line vty 0 4

password 7 blah

login

length 0

line vty 5 14

password 7 blah

login

line vty 15

password 7 moreblah

login

transport input telnet


I just configured the line vty 15 and where it says password, I had to use "password 0 enablepswd". With a "sh run", it gave me the above.


Shouldn't it work?? The other one does!


svillardi Wed, 10/22/2008 - 08:55
User Badges:

I'm having the same issue. I am comparing the configs from 2 switches. One works with CNA, the other doesn't. Same model switch.


Goal: set up CNA using the same user/enable passwords as telnetting into the switch.


A few questions:


I looked at the vty settings for the working switch:

ip default-gateway 111.222.333.444

ip classless

ip http server

ip http secure-server


the non-working:

ip default-gateway 111.222.333.444

ip classless

ip http server

ip http authentication local


The working VTY:

ine con 0

stopbits 1

line vty 0 3

password 7 blahblahblah

login

length 0

line vty 4

password 7 blahblahblah

login

length 0

line vty 5 14

password 7 blahblahblah

login

transport input telnet

line vty 15

password 7 blahblahblah

login

transport input telnet


the NON working:

line con 0

line vty 0 4

password 7 blah

login

length 0

line vty 5 14

password 7 blah

login

line vty 15

password 7 moreblah

login

transport input telnet


I just configured the line vty 15 and where it says password, I had to use "password 0 enablepswd". With a "sh run", it gave me the above.


Shouldn't it work?? The other one does!

MUHAMMAD SHAHEEN Wed, 10/22/2008 - 07:40
User Badges:
  • Silver, 250 points or more

Hi,


Use the username "en" and password whatever you have specified.


that should work


Hope this Helps

Shaheen

Pravin Phadte Wed, 10/22/2008 - 10:55
User Badges:
  • Silver, 250 points or more

hi,


Try removing the command. "ip http authentication local"


the non-working:

ip default-gateway 111.222.333.444

ip classless

ip http server

ip http authentication local


Also try to just provide the enable password without any username.


Hope this helps,


Regards,

Pravin

svillardi Wed, 10/22/2008 - 11:27
User Badges:

I think that's it! the ip http authentication local was the problem.

Pravin Phadte Wed, 10/22/2008 - 23:53
User Badges:
  • Silver, 250 points or more

Nice to know.


Please rate if helpful.


Regards,


Pravin

CSCO12577916 Wed, 11/12/2014 - 01:08
User Badges:

Resolve it by adding the below command ::::

(conf)# ip http authentication local

Actions

This Discussion