QOS Methods with mixed VOIP Phones

Unanswered Question
Oct 13th, 2008
User Badges:

We currently have several sites with mixed VOIP phones consisting of Siemens Hipath and Asterisk with Snom phones.


Our WAN's are all linked with Sprint MPLS with our routers being mostly Cisco 2821's wich then connect to 6500's using CEF 720's then 4500's for Access layer using ws-x4515 sup cards.


What would be the best method of implementing QOS in a mixed environment like this?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Marwan ALshawi Mon, 10/13/2008 - 15:39
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

in case like ur

its better to mark the phones traffic manuly on the access switches in ur case on the 4500 switches

creat a policy map with calss map that match voip traffic like


permit udp any any range 16384 32767


and set it as dscp ef


and u need to find out each vender call signaling ports to match as well for advanced qos


with cisco ip phones the call signaling can be matched like

permit tcp any any range 2000 2002


for voip lets make simple policy to mark the traffic


ip access-list extended voice

permit udp any any range 16384 32767


class-map match-all ipphon

match access-group name voice


policy-map voip

class ipphon

set ip dscp 46


now lets sat u will apply it to the range interfaces on the 4500


interface range fa 0/1 -22

service-policy input voip


on global config mode do on 4500

qos


to enable qos


on all uplinks between switches u need to trust ur dscp marking in oreder to make sur this marking will be kept end to end till reach ur router and there u can make policies for priority


on each ulink


qos trust dscp


this is in brief if u want any more details just post here


good luck

if helpful Rate

jonesm111 Tue, 10/14/2008 - 13:36
User Badges:

Thanks...


Seems SNOM (320) Phone default uses:


Call signalling - SIP protocol, UDP 5060?

Calls use? RTP 10000 - 20000

TOS Default value 160 (0x28)


Anyone know how to enable QOS globally on a 3560?


---Mike

jonesm111 Tue, 10/14/2008 - 14:44
User Badges:

Ok, I've tested this config out on a 3560, any feedback would be greatly appreciated...


I have Snom phones and an Asterisk server.


Access-list with Snom SIP & RTP (Can I use the same ACL for both?):

ip access-list extended voip-traff

permit udp any any range 5060 5061

permit udp any any range 10000 20000


class-map named ipphone & match acl voip-traff:

class-map match-all ipphone

match access-group name voip-traff


Policy map named voip, match class-map iphone:

policy-map voip

class ipphone

set dscp cs5


set interfaces to police policy-map voip:

interface-range gi 0/1 - 48

service-policy input voip


enable qos globally:

mls qos

Does this look like a good config and will this actually do a rewrite of TOS?


Thanks,


---Mike



Marwan ALshawi Tue, 10/14/2008 - 18:35
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

its ok but u need to add and change somthings

first add this command


mls qos map cos-dscp 0 8 16 24 32 46 48 56


it is help u if u use cos with dscp


now for ur class map make it match-any not match-all


class-map match-any ipphone

match access-group name voip-traff



try to use dscp ef or 46


and the above config will mark all sip and rtp traffic with the marking u put


good luck

if helpful Rate

jonesm111 Wed, 10/15/2008 - 11:20
User Badges:

My Snom Phones default is DSCP 40 and I would like to stay with that if possible. Does this mean my qos map should be;

mls qos map cos-dscp 0 8 16 24 32 40 46 48


Many thanks!

Marwan ALshawi Fri, 10/17/2008 - 15:50
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

as long as ur access switch is dscp aware and u will use dscp marking from the begining them u will not need this maping caommnd from cos to dscp

this one help when u trust or use cos on the access port then u go to dscp on the uplinks


and for ur case u can use the policy with set ip dscp

or as u stated above ur pohne is marking with dscp 40 and u happy with it

if u have only phone connected to the port without pc then u could use trust dscp on the port level

this way the port will use the dscp marked from the connected device this way u may dont need to creat policy for marking only


good luck

if helpful Rate

Actions

This Discussion