Etherchannel to HP Server from 6500 - Multiple Port-Channels?

Unanswered Question
Oct 13th, 2008
User Badges:

I created a port-channel on a HP server using LACP to a Cisco switch, and it seems to create two port channels, one of which the server uses, one of which it doesn't. This is the result of the show etherchannel 1 sum:

Group Port-channel Protocol Ports

------+-------------+-----------+-----------------------------------------------

1 Po1(SU) LACP Gi3/3(P) Gi4/3(P)

1 Po1A(SU) LACP Gi3/31(P) Gi3/32(P) Gi3/33(P)

Gi3/34(P)


The server is configured for 802.3ad, and it shows the two ports in Po1 as not being active, and the other four as being active. What would cause the 6500 to create the second port channel like that?


I used this for the configuration on the Cisco switch for all 4 ports:

channel-protocol lacp

channel-group 1 mode active


If it helps, I attached the show etherchannel 1 det.



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Calin Chiorean Tue, 10/14/2008 - 02:53
User Badges:
  • Silver, 250 points or more

Hi!


Can we see an output of

"show run int gi3/3"

"show run int gi3/31"

"show run int po1"


Thanks!


Calin

meballard Tue, 10/14/2008 - 15:07
User Badges:

Here it is:


gahmnb01-rt01#sh run int gi 3/3

Building configuration...


Current configuration : 248 bytes

!

interface GigabitEthernet3/3

description GISPW3BK01

switchport

switchport access vlan 233

switchport mode access

no cdp enable

channel-protocol lacp

channel-group 1 mode active

spanning-tree portfast

spanning-tree bpdufilter enable

end


gahmnb01-rt01#sh run int gi 3/31

Building configuration...


Current configuration : 249 bytes

!

interface GigabitEthernet3/31

description GISPW3BK01

switchport

switchport access vlan 233

switchport mode access

no cdp enable

channel-protocol lacp

channel-group 1 mode active

spanning-tree portfast

spanning-tree bpdufilter enable

end


gahmnb01-rt01#sh run int po1

Building configuration...


Current configuration : 95 bytes

!

interface Port-channel1

switchport

switchport access vlan 233

switchport mode access

end

steve_steele Tue, 10/14/2008 - 23:12
User Badges:
  • Bronze, 100 points or more

My guess on this is that LACP has negotiated 2 links because you have 6 configured on the 6500 and the HP server only supports up to 4 links in a single channel.


Check the driver specifications for the NIC's


You could try shutting down one of the currently active ports to check if one of the other ports turns active, which would suggest a 4 port maximum.


Hope this helps


Steve

meballard Wed, 10/15/2008 - 09:13
User Badges:

When I shut down one of the active NICs, either on the server or on the core, it does this:

Group Port-channel Protocol Ports

------+-------------+-----------+-----------------------------------------------

1 Po1(SU) LACP Gi3/3(P) Gi3/32(D) Gi4/3(P)

1 Po1A(SU) LACP Gi3/31(P) Gi3/33(P) Gi3/34(P)


I saw the same thing happen on another HP server that I created a port channel with only 3 NICs (with it creating two port channels, where the one with 2 was active, and the one with 1 wasn't).

Actions

This Discussion