Problem with CTMJrmServer process

Answered Question
Oct 13th, 2008
User Badges:

Hello,


I installed one month ago a LMS v3.0.1 and all goes fine during 2 weeks. Now I encounter an error with CTMJrmServer process.


Here is the CTMJrmServer.log :


CTMJrmServer: initializing daemon manager

CTMJrmServer: initialized daemon manager

[ Mon Oct 06 11:07:58 WAT 2008 ],INFO ,[main],com.cisco.nm.rmeng.util.logger.ServiceLogLevelChanger,notifyLevelChange,35,publishing urn for jrmw-log

[ Mon Oct 06 11:07:58 WAT 2008 ],INFO ,[main],com.cisco.nm.rmeng.util.logger.ServiceLogLevelChanger,notifyLevelChange,42,published urn as jrmw-log-RMELogLevelChange

[ Mon Oct 06 11:09:24 WAT 2008 ],FATAL,[main],com.cisco.nm.rmeng.jrmwrapper.server.JobManagerExt,getJRM,139,getJRM:Can't bind to JrmServiceManager. giving up and exiting.

[ Mon Oct 06 11:09:24 WAT 2008 ],ERROR,[main],com.cisco.nm.rmeng.jrmwrapper.server.CTMJobManagerServer,<init>,66,Null JRM. Exiting


I look at some topics related to CTMJrmServer but I haven't find a solution.

For info : I haven't change the server name. I look at registry but I don't see anything wrong.


Thanks for your help !


Florian

Correct Answer by Joe Clarke about 8 years 9 months ago

You have modified the service startup parameters. This has broken LMS. You must revert all CiscoWorks, DFM, and CWCS services EXCEPT CiscoWorks Daemon Manager, CWCS rsh, syslog, and tftp services to Manual, then reboot. After this, things should work again.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Tue, 10/14/2008 - 08:25
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Please post the output of the pdshow command.

flabarriere Tue, 10/14/2008 - 08:52
User Badges:

As you can see CTMJrmServer process is not running. I can't start it. Sometimes I have state "Waiting to initialize" and other time "Administrator has shut down this server"...


Thanks for your help.



Joe Clarke Tue, 10/14/2008 - 09:20
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Please send the output of the command:


pdreg -l CTMJrmServer


And the output of the DOS SET command.

Joe Clarke Tue, 10/14/2008 - 09:47
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Enable CTMJrmServer debugging under RME > Admin > System Preferences > Application Loglevel Settings, then try starting CTMJrmServer. Then post the CTMJrmServer.log.

Joe Clarke Tue, 10/21/2008 - 09:16
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Please post the jrm.log.

Joe Clarke Wed, 10/22/2008 - 08:58
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Please post the service startup parameters from the Services control panel.

Correct Answer
Joe Clarke Thu, 10/23/2008 - 08:28
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

You have modified the service startup parameters. This has broken LMS. You must revert all CiscoWorks, DFM, and CWCS services EXCEPT CiscoWorks Daemon Manager, CWCS rsh, syslog, and tftp services to Manual, then reboot. After this, things should work again.

Actions

This Discussion