Outgoing Call Problem

Unanswered Question
Oct 14th, 2008
User Badges:

Hi,


We are experiencing problems with outgoing calls thrue an H323 gateway and PRI in Canada.

The gateway is connected to a CallManager 6.1


When doing international calls, calls are ok, when i'm doing local calls I received an error "Ressource unavailable"

I don't things it's a DSP problem as it works for international call and I have 2 PVDM32.


Here is the q931 debug of an error call:


Oct 14 09:34:03.257: ISDN Se1/0:23 Q931: Applying typeplan for sw-type 0x5 is 0x

2 0x1, Calling num 4166440821

Oct 14 09:34:03.257: ISDN Se1/0:23 Q931: Sending SETUP callref = 0x01FA callID

= 0x8199 switch = primary-dms100 interface = User

Oct 14 09:34:03.261: ISDN Se1/0:23 Q931: TX -> SETUP pd = 8 callref = 0x01FA

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98397

Exclusive, Channel 23

Progress Ind i = 0x8183 - Origination address is non-ISDN

Calling Party Number i = 0x2181, '4166440821'

Plan:ISDN, Type:National

Called Party Number i = 0xA1, '4166237846'

Plan:ISDN, Type:National

Oct 14 09:34:03.409: ISDN Se1/0:23 Q931: RX <- CALL_PROC pd = 8 callref = 0x81F

A

Channel ID i = 0xA98397

Exclusive, Channel 23

Oct 14 09:34:04.357: ISDN Se1/0:23 Q931: RX <- ALERTING pd = 8 callref = 0x81FA


Progress Ind i = 0x8088 - In-band info or appropriate now available

Oct 14 09:34:16.505: ISDN Se1/0:23 Q931: TX -> DISCONNECT pd = 8 callref = 0x01

FA

Cause i = 0x80AF - Resource unavailable, unspecified

Oct 14 09:34:16.557: ISDN Se1/0:23 Q931: RX <- RELEASE pd = 8 callref = 0x81FA

Oct 14 09:34:16.557: ISDN Se1/0:23 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x

01FA



As the gateway is also a CME i tried registring the phone not the CUCM6 but to the gateway directly and like this it works :


Debug of a good call :



Oct 14 09:35:06.006: ISDN Se1/0:23 Q931: Applying typeplan for sw-type 0x5 is 0x

2 0x1, Calling num 4166440821

Oct 14 09:35:06.006: ISDN Se1/0:23 Q931: Sending SETUP callref = 0x01FB callID

= 0x819A switch = primary-dms100 interface = User

Oct 14 09:35:06.006: ISDN Se1/0:23 Q931: TX -> SETUP pd = 8 callref = 0x01FB

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98397

Exclusive, Channel 23

Progress Ind i = 0x8183 - Origination address is non-ISDN

ccmetoronto#

ccmetoronto#

ccmetoronto#

Calling Party Number i = 0x2180, '4166440821'

Plan:ISDN, Type:National

Called Party Number i = 0xA1, '4166237846'

Plan:ISDN, Type:National

Oct 14 09:35:06.158: ISDN Se1/0:23 Q931: RX <- CALL_PROC pd = 8 callref = 0x81F

B

Channel ID i = 0xA98397

Exclusive, Channel 23

Oct 14 09:35:07.058: ISDN Se1/0:23 Q931: RX <- ALERTING pd = 8 callref = 0x81FB


Progress Ind i = 0x8088 - In-band info or appropriate now available

Oct 14 09:35:10.642: ISDN Se1/0:23 Q931: TX -> DISCONNECT pd = 8 callref = 0x01

FB

Cause i = 0x8090 - Normal call clearing

Oct 14 09:35:10.706: ISDN Se1/0:23 Q931: RX <- RELEASE pd = 8 callref = 0x81FB

Oct 14 09:35:10.710: ISDN Se1/0:23 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x

01FB



Do you have an idea why outgoing calls are OK when phones and registred directly to the gateway and not when they are registred on the CUCM6.1.


Thanks for your help.


CUCM6.1 <---H323---> CME on 2821 <---PRI--->


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Marwan ALshawi Tue, 10/14/2008 - 04:35
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

do the phones have the correct CSS to make outside calls ?



ccr_cisco Tue, 10/14/2008 - 04:55
User Badges:

Yes, on the CUCM they are on the correct CSS.

On the gateway itself I don't have CSS.


Marwan ALshawi Tue, 10/14/2008 - 04:58
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

on the gateway setting page u dont need CSS for outbound calls but need it for incoming calls


ccr_cisco Tue, 10/14/2008 - 05:05
User Badges:

U right. but I don't think it's CSS problem, the call is well directed to the gateway and I see the call's going out to PRI but being disconnected after 5 seconds of call processing with the error :


Oct 14 09:34:16.505: ISDN Se1/0:23 Q931: TX -> DISCONNECT pd = 8 callref = 0x01

FA

Cause i = 0x80AF - Resource unavailable, unspecified



Actions

This Discussion