Ap's Registration Fails With "did not recieve config response"

Unanswered Question
Oct 14th, 2008

Greetings, we have been running a Cisco 2106 controller for awhile now, following a recent reboot two out of the four AP's failed to re-register with the following messages.

Translating "CISCO-LWAPP-CONTROLLER.****************.local"...domain server (172.29.255.25) [OK]

%LWAPP-3-CLIENTEVENTLOG: Did not get vendor specific options from DHCP.

%LWAPP-3-CLIENTEVENTLOG: Did not get log server settings from DHCP.

%SYS-6-LOGGINGHOST_STARTSTOP: Logging to host 255.255.255.255 started - CLI initiated

%LWAPP-3-CLIENTEVENTLOG: Performing DNS resolution for CISCO-LWAPP-CONTROLLER..****************.local

%LWAPP-3-CLIENTEVENTLOG: Controller address 172.29.255.5 obtained through DNS

%LWAPP-5-CHANGED: LWAPP changed state to JOINEncoding the APType as 0

Encoding the RSSI threshhold as 0

Encoding the APType as 0

Encoding the RSSI threshhold as 0

%LWAPP-5-CHANGED: LWAPP changed state to CFG

Writing out the event log to nvram...

%LWAPP-3-CLIENTERRORLOG: Config Request Timer: did not recieve config response (controller - it-wlc-2106)

%SYS-5-RELOAD: Reload requested by LWAPP CLIENT. Reload Reason: DID NOT GET CONFIG RESPONSE.

%LWAPP-5-CHANGED: LWAPP changed state to DOWNXmodem file system is available.

flashfs[0]: 11 files, 3 directories

flashfs[0]: 0 orphaned files, 0 orphaned directories

flashfs[0]: Total bytes: 15998976

flashfs[0]: Bytes used: 7049728

flashfs[0]: Bytes available: 8949248

flashfs[0]: flashfs fsck took 30 seconds.

Base ethernet MAC Address: 00:1e:7a:be:63:60

Initializing ethernet port 0...

Reset ethernet port 0...

Reset done!

ethernet link up, 100 mbps, full-duplex

Ethernet port 0 initialized: link is up

The AP manager interface on the controller is 172.29.255.6 and the management interface is on 172.29.255.5, could anyone shed any light on what may be the problem, i have tried to hard reset the AP's with no effect.

Regards

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
CFayNTAdmin83 Tue, 10/14/2008 - 11:47

Hello. Please tell us what model of AP's you are trying to get connected to the WLC. Have you tried a TFTP recovery for the AP to see if it will join after that? I've noticed that sometimes if an AP loses connection with a controller and gets interrupted while downloading an image, it gets corrputed and needs to have the recovery image loaded in order to get it to register again.

exonetinf1nity Wed, 10/15/2008 - 04:01

Thank you for your response they are 1131AG Lightweight Access points, i haven't yet tried the recovery image, can this be done with Lightweight Ap's?

Regards

CFayNTAdmin83 Wed, 10/15/2008 - 04:29

Oh no problem. I usually work with the 1200 series access points in lightweight mode. So, if a converted ap has a major problem and cannot join after reboots, I load the autonomous IOS image onto it and then use the LWAPP upgrade utility to get it into lightweight mode again. There actually was a recent post regarding 1130's and autonomous mode ios. I guess someone was able to load an autonomous image onto it. If that's the case then you could definitely use the utility to reload the LWAPP image. However, I'm thinking that there has got to be a flash restore mode for that AP. It's probably similar to the 1300's, where you use TFTP. I'll check into the recovery process for the 1130's and let you know what I find.

CFayNTAdmin83 Wed, 10/15/2008 - 04:36

Hi, I found a post from another person regarding the TFTP recovery on an 1131AG. I would try that and also make sure you have the CISCO-LWAPP-CONTROLLER static DNS entry set to the management (login) ip address of your WLC...

"Posted by: jaichauh - Network Engineer, CISCO SYSTEMS - Oct 1, 2008, 1:06pm PST

Yes,

You need to downlaod an IOS autonomous image and then upgrade it by using the following steps:

Step 1 The static IP address of the PC on which your TFTP server software runs should be between 10.0.0.2 and 10.0.0.30, as AP gets an IP of 10.0.0.1 after reset by default.

Step 2 Make sure that the PC contains the access point image file (such as c1130-k9w7-tar.124-3g.JA1.tar for an 1130 series access point) in the TFTP server folder (Root folder) and that the TFTP server is activated.

Step 3 Rename the access point image file in the TFTP server folder to c1130-k9w7-tar.default.

Step 5 Connect the PC to the access point using a Category 5 (CAT5) Ethernet cable.

Step 6 Disconnect power from the access point.

Step 7 Press and hold MODE while you reconnect power to the access point.

Step 8 Hold the MODE button until the status LED turns red (approximately 20 to 30 seconds) and then release.

Step 9 Wait until the access point reboots, as indicated by all LEDs turning green followed by the Status LED blinking green.

Step 10 After the access point reboots, reconfigure it using the GUI or the CLI.

HTH

-Jai"

exonetinf1nity Wed, 10/15/2008 - 04:39

Thank you once again, will i be able to apply the autonomous image to an AP that was shipped as a Lightweight AP?

I would imagine that if this is possible i would then have to upgrade the image a second time to a lightweight image?

Regards

Scott Fella Wed, 10/15/2008 - 04:46

You can convert a LAP to autonomous. Just follow the instructions on the previous post. To convert the ap back to lwapp, you can use the upgrade tool, but I think since you have the rcv image still in the flash, you might be able to just hold the mode button for 20 seconds and release that. that has worked for me in the past with 1252's.

Also, are your ap's connected to 2106 or to the network switch?

exonetinf1nity Wed, 10/15/2008 - 05:29

Cheers for that, there is a recovery image in flash that is loaded after using the mode key also the Aps are connected to a 2960 switch. The controller itself has three interfaces configured.

Data, The Management Interface and The AP Manager are on the same vlan and physical interface on the controller, voice is on a seperate wlan, interface and vlan and guest access is on a third physical controller interface with its own wlan and vlan.

Regards

Scott Fella Wed, 10/15/2008 - 05:35

All the ports that you connect to the 2960 needs to be a dot1q trunk and also you need to only allow the vlans for that port. If you setup the switch ports as trunk and you don't prune the vlans, you will get errors on the switch.... this can cause your issue.

exonetinf1nity Wed, 10/15/2008 - 08:41

Thank you for the help people, ive since discovered the following errors relating too the two Ap's that are failing to register.

The Ap's register with the controller then the second message is generated stating that the regulatory domain/country code is incorrect, i have no idea how this happened. All four Ap's were purchased with the "E" designation and the country code on the controller is set to "GB".

If somehow the two Ap's which are failing to register had there country code changed when they were registered previously could this cause the issue even after they have been reset using the mode key?

0 Wed Oct 15 16:35:51 2008 AP Associated. Base Radio MAC: 00:1d:e5:55:df:1a

1 Wed Oct 15 16:35:26 2008 AP Associated. Base Radio MAC: 00:1e:7a:be:63:60

Oct 15 16:35:53.306 spam_lrad.c:2123 LWAPP-3-RD_ERR4: Invalid regulatory domain 802.11bg:-E 802.11a:-E for AP 00:1d:e5:55:df:1a

Previous message occurred 2 times.

Oct 15 16:35:53.305 spam_lrad.c:7715 LWAPP-3-RD_ERR7: Invalid country code () for AP 00:1d:e5:55:df:1a

Oct 15 16:35:53.304 spam_lrad.c:7715 LWAPP-3-RD_ERR7: Invalid country code () for AP 00:1d:e5:55:df:1a

Oct 15 16:35:27.545 spam_lrad.c:2123 LWAPP-3-RD_ERR4: Invalid regulatory domain 802.11bg:-E 802.11a:-E for AP 00:1e:7a:be:63:60

Previous message occurred 2 times.

Oct 15 16:35:27.544 spam_lrad.c:7715 LWAPP-3-RD_ERR7: Invalid country code () for AP 00:1e:7a:be:63:60

Oct 15 16:35:27.543 spam_lrad.c:7715 LWAPP-3-RD_ERR7: Invalid country code () for AP 00:1e:7a:be:63:60

Regards.

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode