Keep alive on physical interface

Unanswered Question
Oct 14th, 2008
User Badges:

1. Please does keep alife work on physical inteface. I have two links to branch router, I notice if I pass the static routes through physical interface,the links wont fail over,but if I use tunnel,they will.

2.what command can i use to know when last a router was modified.

3. Will GLBP work on links from two service providers on a single route.

4.can i do load balancing without running dynamic routing.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Istvan_Rabai Tue, 10/14/2008 - 09:45
User Badges:
  • Gold, 750 points or more

Hi Just,


1. Yes, on physical interfaces you can configure keepalive with the "keepalive" command (how interesting:).

Please check if your interfaces are configured with the "no keepalive" commands.


2. "show running-config" will show you the date when the config was last modified in one of its first rows of output.


3. GLBP is designed for load balancing. It will load balance traffic from the hosts to the default gateways and traffic on the ISP facing interfaces, if 2 (or more) routers connect to different ISPs for example.

GLBP will not do load balancing on a single router when this router is connected to 2 different ISPs, or even with 2 links to the same branch router.


4. Yes, GLBP should work when static routes are configured on the routers.


Cheers:

Istvan


Just Kennie Tue, 10/14/2008 - 10:00
User Badges:

Thanks so much, but i am having problems.

1. i cant see the time the last config was done fron show run.

2.you dont get my number 4 question,what i am saying is can i make traffic pass though two ISP when i am using static routing.

cpubob Tue, 10/14/2008 - 10:01
User Badges:
  • Bronze, 100 points or more

Check this feature out.


http://www.cisco.com/en/US/docs/ios/12_3/12_3x/12_3xe/feature/guide/dbackupx.html



You can do load-balancing with just static routes. I am assuming that your using cef switching. By default, cef does per-destination load balancing over equal paths.


On my router I did the following:


ip route 1.1.1.1 255.255.255.255 null0

ip route 1.1.1.2 255.255.255.255 null0

ip route 222.2.2.0 255.255.255.0 1.1.1.1

ip route 222.2.2.0 255.255.255.0 1.1.1.2


Rack1R1#sh ip route

1.0.0.0/32 is subnetted, 2 subnets

S 1.1.1.1 is directly connected, Null0

S 1.1.1.2 is directly connected, Null0

222.2.2.0/32 is subnetted, 1 subnets

S 222.2.2.0 [1/0] via 1.1.1.2

[1/0] via 1.1.1.1

Rack1R1#

Rack1R1#sh ip cef 222.2.2.0 detail

222.2.2.0/24, epoch 0, per-destination sharing

recursive via 1.1.1.1

attached to Null0

recursive via 1.1.1.2

attached to Null0

Rack1R1#


cpubob Tue, 10/14/2008 - 10:09
User Badges:
  • Bronze, 100 points or more

You have to set the clock first. Then the timestamps will show up.


Would you like to enter the initial configuration dialog? [yes/no]:

% Please answer 'yes' or 'no'.

Would you like to enter the initial configuration dialog? [yes/no]: no



Press RETURN to get started!


Router>

Router>

Router>

Router>en

Router#sh run

Building configuration...


Current configuration : 667 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

Router#sh clock

*00:11:02.766 UTC Fri Mar 1 2002

Router#clock set 13:22:00 14 Oct 2008

Router#wr mem

*Oct 14 13:22:00.000: %SYS-6-CLOCKUPDATE: System clock has been updated from 00:11:18 UTC Fri Mar 1 2002 to 13:22:00 UTC Tue Oct 14 2008, configured from console by console.

Building configuration...

[OK]

Router#sh run

Building configuration...


Current configuration : 774 bytes

!

! No configuration change since last restart

! NVRAM config last updated at 13:22:01 UTC Tue Oct 14 2008

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 15

no network-clock-participate slot 1

no network-clock-participate wic 0

ip cef

!

Oct 14 13:22:16.871: %C2600-4-SMARTINITDISABLE: Warning! You have disabled SMART INIT

and manually configured the amount of IO memory allocated. This is HIGHLY

discouraged on the Cisco 2600XM Series platforms as it may deprive the

system of memory necessary for normal operation. It is highly recommended

that SMART INIT not be disabled to ensure proper router operation.


Router#

Actions

This Discussion