Unable to log in to CiscoWorks LMS

Unanswered Question
Oct 14th, 2008
User Badges:

Hi all,


when i try to log in to CiscoWorks home page:

https://localhost/CSConm/servlet/login/login.jsp


i get the screen:


HTTP Status 404 - /cwportal/html/cwhp/cwhp.applications.do


type Status report


message /cwportal/html/cwhp/cwhp.applications.do


description The requested resource (/cwportal/html/cwhp/cwhp.applications.do) is not available


I've attached tomcat's stdout.log


Any suggestions?

Thanks!



Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Tue, 10/14/2008 - 08:49
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Is this Windows or Solaris?

Velin Georgiev Tue, 10/14/2008 - 12:24
User Badges:

It is on Windows Server 2003, Standart Edition

I've read your comments about similar posted cases and none of them works for me. There isn't any anti-virus software on the LMS server

Joe Clarke Tue, 10/14/2008 - 16:43
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

What are the Service startup parameter for all of your services?

Velin Georgiev Tue, 10/14/2008 - 22:23
User Badges:

Sorry, but do you ask me for "startup type" and "log on as" from the Windows Services display, or you ask me for the ouput of the pdshow command?

Velin Georgiev Wed, 10/15/2008 - 05:23
User Badges:

Anyway, i'm posting both information.


Process:

CiscoWorks Daemon Manager:

C:\PROGRA~1\CSCOpx\bin\dmgtd.exe automatic

Startup type automatic, Local System


CiscoWorks ANI database engine:

C:\PROGRA~1\CSCOpx\objects\db\win32\dbsrv9.exe -hvANIDbEngine

Startup type manual, Local System


CiscoWorks RME NG database engine:

C:\PROGRA~1\CSCOpx\objects\db\win32\dbsrv9.exe -hvRMEDbEngine

Startup type manual, Local System


CiscoWorks Tomcat Servlet:

C:\PROGRA~1\CSCOpx\MDC\Tomcat\bin\tomcat.exe

Startup type manual, Local System


CiscoWorks Apache

"C:\PROGRA~1\CSCOpx\MDC\Apache\Apache.exe" --ntservice

Startup type manual, Local System


error.log is from apache server



Attachment: 
Velin Georgiev Wed, 10/15/2008 - 05:50
User Badges:

Hi,


When i try http, the login page is accessed but after i enter credentials, i get the error page (which i described in the first message)


When i try https, the login page cannot be found

Martin Ermel Wed, 10/15/2008 - 06:24
User Badges:
  • Blue, 1500 points or more

are you connecting from a client?

If yes try to login from a browser on the LMS server and report the result.

Joe Clarke Wed, 10/15/2008 - 08:25
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Neither is what I wanted. I wanted the Windows Service startup parameters from the Services control panel.

kimby200602 Fri, 10/17/2008 - 00:00
User Badges:

Hello,

I am a substitute for Velin about this problem, because he is at leave and we need to solve this problem.

Here is some more information: There are no startup parameters for the CiscoWorks services in the Services Control Panel.

I am attaching some exports from this Control Panel (taken from mmc and sc utilities), but I was not able to include the startup parameters there. If you need any other info or you have some suggestions, please let me know.

Best Wishes, Kliment Karchanov



Joe Clarke Fri, 10/17/2008 - 07:57
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This looks fine. Please post the NMSROOT/MDC/tomcat/logs/stdout.log and the NMSROOT/MDC/etc/regdaemon.xml. If you are not comfortable posting the regdaemon.xml to an open forum, please open a TAC service request with these files.

kimby200602 Tue, 10/21/2008 - 00:18
User Badges:

Hello,

I have opened a TAC Service Request: 609861987

If you still need any information, let me know

rgomes Tue, 07/14/2009 - 07:25
User Badges:

Hi


I have a customer that is getting this same problem. Have you solved the problem after the TAC case openning?


Thanks

Velin Georgiev Tue, 07/14/2009 - 21:16
User Badges:

Yes the TAC engineers solved that problem and here it is how:


1. Stop the daemons:

C:\>net stop crmdmgtd

2. delete CSCOpx/MDC/tomcat/webapps/cwportal/db/portal.* , ( I prefer to move them to another directory out of NMSROOT;)


3. Then copy CSCOpx/MDc/tomcat/webapps/cwportal/db/orig/*

to CSCOpx/MDC/tomcat/webapps/cwportal/db,


4. verify permissions of the files on that folder


5. Restart the daemons:

C:\>net start crmdmgtd


I hope it works for you too, and because i'm curious, please post the result here


Greetings

rgomes Wed, 07/15/2009 - 09:34
User Badges:

Hi


Great, the procedure has worked fine.

The only addition is that the Daemon Manager did not started and was needed to run resetCasuser to make it run.

Now the Portal Page is oppening fine.


Many thanks

benjo.rulloda Thu, 07/30/2009 - 00:23
User Badges:

Hi Velin,


I'm having similar problems with our client wherein he cannot login to the Ciscsoworks homepage. We noticed that the Tomcat service is not starting. Whenever we try forcing it by clicking the Start button, an error would pop-up. Even if the start-up type is Automatic or Manual, both will have the same result.


I just want to ask if the procedure you posted above will resolve the issue regarding the Tomcat service?


Regards,


Benjo

Velin Georgiev Thu, 07/30/2009 - 00:34
User Badges:

I didn't have problems with starting the Tomcat server, so i can't answer your question for sure. What is logged in Tomcat's log files? You can always try the procedure i've described in the previous post, just make a backup before that.

Actions

This Discussion