EIGRP not working on c837 router

Unanswered Question
Oct 14th, 2008

Hello,

I'm facing an issue of configuring eigrp on my home router cisco 837. So when I lunch "router eigrp 10" command; I get nothing, I mean no thing happen & I stand in the config exec mode "R1(config)#"

My IOS is 12.2

Any comments

Tarik

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
John Blakley Tue, 10/14/2008 - 08:53

Do you have the option of EIGRP if you do "router ?" at the prompt?

You may need to update the IOS.

--John

Richard Burts Tue, 10/14/2008 - 13:57

Tarik

I believe that John is on the right track, but perhaps a clarification might help. It is not so much the version that needs to be updated but probably it is the feature set of the code you are executing that may need to be updated (and a version update may help also). I am guessing that your router is running the IP Base feature set (or something equivalent). This feature set gives you basic routing capability - such as router rip. But for EIGRP you probably need a different feature set.

HTH

Rick

Sushil Kumar Katre Wed, 10/15/2008 - 00:50

Hi Tarik,

If I can recall correctly IP Plus feature set is required for supporting EIGRP on 837 router.

Plaese share the show version output with us so what we can crosscheck that you are running the currect image and then troubleshoot the issue further.

-> Sushil

tarik.fakir Thu, 10/16/2008 - 12:05

Hi Sushil,

Bellow the output

sh ver

Cisco Internetwork Operating System Software

IOS (tm) C837 Software (C837-K9O3SY6-M), Version 12.2(13)ZH4, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

Synched to technology version 12.2(14.5)T

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2004 by cisco Systems, Inc.

Compiled Wed 24-Mar-04 18:51 by ealyon

Image text-base: 0x800131E8, data-base: 0x80B51594

ROM: System Bootstrap, Version 12.2(11r)YV1, RELEASE SOFTWARE (fc1)

ROM: C837 Software (C837-K9O3SY6-M), Version 12.2(13)ZH4, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

ADSL_Router uptime is 3 minutes

System returned to ROM by power-on

System image file is "flash:c837-k9o3sy6-mz.122-13.ZH4.bin"

CISCO C837 (MPC857DSL) processor (revision 0x501) with 44237K/4915K bytes of memory.

Processor board ID FCZ091041BQ (2850802074), with hardware revision 0000

CPU rev number 7

Bridging software.

1 Ethernet/IEEE 802.3 interface(s)

1 ATM network interface(s)

128K bytes of non-volatile configuration memory.

12288K bytes of processor board System flash (Read/Write)

2048K bytes of processor board Web flash (Read/Write)

Configuration register is 0x2102

--- >

tarik.fakir Thu, 10/16/2008 - 12:45

I've found the solution, see next

##

ADSL_Router(config)#ip routing

ADSL_Router(config)#router ei

ADSL_Router(config)#router eigrp 10

ADSL_Router(config-router)#network 172.30.96.0

##

Thnaks guys

Actions

This Discussion