adding Voice Vlan to my LAN

Unanswered Question
Oct 14th, 2008

I am adding Cisco 7940 IP phones to our network. I don't have a router other than the ISP router to the internet. I have a C3750G-24TS switch that all my servers are connected and this is attached to a ASA 5510. I have replaced our workstation switch which is connected to the C3750G with a 3550-24 POE switch. All workstation are getting DHCP form a windows 2003 server 10.1.0.1. I have setup up a 2nd scope for the phones on the DHCP server.

I have connected the workstations to the Cisco phones and the phones into the 3550, the workstations are getting IP settings but the phones are not.

I have a Trunk port between the 2 switches and a switchport mode access for the port on the C3750G to the ASA 5510

Do I need to make any changes to the C3750 switch? Thanks for any Suggestions.

This is the config for the new 3550 switch

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption/

!

no aaa new-model

mls qos

ip subnet-zero

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

interface FastEthernet0/24

switchport mode access

switchport voice vlan 5

switchport priority extend trust

mls qos trust cos

spanning-tree portfast

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet0/2

switchport mode dynamic desirable

!

interface Vlan1

ip address 10.1.0.10 255.255.255.0

!

interface Vlan5

ip address 192.168.1.10 255.255.255.0

ip helper-address 10.1.0.1

!

ip classless

ip http server

ip http secure-server

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 1 (1 ratings)
Loading.
graemeporter Wed, 10/15/2008 - 01:11

Hi there,

The problem is that you have two VLANs, but you have no way of routing between them.

By this, I mean that your DHCP server is on the Data VLAN, but your phones are on a different VLAN.

I don't know the capabilities of the ASA 5510, whether it can do inter-VLAN routing or not. I know Cisco's routers can do it (as we've done it for our VoIP rollout across the UK) but I have no idea if an ASA 5510 can do it. Can anyone check that?

Either way, you need a router that can support 802.1Q trunking on its' LAN interface. You would need to set up two sub-interfaces - one for your data VLAN and one for your voice VLAN, and set the encapsulation on each subinterface, and set the IP Helper address for the voice VLAN to point to the DHCP servers' IP address. The phones should then be able to obtain IP addresses automatically.

Hope this helps!

Kind regards

Graeme

francisco_1 Wed, 10/15/2008 - 01:35

your C3750G-24TS should have the ip services images installed to do vlan routing between the vlans. Do you have a diagram showing how the phones/PC's are connected to which switch?

you should have a 802.1q trunk between the C3750G-24TS and 3550 switch to carry both voice/data vlans. make sure the voice/data vlan exist on both switches and your vlans SVI should be done on the C3750G-24TS for inter-vlan routing not on the 3550. include the ip helper-address on the SVI's.

The port both PC/Phone are connected to on the 3550 should be similar to the config below.

Switch#configure terminal

Switch(config)#interface fastethernet 2/5

Switch(config-if)#switchport mode access

Switch(config-if)#Switchport access vlan [data vlan]

Switch(config-if)#switchport voice vlan [voice vlan]

Configures the IP phone to transmit voice traffic in 802.1Q frames tagged with voice VLAN ID.

Francisco

Actions

This Discussion