Calling phone sees wrong setup information

Unanswered Question
Oct 15th, 2008

Following is the setup-

18072553---seimens hipath4k (istanbul)---2821-RIST1WAN1---FR---2821-B---nortel cs1000m (london)---10216334

When Istanbul call London the calling party sees "London" displayed on his phone but not the ANI+DNIS. However called party in London sees both. The other way it works fine.

I checked the incoming setup message on 2821-A and the ANI+DNIS information was present.

Oct 15 10:38:15.150 MESZ: ISDN BR0/1/0 Q931: RX <- SETUP pd = 8 callref = 0x000D

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA18382

Preferred, Channel 2

Facility i = 0x91AA068001008201008B0100A11D02022D9606042B0C0900A111040C4D45484D455420414B444153020101

Calling Party Number i = 0x0083, '2553'

Plan:Unknown, Type:Unknown

Called Party Number i = 0x80, '10216'

Plan:Unknown, Type:Unknown

High Layer Compat i = 0x9181

Locking Shift to Codeset 5

Codeset 5 IE 0x31 i = 0x80

Oct 15 10:38:15.158 MESZ: ISDN BR0/1/0 Q931: TX -> SETUP_ACK pd = 8 callref = 0x800D

Channel ID i = 0xA98382

Exclusive, Channel 2

Oct 15 10:38:15.894 MESZ: ISDN BR0/1/0 Q931: RX <- INFORMATION pd = 8 callref = 0x000D

Called Party Number i = 0x80, '3'

Plan:Unknown, Type:Unknown

Oct 15 10:38:17.414 MESZ: ISDN BR0/1/0 Q931: RX <- INFORMATION pd = 8 callref = 0x000D

Called Party Number i = 0x80, '3'

Plan:Unknown, Type:Unknown

Oct 15 10:38:18.154 MESZ: ISDN BR0/1/0 Q931: RX <- INFORMATION pd = 8 callref = 0x000D

Called Party Number i = 0x80, '4'

Plan:Unknown, Type:Unknown

Oct 15 10:38:24.854 MESZ: ISDN BR0/1/0 Q931: TX -> CONNECT pd = 8 callref = 0x800D

Channel ID i = 0xA98382

Exclusive, Channel 2

Facility i = 0x91AA068001008201008B0100A11302020100020102800A4575616E2057616C7368

Progress Ind i = 0xA194 - Reserved value

Connected Number i = 0x8095, '2', 0x0180, '6334' >>>>>> not sure why this is like this, never observed something like this.

I'm quite baffled as to why the calling party sees "London" instead of ANI+DNIS.

Even if I assume that the CNAME from FIE is being displayed that doesnt match either. I checked the FIE with a decoder and it says "MEHMET AKDAS". If the 2821's are swapped with Vangaurd routers everything works just fine. So I'm not sure if this is with some QSIG incompatibility between Cisco and PBX.

There isn't any compatibility matrix/sample test for Nortel CS1000M and Cisco using QSIG+H.323.

Any pointers would be great, thanks in advance.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion