HSRP --- Problem

Unanswered Question
Oct 15th, 2008

We have one router3745 which is connected the all wan links .Out of two ethernet port,one port is connected to lacal lan and second one is connected to Core switch 4509 under vlan 246 .Fix is in between Core switch4509 and Router3745.Layer 2 connectivty is between Core switch 4509 and router 3745.

Now we are planing the replace old router to new two routers with HSRP.Setup is like this

1.All the wan links is connected to the active routrer.Active router gi0/0 is connected to the local lan and gi 0/1 is connected to the Coreswitch under vlan 246.BAsically HSRP is designed for the lan redudancy.

2.Standby router gi0/0 is connected to the local lan and gi 0/1 is connected to the Coreswitch under vlan 246

3.If i remove the active router gi0/0 port from lan ,HSRP to be work ie,standby router to be active...But its not happening what would be the problem?

First (HSRP active) Router Gigabit interface configurations

Interface GigabitEthernet0/0

description ****

ip address 10.12.x.x x.x.x.x secondary

ip address 10.9.x.x. x.x.x.x

standby 70 ip 10.9.x.x

standby 70 priority 120

standby 70 preempt

no ip redirects

duplex auto

speed auto

interface GigabitEthernet0/1

description *****

ip address 172.16.x.x x.x.x.x

ip nat inside

speed auto

half-duplex

end

Second (HSRP standby) Router Gigabit interface configurations

interface GigabitEthernet0/0

description *****

ip address 10.12.x.x x.x.x.x secondary

ip address 10.9.x.x x.x.x.x

standby 70 ip 10.9.x.x

standby 70 preempt

no ip redirects

duplex auto

speed auto

interface Gig0/1

description *****

ip address 172.16.x.x x.x.x.x

ip nat inside

speed auto

half-duplex

Routing Configuration

First (HSRP active and stand by) Router's routing configuration

router eigrp 100

passive-interface Dialer4

network 10.9.x.x 0.0.0.127

network 30.x.x.x 0 0.0.0.3

network 172.x.x.x 0.0.0.3

distribute-list prefix HCIL in

no auto-summary

eigrp stub connected summary

!

router ospf 100

log-adjacency-changes

redistribute static subnets

redistribute eigrp 100 subnets route-map EIGRP-OSPF

passive-interface Serial2/0

passive-interface Serial2/3

network 10.9.x.x 0.0.0.63 area 0

network 10.12.x.x 0.0.0.63 area 0

network 172.16.x.x 0.0.0.7 area 0

network 172.20.x.x 0.0.0.0 area 0

network 202.177.x.x 0.0.0.0 area 0

!

router rip

version 2

network 10.0.0.0

network 172.16.0.0

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Wed, 10/15/2008 - 06:45

Please provide the show stand output from both routers, before and after removing g0/0 from the active router.

___

Edison.

CSCO10320953 Wed, 10/15/2008 - 22:16

Pl find the out put of active router after removing

route#

*Oct 14 22:23:11.394: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.21.1.13 (Serial2/3) is resync: peer graceful-restartsh standby

GigabitEthernet0/0 - Group 70

State is Init (interface down)

3 state changes, last state change 00:01:23

Virtual IP address is 10.9.x.x

Active virtual MAC address is unknown

Local virtual MAC address is 0000.0c07.ac46 (v1 default)

Hello time 3 sec, hold time 10 sec

Preemption enabled

Active router is unknown

Standby router is unknown

Priority 120 (configured 120)

IP redundancy name is "hsrp-Gi0/0-70" (default)

CorpFTSPRM#

*Oct 14 22:23:20.377: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.21.1.13 (Serial2/3) is resync: peer graceful-restart

Oct 15 00:20:42.053: %IP-4-DUPADDR: Duplicate address 10.12.148.67 on GigabitEthernet0/0, sourced by 001f.6cf8.f3b0

*Oct 15 00:20:46.497: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.21.1.13 (Serial2/3) is resync: peer

graceful-restart

*Oct 15 02:11:46.017: %OSPF-4-DUP_RTRID_NBR: OSPF detected duplicate router-id 202.177.133.7 from 172.16.246.5 on interface GigabitEthernet0/1

*Oct 15 02:11:51.720: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.21.1.13 (Serial2/3) is resync: peer graceful-restart

before removing

route#sh standby

GigabitEthernet0/0 - Group 70

State is Active

2 state changes, last state change 00:13:54

Virtual IP address is 10.9.x.x

Active virtual MAC address is 0000.0c07.ac46

Local virtual MAC address is 0000.0c07.ac46 (v1 default)

Hello time 3 sec, hold time 10 sec

Next hello sent in 2.504 secs

Preemption enabled

Active router is local

Standby router is 10.9.x.x, priority 100 (expires in 7.492 sec)

Priority 120 (configured 120)

IP redundancy name is "hsrp-Gi0/0-70" (default)

Stand by router before removing

route1#sh standby

GigabitEthernet0/0 - Group 70

State is Standby

7 state changes, last state change 1d07h

Virtual IP address is 10.9.x.x

Active virtual MAC address is 0000.0c07.ac46

Local virtual MAC address is 0000.0c07.ac46 (v1 default)

Hello time 3 sec, hold time 10 sec

Next hello sent in 2.916 secs

Preemption enabled

Active router is 10.9.x.x, priority 120 (expires in 9.032 sec)

Standby router is local

Priority 100 (default 100)

I dont have the after removing the gi0/0 out for stanby router

Pl do the needful

Edison Ortiz Thu, 10/16/2008 - 05:28

1) What's with all those duplicate address error messages that I see from your log?

2) The show stand command on the standby router displays that the state hasn't changed over 1 day and 7 hours while on the active router, it changed 13 minutes and 54 seconds ago. Which tells me the HSRP hellos aren't being exchanged between these routers.

Please explain the physical connectivity on these routers and make sure you aren't filtering multicast on this segment.

__

Edison.

vishwancc Thu, 10/16/2008 - 00:14

Hi,

In which state the second router is when the 1st router is down.

Actions

This Discussion