LMS cannot fetch vlan.dat

Unanswered Question
Oct 15th, 2008

Hi,

we have an LMS and we have some devices in different networks. Devices are 38xx, 28xx, etc.

LMS can only fetch VLAN config from devices located in the same subnet that the LMS is.

In the rest of devices, LMS can fetch running and startup configs but not vlan.dat.

It's not a credentials problem. We think it's the internal method used for recovering this file.

We need to know how is this file retrieved (via TFTP, is it send by the router...) because there is a network between LMS and these devices administered by other group and we have to tell them which ports must be opened.

Many thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Wed, 10/15/2008 - 08:26

Vlan.dat is fetched by teleting or SSHing to the device, then performing, "copy flash:vlan.dat tftp:". This is the only way vlan.dat can be archived.

cmartinvalle Wed, 10/15/2008 - 09:10

Hi,

this is the output from the router if I execute that command:

%Error opening tftp://x.x.x.x/vlan.dat (time out)

I think that:

- it's not a route problem nor a tftp server permission problem: because LMS can retrieve the running and startup config perfectly.

- it's a problem with ports: am I right? If so, what ports and where do I have to open?

- perhaps an access-list...

Thank you very very much.

Joe Clarke Wed, 10/15/2008 - 10:13

You have to open udp/69 between the device and the server. The device will make a write request to udp/69, then the TFTP will happen over high UDP ports.

Actions

This Discussion