VG224 SCCP - no voice

Unanswered Question
Oct 15th, 2008

CCM 4.2(3)sr4, 2 server cluster, VG224 w/ SCCP to Bogen Paging system.


I get the FXS to answer, but no voice stream is cut through. VTSP inout shows the access digit (*) begin recieved by the VG, but a buttset hears no DTMF nor voice.


This sounds like CSCsi81450 (http://forums.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Unified%20Communications%20and%20Video&topic=IP%20Telephony&topicID=.ee6c829&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.2cbf3233/0#selected_message), but my VG is running 12.4(15)T...


Config & debug output attached.


Thank you.



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.3 (5 ratings)
Loading.
allan.thomas Wed, 10/15/2008 - 11:23

The are some inconsistencies concerning the configuration of your VG224, the main fundamental issue is that there does not appear to be any configuration necessary for CallManager registration.


Once the VG registers with CallManager it should then automatically create your STCAPP controller dial-peers, you should not need to manually configure them.


Also I have notice that you specified the CallManager IP address as the VG224 FastEthernet IP address. These sccp ccm IP address should match the addresses of your CallManager Servers.


sccp local FastEthernet0/0

sccp ccm identifier 10

sccp ccm

sccp

!

The following configuration which you appear to be missing from the VG is the necessary command to download the dial-peer configuration, and enable the gateway to register to CallManager. Providing it is configured of course:-


ccm-manager config server

ccm-manager sccp local FastEthernet0/0

ccm-manager sccp

!

Rgds

Allan.

bbenner Wed, 10/15/2008 - 11:39

Thanks for the post Allan.


I changed the IP addresses in the config I attached (customer req), so registering with CCM is functional. My call routing works as expected - I call a DN, CCM routes the call to the VG, the VG seizes the appropriately defined FXS port, and rings the device. Only then does the problem begin - no audio.


I'll put the ccm-manager config server command in and see what we get.

bbenner Mon, 10/20/2008 - 13:51

I solved it by removing the 'caller-id enable' command at the voice-port level.


The bug says it's fixed in 12.4(15)T, but I experienced it myself.

allan.thomas Mon, 10/20/2008 - 14:16

As you have discovered the workaround was to remove caller-id from the voice-port, however the other alternative was to configure the gateway as MGCP which should have also resolved the issue.


The bug was not fixed until 12.4(15)T2, and 12.4(15)T was an affected version. Either way removing caller-id or configuring MGCP as I had mentioned would have been workaround.


Rgds

Allan.

allan.thomas Wed, 10/22/2008 - 02:22

I don't see why you have twice given such a low rating form information that I have provided you with?


Firstly I provided you information concerning your MGCP configuration which did not appear to be correct, and secondly I pointed out to you that the issue that you were running into is in fact in the release that you are currently running.


This forum is aimed at providing posts which are helpful, and in both cases I have tried to be helpful...

adns_jeremy Thu, 07/09/2009 - 12:34

I know this is basically solved, but does anyone know how to prove this was the case via debugs (for documentation purposes)?

Actions

This Discussion