snmp linkup/linkdown traps not being sent to the snmp server

Unanswered Question
Oct 16th, 2008

Hi All,

I have configured the Cisco 6509 to send all the snmp traps to the NEtact snmp server. I get the config change traps being sent to the server. But when I plug and unplug my laptop to a Gigabit interface I do not get any traps.

I am able to see the linkup and linkdown logs on the console but not on the snmp server.

Hardware:

PACO-C6509

Software Version:

12.2(18)SXF10

logging snmp-authfail

snmp-server community xxx RO 15

snmp-server community yyy RW 15

snmp-server trap-source Vlan401

snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart

snmp-server enable traps chassis

snmp-server enable traps module

snmp-server enable traps transceiver all

snmp-server enable traps casa

snmp-server enable traps tty

snmp-server enable traps ospf state-change

snmp-server enable traps ospf errors

snmp-server enable traps ospf retransmit

snmp-server enable traps ospf lsa

snmp-server enable traps ospf cisco-specific state-change

snmp-server enable traps ospf cisco-specific errors

snmp-server enable traps ospf cisco-specific retransmit

snmp-server enable traps ospf cisco-specific lsa

snmp-server enable traps bgp

snmp-server enable traps config-copy

snmp-server enable traps config

snmp-server enable traps dlsw

snmp-server enable traps event-manager

snmp-server enable traps frame-relay

snmp-server enable traps hsrp

snmp-server enable traps ipmulticast

snmp-server enable traps MAC-Notification move threshold

snmp-server enable traps msdp

snmp-server enable traps pim neighbor-change rp-mapping-change invalid-pim-message

snmp-server enable traps rf

snmp-server enable traps rtr

snmp-server enable traps slb real virtual csrp

snmp-server enable traps bridge newroot topologychange

snmp-server enable traps stpx inconsistency root-inconsistency loop-inconsistency

snmp-server enable traps syslog

snmp-server enable traps flex-links status

snmp-server enable traps sonet

snmp-server enable traps dial

snmp-server enable traps fru-ctrl

snmp-server enable traps entity

snmp-server enable traps rsvp

snmp-server enable traps srp

snmp-server enable traps vtp

snmp-server enable traps vlancreate

snmp-server enable traps vlandelete

snmp-server enable traps flash insertion removal

snmp-server enable traps c6kxbar intbus-crcexcd intbus-crcrcvrd

snmp-server enable traps envmon fan shutdown supply temperature status

snmp-server enable traps csg agent quota database

snmp-server enable traps port-security

snmp-server enable traps mpls traffic-eng

snmp-server enable traps mpls ldp

snmp-server enable traps isakmp policy add

snmp-server enable traps isakmp policy delete

snmp-server enable traps isakmp tunnel start

snmp-server enable traps isakmp tunnel stop

snmp-server enable traps ipsec cryptomap add

snmp-server enable traps ipsec cryptomap delete

snmp-server enable traps ipsec cryptomap attach

snmp-server enable traps ipsec cryptomap detach

snmp-server enable traps ipsec tunnel start

snmp-server enable traps ipsec tunnel stop

snmp-server enable traps ipsec too-many-sas

snmp-server enable traps alarms

snmp-server enable traps vlan-mac-limit

snmp-server enable traps voice poor-qov

snmp-server enable traps mpls vpn

snmp-server host 10.x.y.17 public

snmp-server host 10.x.y.23 public

Please let me know if you have come across this kind of an issue before.

DO i have to configure anything under the interface mode?

Please let me know.

This is the sample interface configuration:

interface GigabitEthernet1/44

description SW1-Netact Port 0/18 QTSGSN1-OM-to-NetAct-Router-1

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 400,401

--More-- switchport mode trunk

switchport nonegotiate

no ip address

speed 100

duplex full

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
singhsaju Thu, 10/16/2008 - 07:33

Hello,

Under interface for specific interface: snmp trap link-status

http://www.cisco.com/en/US/docs/ios/12_0/configfun/command/reference/frmonitr.html#wp1023375

Also in newer IOS

The snmp-server enable traps snmp [ linkup] [linkdown] form of this command replaces the snmp trap link-status interface configuration mode command.

http://www.cisco.com/en/US/tech/tk648/tk362/technologies_tech_note09186a0080094a05.shtml

HTH

Saju

Pls rate helpful posts

Actions

This Discussion