Problems Upgrading 3.3 to 4.2

Unanswered Question
Oct 16th, 2008

I'm having a problem with a 3.3 to 4.2 upgrade. The steps I'm following are;

1) install 3.3 on new server

2) replicate production server db to new db

3) upgrade to 4.1

4) upgrade to 4.2

5) apply patch 4.2.5

I've done this in the lab and it's worked fine. However when doing it for the production serversI lost my connection (RDP) at the end of the 3.3->4.1 upgrade. I booted the server and was able to log in to the ACS 4.1 server, everything looked ok. Next I ran the 4.1->4.2 upgrade and it errored with "The existing installation was not removed correctly. Do you want to try again or abort this installation?". If I try to remove 4.1 I get "The log file DeIsL1.isu" is not valid or the data has been corrupted Uninstallation will not continue"

I see to be in a catch-22. I would be fine with wiping the system clean and starting all over again 3.3->4.1->4.2. Short of reinstalling the OS, which comes from another group and will take 4-6 weeks, is there something I can do?

thanks

Bob

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
srivchan Fri, 10/17/2008 - 02:10

Hi Bob,

Using ACS 4.1 Clean (available in ACS 4.1 Installation CD/Package), run it and it cleans ACS completely.

Do a fresh ACS 4.2 installation and restore ACS 4.1 dump in that.

Below docs helps in upgradtion process from ACS 3.3 to 4.2

http://www.cisco.com/en/US/docs/net_mgmt/cisco_secure_access_control_server_for_windows/4.2/installation/guide/windows/install.html#wp1102849

Thanks,

Srividhya

rd9689@sbc.com Fri, 10/17/2008 - 06:25

Srividhya,

That was exactly what I needed.

I used clean and started again from scratch and things worked perfectly.

thanks!

Bob

Actions

This Discussion