LMS 3.0.1 / RME : unable to subscribe syslog collector

Unanswered Question
Oct 17th, 2008

Hi,

Customer has LMS 3.0.1. syslog reports are empty.

When we look at RME->tools->syslog->collector status:

all colums are N/A except Name: LMS hostname and Update time : Not Reachable.

Both SyslogCollector and SyslogAnalysor are running:

Process= SyslogAnalyzer

State = Program started - No mgt msgs received

Pid = 9576

RC = 0

Signo = 0

Start = 03/10/2008 12:16:01

Stop = Not applicable

Core = Not applicable

Info = Server started by admin request

Process= SyslogCollector

State = Program started - No mgt msgs received

Pid = 19616

RC = 0

Signo = 0

Start = 03/10/2008 12:13:58

Stop = Not applicable

Core = Not applicable

Info = Server started by admin request

We have verified that LMS server received syslog with a sniffer.

We unsubscribe collector, after we try to subcribe, but it fails with this message:

SLCA0126: Could not subscribe to the Collector.

1.Check whether the collector is running.

2.Make sure that SSL certificates are imported/exported correctly and process restarted.

3.Check whether the Certificates exported/imported are valid and have not expired.

4.Check whether SyslogAnalyzer process is running.

Thanks, Elisabeth

Here, you can find logs with debug.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Fri, 10/17/2008 - 07:50

Two problems I see. One, the server appears to be localized for French which is not supported. You must change the server's localization to US English. Second, it appears another application is occupying tcp/4444. If you shutdown Daemon Manager, and look at netstat -a -n -o -b, you can see what application this is. If that application is shutdown, and Daemon Manager is restarted, syslog analysis should begin to work.

ebezombes Mon, 10/20/2008 - 04:22

Hi Joe,

Many thanks for your response, port 4444 was not available ! Best regards, Elisabeth

mohamedtwair Wed, 02/25/2009 - 05:41

hi ebezombes,

i am facing the same problem excatly

port 4444 is not available,what did you do after that?

thanks in advance

regards

Joe Clarke Wed, 02/25/2009 - 10:43

Your two choices are either to free up tcp/4444 on the server so that SyslogAnalyzer can use it, or change the value on NMSROOT/MDC/etc/regdaemon.xml. Replace 4444 with another free TCP port value. Make sure you backup regdaemon.xml before making any changes.

After making the change, restart Daemon Manager.

mohamedtwair Sun, 03/01/2009 - 02:33

hi again

i replaced 4444 with 48889 TCP port(NMSROOT/MDC/etc/regdaemon.xml) but still facing the same problem

do you have any other options?

regards

mohamedtwair Sun, 03/01/2009 - 22:49

Thanks for your response but i have one more questions,after changing the ports,i followed the following path:C:/PROGRA~2/CSCOpx\MDC\tomcat\webapps\rme\WEB-INF\classes\C:\PROGRA~2\CSCOpx\MDC\tomcat\webapps\rme\WEB-INF\classes\com\cisco\nm\rmeng\csc\data

\Collector.properties"

and i noticed that the COLLECTOR_PORT=4444

do u think i need to change this too?

i have another cusotmer with same configurations but the syslog is working just fine.

regards

Joe Clarke Mon, 03/02/2009 - 07:36

Yes, this port must be changed, too, to match the port in regdaemon.xml.

Actions

This Discussion