ATM to FR, ping is ok, EIGRP - Retry Limit Exceeded

Unanswered Question
Oct 17th, 2008
User Badges:

Hi, I have problem with translation Frame Relay to ATM, I will copy my config from ATM router and FR router, ping is ok, I can ping other side perfect but EIGRP all the time do EIGRP - Retry Limit Exceeded. What I missing in configuration ? This is test so i dont have nothing configure about CIR , Bandwith limit itd.. only I need to get that this work and later i will with ISP configure CIR.





FRAME-RELAY SIDE ROUTER

interface Serial0/0/0

no ip address

encapsulation frame-relay IETF

no ip mroute-cache

load-interval 30

no fair-queue

frame-relay traffic-shaping

frame-relay lmi-type ansi

!

interface Serial0/0/0.1 point-to-point

ip address 192.168.1.2 255.255.255.252

no ip mroute-cache

no cdp enable

frame-relay interface-dlci 50


router eigrp 10

network 192.168.1.2 0.0.0.0

no auto-summary


ATM SIDE ROUTER

interface ATM1/0

no ip address

no atm ilmi-keepalive

!

interface ATM1/0.50 point-to-point

description *** to Router Frame-Relay

ip address 192.168.1.1 255.255.255.252

pvc Unitic 2/50

!

router eigrp 10

network 192.168.1.1 0.0.0.0

no auto-summary

!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Fri, 10/17/2008 - 09:30
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Anis,

you can face an MTU mismatch and possibly you need a protocol command on atm side


int atm1/0

mtu 1500

interface ATM1/0.50 point-to-point

pvc Unitic 2/50

protocol ip 192.168.1.2 broadcast


Hope to help

Giuseppe



aniss12345 Fri, 10/17/2008 - 09:42
User Badges:

I try this what you say but I still get same problem:


Oct 17 19:40:18.368: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 192.168.1.2 (Serial0/0/0.50) is down: Interface Goodbye received

Oct 17 19:40:18.596: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 192.168.1.2 (Serial0/0/0.50) is up: new adjacency

Giuseppe Larosa Fri, 10/17/2008 - 09:49
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Anis,

do you see these two lines all the time ?


verify that the frame-rel pvc is stable with


sh frame-rel pvc


and on atm side

sh atm pvc


try to perform an extended ping to qualify the link.

I would add on each side something to advertise


r1


int loop1

ip address 192.168.1.111 255.255.255.255


router eigrp 10

network 192.168.1.111 0.0.0.0


r2 atm side


int atm1/0.50

mtu 1500



int loop1

ip address 192.168.1.112 255.255.255.255


router eigrp 10

network 192.168.1.112 0.0.0.0


use debug ip eigrp hello



Hope to help

Giuseppe


aniss12345 Fri, 10/17/2008 - 09:58
User Badges:

When I change on side Freame relay interface on this kind of config , then seems like its ok. But when i use point to pontt then eigrp is down,


FR side:


interface Serial0/0/0

ip address 192.168.1.2 255.255.255.252

encapsulation frame-relay IETF

frame-relay map ip 192.168.1.2 50 broadcast

frame-relay map ip 192.168.1.1 50 broadcast

frame-relay interface-dlci 50

frame-relay lmi-type ansi


ATM side :


interface ATM1/0.50 multipoint

ip address 192.168.1.1 255.255.255.252

pvc 2/50

protocol ip 192.168.1.1

protocol ip 192.168.1.2 broadcast

aniss12345 Fri, 10/17/2008 - 10:00
User Badges:

RouterFR#show ip eigrp neighbors

IP-EIGRP neighbors for process 10

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

1 192.168.1.1 Se0/0/0 12 00:06:18 128 768 0 351

aniss12345 Fri, 10/17/2008 - 10:19
User Badges:

Ok so now work like this:


FR side:


interface Serial0/0/0

ip address 192.168.1.2 255.255.255.252

encapsulation frame-relay IETF

frame-relay map ip 192.168.1.2 50 broadcast

frame-relay map ip 192.168.1.1 50 broadcast

frame-relay interface-dlci 50

frame-relay lmi-type ansi


ATM side :


interface ATM1/0.50 multipoint

ip address 192.168.1.1 255.255.255.252

pvc 2/50

protocol ip 192.168.1.1

protocol ip 192.168.1.2 broadcast


but how to make work on point to point ?

if work like this then i type some wrong commands and point to point not work.


thanks for any help ppl

Giuseppe Larosa Fri, 10/17/2008 - 10:21
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Anis,

it looks like that when using point-to-point FR to ATM service interworking does not transport the multicast ip over the FR DLCI: it is the atm side that does not receive and then sends the goodbye message to close the session


try


int ser0/0/0


int ser0/0/0.50 point-to-point

frame-relay interface-dlci 50

frame-relay map ip 192.168.1.1 50 broadcast


! if the second is not allowed remove the first and put only the second



or try to use neighbor commands under the router eigrp process on both routers


router eigrp 10

neighbor 192.168.1.2


router eigrp 10

neighbor 192.168.1.1


in this way you instruct the routers to use unicast packets to exchange hellos and updates


Hope to help

Giuseppe


Actions

This Discussion