routing a NATed packet

Unanswered Question
Oct 19th, 2008
User Badges:

We're building a network for DR, where we're testing a whole bunch of apps on the Intel servers and one app on 4 Unix servers that has hard coded production addresses (172.21.242.0/24). So, we figured we would have to deploy NAT to translate the production addresses for this app. The way we're building the network is with a couple of daisy chained routers. The first router would be the choke router and the second would NAT the addresses, similar to this:

12.2.3.4 s0 --- 10.47.24.1 e0 ~~~~~e0 (nat outside) 10.47.24.2 --- 172.21.242.1 e1 (nat inside)

The second router with the e0/e1 interfaces would be doing the NAT. This, I believe should work OK. What I need to clarify is, the Intel servers will be hanging off the first router and the Unix servers will be hanging off of the second router (the NAT router). When a packet with the destination address of 10.47.24.17 arrrives at the first router, how would we make sure that if the server with that address is hanging off of the first router, it would find it, otherwise, the packet would be sent to the second router?


Thanks..

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lamav Sun, 10/19/2008 - 16:30
User Badges:
  • Blue, 1500 points or more

Hi:


Im not too sure I fully understand your topology, but I'll take a crack at explaining a bit about NATing.


Typically, the network device that does the NATing will advertise the subnet to which internal hosts will be NATed.


So, what you typically will see in a NAT device is the following configuration:


interface loopback0

ip address 172.16.10.2 255.255.255.0


interface gi1/1

ip nat inside


interface s0/0

ip nat outside


router eigrp

network 172.16.10.0 0.0.0.255


ip nat pool NAT-POOL 172.16.10.2 172.16.10.254 prefix 24


ip nat inside source list 7 pool NAT-POOL overload


access-list 7 permit 10.10.10.0


Of course this is just an example.


What I want you to take away from this is the fact that the NAT device performs the NATing and advertises the subnet that it uses.


HTH


Victor



Actions

This Discussion