IPsec and SSL VPN, No Internet access

Unanswered Question
Oct 20th, 2008

Hi,

I've set up Easy VPN Server and SSL VPN on a couple of cisco routers (877 and 3800) with a full tunnel (No split tunnelling). Everything works as it should, except that I don't have access to the internet using the WAN connection of the remote location I'm connected to.

I've configured split tunnelling and that works allowing me to use my local internet connection and to modify my windows xp routing table, however I would much prefer to have a full tunnel and use the internet connection of the remote network I'm VPNed into.

Somebody told me, I can't have access of the internet on the remote location if I'm using the interface on the router connected to the internet as VPN tunnel.

From a traffic prospective, to be more clear the requests to the internet would enter the remote network through the tunnel interface connected to the internet go out on the same interface to the internet come back again on that interface and enter the tunnel again to reach the remote vpn client.

Would somebody know what changes I need to apply to the standard SDM generated configuration to fix the problem above.

Thank you.

Rocco

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
0600648902 Tue, 04/21/2009 - 04:45

Hi,

I am not successful to solve this issue with the solution from the provided link.

here is my config :

============

interface lo199

ip address 10.255.255.1 255.255.255.0

ip virtual-reassembly

ip nat inside

interface atm0/0/0.1 point-to-point

--omitted--

ip address a.b.c.d 255.255.255.252

ip nat outside

ip policy route-map toX

--omitted--

ip nat inside source list 101 interface atm0/0/0.1 overload

access-list 101 permit ip 192.168.132.0 0.0.0.15 any

route-map toX permit 10

match 101

set ip next-hop 10.255.255.2

====================

VPN client is successfully connected. When I traceroute, the 1st hop is a.b.c.d and the rests are '*'. Remote client completely can access LAN and cannot access internet through the same router.

Any suggestion would be apreciatted.

Regards.

0600648902 Wed, 04/22/2009 - 19:39

Hi,

I try this solution :

http://www.cisco.com/en/US/products/sw/secursw/ps2308/products_configuration_example09186a008073b06b.shtml

but it does not work on my device.

I have router which serves remote access vpn and internet. I want when user does vpn to this router and browses internet through this router as well. the situation is exactly the same with the above link.

But when the user connects vpn, they cannot browse to internet. how to debug this issue ?

Actions

This Discussion