BGP different number of prefixes

Answered Question
Oct 20th, 2008

I have a neighbor bgp with my mpls provider. In some cases the number of prefixes that I receive is different that the number of prefixes that they advertise.

For example:

In the ISP's router:

sh ip bgp vpnv4 vrf xxxxx neighbors 77.3.220.26 advertised-routes | inc Total

Total number of prefixes 1380

and y my router:

sh ip bgp neighbors 172.56.255.37 received-routes | include T

Total number of prefixes 870

I have this problem too.
0 votes
Correct Answer by Giuseppe Larosa about 8 years 2 months ago

Hello Marcelo,

I've noticed you have :

neighbor 172.x.y.129 allowas-in

I think the default-value is 1.

this probably will not allow a prefix were your own AS number appears more then one as a result of AS prepending done on another site and reported to your local router by the PE router because is not using any form of as-override.

Hope to help

Giuseppe

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Giuseppe Larosa Mon, 10/20/2008 - 05:05

Hello Marcelo,

at startup or BGP session it takes some time to load the 1380 prefixes over the BGP/TCP session you can see a partial value during "loading"

Or do you see this in a stable eBGP connection ?

Verify if the eBGP session is stable with sh ip bgp sum.

Hope to help

Giuseppe

MARCELO MATURO Mon, 10/20/2008 - 05:50

I have de maximum-prefix parameter in default value. I don't know the other peer. Is it possible cause of the problem?

Thanks

Marcelo

joshua.wilson Mon, 10/20/2008 - 06:07

Depending on what the default maximum prefix is set to it could explain why the you not receiving all the prefixes from you isp. You could try increasing it to say...1400 to see you you will receive the 1380 prefixes your isp is sending to you.

When you do a show ip bgp neighbor xxx.xxx.xx.xxx, what is the max prefix ?

MARCELO MATURO Mon, 10/20/2008 - 06:25

I don't find de max prefix in that command output.

On the other hand if I do a clear ip bgp * I start to receive all the prefix. But I want to find out the issue, because there is an usual situation.

Thanks

Marcelo

lamav Mon, 10/20/2008 - 07:04

maturo:

Do you have any input route filters pointing to the neighbor in question?

lamav Mon, 10/20/2008 - 08:48

OK, so is it possible that the prefix list is filterng routes and this is why there is a disparity between what the ISP is sendin you and what you are viewing with the 'received routes' keyword?

try using the sho ip bgp neighbor x.x.x.x routes command. if you have soft reconfiguration inbound enabled, you will be able to view all routes received by the peer router, not just the ones installed in the bgp table, which typically exclues those that get filtered.

Let me know...

MARCELO MATURO Mon, 10/20/2008 - 09:05

The sho ip bgp neighbor x.x.x.x routes command show me the routes after the filters engine.

The sho ip bgp neighbor x.x.x.x received-routes show me all the prefix received before ther are filtered. This last number is different from the advertised routes, so I suppose there is not issue with the filters.

Marcelo

MARCELO MATURO Tue, 10/21/2008 - 04:04

2801,IOS 12.4(7a)

The bgp config is:

router bgp 65000

no synchronization

bgp log-neighbor-changes

network a.b.c.d mask 255.255.255.255

network a.b.c.d mask 255.255.255.255

neighbor 77.b.c.25 remote-as 65000

neighbor 77.b.c.25 send-community

neighbor 77.b.c.25 distribute-list local in

neighbor 77.b.c.25 prefix-list out out

neighbor 172.x.y.129 remote-as 10xxx

neighbor 172.x.y.129 ebgp-multihop 2

neighbor 172.x.y.129 send-community

neighbor 172.x.y.129 allowas-in

neighbor 172.x.y.129 soft-reconfiguration inbound

neighbor 172.x.y.129 weight 1000

neighbor 172.x.y.129 prefix-list in in

neighbor 172.x.y.129 prefix-list out out

no auto-summary

!

Correct Answer
Giuseppe Larosa Tue, 10/21/2008 - 06:52

Hello Marcelo,

I've noticed you have :

neighbor 172.x.y.129 allowas-in

I think the default-value is 1.

this probably will not allow a prefix were your own AS number appears more then one as a result of AS prepending done on another site and reported to your local router by the PE router because is not using any form of as-override.

Hope to help

Giuseppe

MARCELO MATURO Tue, 10/21/2008 - 07:24

Thanks Giuseppe,

I modify to neighbor 172.x.y.129 allowas-in 10 and do a clear soft, so I started to receive the routes.

Marcelo

Actions

This Discussion