BGP <-> EIGRP question

Unanswered Question
Oct 20th, 2008

i inherited a network that is redistributing routes from BGP to EIGRP and back again. I get a queasy feeling everytime I make a routing change. I want to clean it up (and make the table smaller) by announcing summarized routes via BGP to remote sites and killing the EIGRP -> BGP redistribution. is this the right approach?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Calin Chiorean Mon, 10/20/2008 - 21:51

Hello!

Before I'll try to help I have a question:

"...redistributing routes from BGP to EIGRP and back again..." You wanted to say that you redistribute routes from BGP to EIGRP and routes from EIGRP to BGP? I don't see any reason to redistribute the SAME routes from BGP to EIGRP and again back to BGP.

If you announce summarized routes via BGP, your routing table will not be smaller (because of the EIGRP routes and what you receive from BGP peer) but your peering neighbor.

If you want less routes than ask your peering BGP neighbor to announce to you summarized routes too.

Tell me if you understand!

Cheers,

Calin

anthoney_murphy... Tue, 10/21/2008 - 07:48

"You wanted to say that you redistribute routes from BGP to EIGRP and routes from EIGRP to BGP"

Correct. I also am saying that I want to turn of the redistribution from EIGRP to BGP and announce summary routes to EBGP peers. Why would that not make the table smaller?

vdadlaney Tue, 10/21/2008 - 08:47

Hi Anthony,

Controlled redistribution should not be an issue. Ofcourse if your addresses do fall on a bit boundary and you can summarize than its even better but there are times when its not possible to summarize. Oversummarization should definetly be avoided atleast in my opinion.

It seems that you are using EIGRP as your IGP locally within the site and eBGP. You can reduce the RT in your branch sites by advertising only a summary from your core site towards the branches. Also on the branch sites if you summarize the subnet and than advertise only that subnet to your core site than you will also reduce the RT in your Core site depending on how many routes you are summarizing.

I do however think that you will have to redistribute all your eBGP learnt routes into EIGRP since you want the summary to be advertised from the branch routers.

In addition you will have to redistribute the routes that originate within your core site towards the branches. You could do this if you can summarize them to a bit boundary with a static route to null0 and redistribute the static's or you can redistribute EIGRP into BGP with prefix-lists to control which routes get advertised.

In my humble opinion redistribution should always be controlled regardless hence I always use a route-map/prefix-list to redistribute and I don't see any issues with it. Thx

francisco_1 Tue, 10/21/2008 - 09:33

even with the redistrubuiton in place between BGP/EIGRP you can send smaller aggregate routes in to EIGRP redisributed from BGP to make the EIGRP routing smaller.

Below is a simple config between 3 routers. Router1 is connected to R3 via BGP and R3 in turn Connected to R2 via EIGRP. R3 is redistributing between R1/2. I am sending a BGP aggregate routes from R1 to R3 with the summary-only command. R3 advertised that in to EIGRP. In turn R3 is also aggregating the EIGRP routes and send in to R1. Both R1/R2 are receiving the aggregates routes from R3. So

R1

interface Loopback0

ip address 10.1.0.1 255.255.255.0

!

interface Loopback1

ip address 10.2.0.1 255.255.255.0

!

interface Loopback2

ip address 10.5.0.1 255.255.255.0

!

interface Loopback3

ip address 10.3.0.1 255.255.255.0

!

interface Loopback4

ip address 10.4.0.1 255.255.255.0

interface Serial1/0

Connected to R3

ip address 155.1.0.1 255.255.255.0

serial restart-delay 0

clock rate 64000

router bgp 1

no synchronization

bgp log-neighbor-changes

network 10.1.0.0 mask 255.255.255.0

network 10.2.0.0 mask 255.255.255.0

network 10.3.0.0 mask 255.255.255.0

network 10.4.0.0 mask 255.255.255.0

network 10.5.0.0 mask 255.255.255.0

aggregate-address 10.0.0.0 255.252.0.0 summary-only

neighbor 155.1.0.3 remote-as 2

no auto-summary

sh ip route on R1

B 172.25.48.0 [20/0] via 155.1.0.3, 00:03:32 --------------This is the summarised EIGRP route from Router 3

10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks

R3

interface Serial1/0

Connected to R1

ip address 155.1.0.3 255.255.255.0

!

interface Serial1/1

Connected to R2

ip address 172.25.1.3 255.255.255.0

clock rate 64000

!

router eigrp 1

redistribute bgp 2 metric 1 1 1 1 1

network 172.25.1.3 0.0.0.0

no auto-summary

!

router bgp 2

no synchronization

bgp log-neighbor-changes

aggregate-address 172.25.48.0 255.255.252.0 summary-only

redistribute eigrp 1

neighbor 155.1.0.1 remote-as 1

no auto-summary

R2

interface Loopback0

ip address 172.25.48.1 255.255.255.0

!

interface Loopback1

ip address 172.25.49.1 255.255.255.0

!

interface Loopback2

ip address 172.25.50.1 255.255.255.0

!

interface Loopback3

ip address 172.25.51.1 255.255.255.0

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface Serial1/0

Connected to R3

ip address 172.25.1.2 255.255.255.0

router eigrp 1

network 172.25.1.2 0.0.0.0

network 172.25.0.0

no auto-summary

!

router bgp 1

synchronization

bgp log-neighbor-changes

neighbor 13.0.0.1 remote-as 1

neighbor 25.0.0.5 remote-as 5

no auto-summary

sh ip route on R2 --------------This is the aggregated BGP route from Router 3

D EX 10.0.0.0/14 [170/2560512256] via 172.25.1.3, 00:24:35, Serial1/0

Actions

This Discussion