two jtapi-apps on the same terminal

Unanswered Question
Oct 20th, 2008
User Badges:

hi experts,


I have the following problem:


I have a working JTAPI Application running on a bunch of IP phones, mostly 7911, 7962, 7970 terminals.


Now I need an additional service to create some XML data that I can push to the phones. But the push is done by an external source, for instance an asterisk telephone server. The *-server calls the jar file containing the JTAPI functionality and try to push an XML <CiscoIPPhoneExecute> object via CiscoTerminal.sendData(xml) to the terminal.


Then I get the following error:


at com.cisco.jtapi.TerminalImpl.getButtonPressedEnabled(CTQF)

at com.cisco.jtapi.TerminalImpl.getDeviceState(CTQF)

at de.aco.al.Start.<init>(Start.java:70)

at de.aco.al.Start.main(Start.java:25)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:597)


The weird thing is. I use the same code in the working application and everything works fine...


CiscoTerminal ct = (CiscoTerminal) term;

int state = ct.getDeviceState(); System.out.println("state:" + state);

ct.sendData(xmlResponse);


The code already interrupts at the getDeviceState method!


Any clues what could be the reason for this behaviour?


Cheers and thx in advance for your mostly appreciated help!


Peter

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
peter0601 Wed, 10/22/2008 - 03:40
User Badges:

Hi there,


solved the problem.


I did not place an observer on the phone. hence i was unable to control it. I do not know why an observer is necessary to use the CiscoTerminal.sendData method but anyway. Solved!


Cheers Peter

Actions

This Discussion