DMVPN issue

Unanswered Question
Oct 21st, 2008

I have a DMVPN setup with two hubs, primary and secondary and about 20 remote sites.

At present all sites are able to build a tunnel to the primary site and learn routes (EIGRP).

However this is only working on the secondary for one of these 20 sites and we cannot see why.

All of the others the tunnel comes up, goes idle, then another tunnel will build to the same addressing, then it will go into no state.

I have tried various debugs but nothing has come up.

The only difference between the single remote site which works and the others is it is on 12.4(6)T7, not 12.4(9)T7 like all others.

The config extract of the working hub is..

interface Tunnel1

description Primary Multi-Point GRE Tunnel For Remote Sites

bandwidth 10000

ip address 192.168.111.1 255.255.255.0

no ip redirects

no ip next-hop-self eigrp 206

ip nhrp authentication pQHtmoKO

ip nhrp map multicast dynamic

ip nhrp network-id 9371

ip nhrp holdtime 600

ip nhrp cache non-authoritative

no ip split-horizon eigrp 206

delay 1000

tunnel source 192.168.206.251

tunnel mode gre multipoint

tunnel key XXXX

tunnel protection ipsec profile dmvpn

!

The secondary hub is..

interface Tunnel2

description Secondary Multi-Point GRE Tunnel For Remote Sites

bandwidth 10000

ip address 192.168.112.1 255.255.255.0

no ip redirects

no ip next-hop-self eigrp 206

ip nhrp authentication pQHtmoKO

ip nhrp map multicast dynamic

ip nhrp network-id 9372

ip nhrp holdtime 600

ip nhrp cache non-authoritative

no ip split-horizon eigrp 206

delay 5000

tunnel source 192.168.206.252

tunnel mode gre multipoint

tunnel key XXXX

tunnel protection ipsec profile dmvpn

The remote sites all have the same and are set at..

interface Tunnel1

description Primary mGRE tunnel to THM Cisco 2801

ip address 192.168.111.137 255.255.255.0

no ip redirects

no ip next-hop-self eigrp 206

ip nhrp authentication pQHtmoKO

ip nhrp map 192.168.111.1 XXXX

ip nhrp map multicast XXXX

ip nhrp network-id 9371

ip nhrp holdtime 600

ip nhrp nhs 192.168.111.1

ip tcp adjust-mss 1300

no ip split-horizon eigrp 206

delay 1000

tunnel source XXXX

tunnel mode gre multipoint

tunnel key XXXX

tunnel protection ipsec profile dmvpn

!

interface Tunnel2

description Secondary mGRE tunnel to TC Cisco 2801

ip address 192.168.112.137 255.255.255.0

no ip redirects

no ip next-hop-self eigrp 206

ip nhrp authentication pQHtmoKO

ip nhrp map 192.168.112.1 XXXX

ip nhrp map multicast XXXX

ip nhrp network-id 9372

ip nhrp holdtime 600

ip nhrp nhs 192.168.112.1

ip tcp adjust-mss 1300

no ip split-horizon eigrp 206

delay 5000

tunnel source XXXX

tunnel mode gre multipoint

tunnel key XXXX

tunnel protection ipsec profile dmvpn

Any ideas?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion