Problem with a Cisco 857W config

Unanswered Question

Hi


(I originally posted this over in the wireless section but was advised to pop it over here)


I'm having real trouble getting a Cisco 857W to access the internet. I've config'd these boxes in the past - admittedly to a Private VPN - and they've worked a treat. This one is proving very troublesome. Here's my config (adapted from a 'working' 857W)


Current configuration : 2422 bytes

!

version 12.4

no service pad

service timestamps debug datetime localtime

service timestamps log datetime localtime

service password-encryption

!

hostname mx_jlennon

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$nhGM$/ONk1CcM2Mh.N1yEh67OB1

!

no aaa new-model

!

!

!

dot11 ssid jimsaca01

authentication open

authentication key-management wpa

guest-mode

wpa-psk ascii 7 030E5206151F2D4D4D0C18111F1D0609

!

no ip source-route

no ip dhcp use vrf connected

ip dhcp excluded-address 10.215.21.1 10.215.21.50

!

ip dhcp pool acas

import all

network 10.215.21.0 255.255.255.0

default-router 10.215.21.1

lease 0 23 59

!

!

ip cef

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

no ip domain lookup

!

!

!

username mxuser password 7 1043110C161200

!

!

archive

log config

hidekeys

!

!

!

bridge irb

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

dsl operating-mode auto

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Dot11Radio0

no ip address

beacon period 200

no dot11 extension aironet

!

encryption mode ciphers tkip

!

ssid jimsaca01

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

description ****local interface****

no ip address

bridge-group 1

!

interface Dialer0

description ****Out to BT Internet****

ip address negotiated

ip virtual-reassembly

encapsulation ppp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

dialer pool 1

dialer-group 1

no cdp enable

ppp chap hostname mxtsuk/jlennon^acas.org.uk

ppp chap password 7 12090442471C03162E

!

interface BVI1

description $ES_LAN$

ip address 10.215.21.1 255.255.255.0

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer0

!

no ip http server

no ip http secure-server

!

access-list 100 permit ip 10.215.21.0 0.0.0.255 any

dialer-list 1 protocol ip permit

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

!

line con 0

no modem enable

stopbits 1

line aux 0

stopbits 1

line vty 0 4

password 7 141B071D0D003F282F

login

!

scheduler max-task-time 5000

end


I've debugged ppp authentication and negotiation and this looks fine (the router is picking up it's public IP address from our ISP) - see attached


The interfaces also look OK (see attached)


I am also able to connect to the wireless card.


Any help would be much appreciated.


Best wishes


Miles



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Jon Marshall Tue, 10/21/2008 - 13:38
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Miles


Have to admit it's been a long time since i did anything with these routers so i could be off base but you have a DHCP pool of 10.215.21.0 255.255.255.0. These addresses are not routable on the Internet so you need to NAT them to a public IP address but i can't see any NAT commands in your configuration.


Jon


Actions

This Discussion