LMS 2.6 / upgrade to RME 4.0.6 : config issue and device update issue

Unanswered Question
Oct 22nd, 2008
User Badges:

Hi,


Since customer has update RME 4.0.6. He has many devices which config failed partially with this message:

Protocol ==> Unknown / Not Applicable

CM0056 Config fetch failed for Amberieu Cause: CM0204 Could not create DeviceContext for 653 Cause: CM0206 Could not get the config transport implementation for 10.44.137.5 Cause: UNKNOWN Action: Check if required device packages are available in RME. Action: Check if protocol is supported by device and required device package is installed.


So he tried to install 2960 package, but it failed.


Now when he select in Device update RME or device type count number we have this error: see attach file error.txt


I tried to delete package 2960 but it failed, I saw in psu.log that the file didn't exist on disk: [ Wed Oct 22 16:12:10 CEST 2008 ] ERROR [PackageInstaller : LogAndUpdateEvent] : Package installation failed : Reason :[java.lang.Exception: Delete failed for d:\cwlms\cscopx/MDC/tomcat/webapps/rme/WEB-INF/lib/pkgs/Cat2960.zip]

[ Wed Oct 22 16:12:11 CEST 2008 ] ERROR [PackageManager : unInstallPackages] : Exception while uninstalling: nulljava.lang.NullPointerException

java.lang.NullPointerException

at com.cisco.nm.xms.psu.packagemgmt.PackageInstaller.LogAndUpdateEvent(Unknown Source)

at com.cisco.nm.xms.psu.packagemgmt.PackageInstaller.invokeUninstallForPackage(Unknown Source)

at com.cisco.nm.xms.psu.packagemgmt.PackageInstaller.performUninstall(Unknown Source)

at com.cisco.nm.xms.psu.packagemgmt.PackageInstaller.autoUnInstall(Unknown Source)

at com.cisco.nm.xms.psu.packagemgmt.PackageManager.unInstallPackages(Unknown Source)

at com.cisco.nm.xms.psu.packagemgmt.InstallWrapper.unInstallPkgs(Unknown Source)

at com.cisco.nm.xms.psu.packagemgmt.InstallWrapper.main(Unknown Source)

[ Wed Oct 22 16:12:11 CEST 2008 ] ERROR [CreateMaps : retainEntries] : String index out of range: -1


Packages are list on device update for delete purpose but they don't exist on disk.


Any idea ? Thanks, Elisabeth



Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Wed, 10/22/2008 - 09:10
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Looks like you have a few problems. All point to an issue with the RME 4.0.6 installation. Please post the list of contents in both d:\cwlms\cscopx/MDC/tomcat/webapps/rme/WEB-INF/lib/pkgs and D:\cwlms\cscopx\www/classpath/com/cisco/nm/xms/psu/pkgs/rme. Also, please post the RME map files under D:\cwlms\cscopx\www/classpath/com/cisco/nm/xms/psu/maps.

Joe Clarke Fri, 10/24/2008 - 11:17
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

First, your RME package directory does not match your PSU package directory. This is bad. There are five packages known to PSU, but not being used by RME. You should shutdown CiscoWorks Daemon Manager, then copy the five missing packages from the PSU directory to the RME lib/pkgs directory. Then restart Daemon Manager.


Second, I actually wanted to see the RME package map files.

ebezombes Mon, 11/03/2008 - 08:26
User Badges:

Hi,


I stoped process.

I copied files from psu to lib:

AS5350.zip

AS5400.zip

ASA.zip

Cat2960.zip

Cat3550.zip

Cat3560.zip

Cat3750.zip

Cat6000.zip

Cat6000IOS.zip

CatGL3.zip

CBS3000.zip

CE500.zip

MDS.zip

MetroSwitch.zip

NAM.zip

Pix.zip

Rtr12000.zip

Rtr2800.zip

Rtr3200.zip

Rtr7000.zip

Sfs.zip


I started process, I have same issue when I selected in Device update RME or device type count number.


Here you can find files :

- rmeDeviceMap.map

- rmePackageMap.map


It seems corrupt, isn't it ?



Joe Clarke Mon, 11/03/2008 - 10:15
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Yes. This is known bug CSCsj58812:


Symptom:


The package and device map files used the the Product Support Updater may become corrupt. This corruption can lead to Java exceptions when trying to view package information under Common Services > Software Center > Device Update. One possible exception is:


java.util.NoSuchElementException

at java.util.StringTokenizer.nextToken(StringTokenizer.java:259)

at com.cisco.nm.xms.psu.ui.gui.model.action.DevUpdate.getPackageMap(Unknown Source)

at com.cisco.nm.xms.psu.ui.gui.model.action.DevUpdate.perform(Unknown Source)


Conditions:


This can occur if multiple PSU jobs are started before one job has had a chance to properly complete.


Workaround:


Before executing any other PSU jobs, wait for the CiscoWorks daemons to recycle, and fully restart.


If the maps become corrupt, run the following commands to regenerate the files. For Windows (each command is on ONE LINE):


set NMSROOT=%CWMIBDIR%\..\..\..


%NMSROOT%\lib\jre\bin\java -classpath %NMSROOT%\lib\jre\lib;%NMSROOT%\lib\classpath;%NMSROOT%\objects\log4j\1.1.3\log4j.jar;%NMSROOT%\MDC\tomcat\shared\lib\MICE.jar;%NMSROOT%\MDC\tomcat\shared\lib\NATIVE.jar;%NMSROOT%\MDC\tomcat\shared\lib\jdom.jar;%NMSROOT%\www\classpath;%NMSROOT%\lib\classpath\servlet.jar;%NMSROOT%\MDC\tomcat\webapps\cwhp\WEB-INF\classes com.cisco.nm.xms.psu.packagemgmt.map.CreateMaps %NMSROOT%\www\classpath\com\cisco\nm\xms\psu\pkgs\rme


%NMSROOT%\lib\jre\bin\java -classpath %NMSROOT%\lib\jre\lib;%NMSROOT%\lib\classpath;%NMSROOT%\objects\log4j\1.1.3\log4j.jar;%NMSROOT%\MDC\tomcat\shared\lib\MICE.jar;%NMSROOT%\MDC\tomcat\shared\lib\NATIVE.jar;%NMSROOT%\MDC\tomcat\shared\lib\jdom.jar;%NMSROOT%\www\classpath;%NMSROOT%\lib\classpath\servlet.jar;%NMSROOT%\MDC\tomcat\webapps\cwhp\WEB-INF\classes com.cisco.nm.xms.psu.packagemgmt.map.CreateMaps %NMSROOT%\www\classpath\com\cisco\nm\xms\psu\pkgs\cvw


For Solaris:


env LD_LIBRARY_PATH=/opt/CSCOpx/lib:/opt/CSCOpx/MDC/lib /opt/CSCOpx/lib/jre/bin/java -classpath /opt/CSCOpx/lib/jre/lib:/opt/CSCOpx/lib/classpath:/opt/CSCOpx/objects/log4j/1.1.3/log4j.jar:/opt/CSCOpx/MDC/tomcat/shared/lib/MICE.jar:/opt/CSCOpx/MDC/tomcat/shared/lib/NATIVE.jar:/opt/CSCOpx/MDC/tomcat/shared/lib/jdom.jar:/opt/CSCOpx/www/classpath:/opt/CSCOpx/lib/classpath/servlet.jar:/opt/CSCOpx/MDC/tomcat/webapps/cwhp/WEB-INF/classes com.cisco.nm.xms.psu.packagemgmt.map.CreateMaps /opt/CSCOpx/www/classpath/com/cisco/nm/xms/psu/pkgs/rme


env LD_LIBRARY_PATH=/opt/CSCOpx/lib:/opt/CSCOpx/MDC/lib /opt/CSCOpx/lib/jre/bin/java -classpath /opt/CSCOpx/lib/jre/lib:/opt/CSCOpx/lib/classpath:/opt/CSCOpx/objects/log4j/1.1.3/log4j.jar:/opt/CSCOpx/MDC/tomcat/shared/lib/MICE.jar:/opt/CSCOpx/MDC/tomcat/shared/lib/NATIVE.jar:/opt/CSCOpx/MDC/tomcat/shared/lib/jdom.jar:/opt/CSCOpx/www/classpath:/opt/CSCOpx/lib/classpath/servlet.jar:/opt/CSCOpx/MDC/tomcat/webapps/cwhp/WEB-INF/classes com.cisco.nm.xms.psu.packagemgmt.map.CreateMaps /opt/CSCOpx/www/classpath/com/cisco/nm/xms/psu/pkgs/cvw


ebezombes Tue, 11/04/2008 - 12:07
User Badges:

Thanks for your update


I made the command line, I had this message:

log4j:ERROR Please initialize the log4j system properly

=> I saw in forum, that was a cosmetic error message.

Unfortunaly, I saw corruption on rme map file, I deleted lines which seem to be bad.

=> Now I can select in Device update RME or device type count number.


Now I try to install cat2960 package and I have this message:

Consistency check failed for base package SharedCdaIOS


Thanks, Elisabeth


Joe Clarke Tue, 11/04/2008 - 12:15
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

The map files may still not be consistent. Move the RME map files out of the way, then run the RME command again. These map files must be properly generated.


This may or may not fix the Cat2960 installation problem. The error points to an older version of SharedCdaIOS being installed than what is required. Given that you had package problems to begin with, you may need to reinstall RME from scratch to fully resolve all of these problems. You must have SharedCdaIOS 1.0.1 installed.

ebezombes Wed, 11/05/2008 - 02:08
User Badges:

Hi,


I suppress both rme map files and executed commands, now files are ok.

But 2960 package installation failed.

I reinstalled RME 4.0.6 and now I could install 2960 package. :)

Thanks, Elisabeth

Actions

This Discussion