3825 not booting properly

Unanswered Question
Oct 22nd, 2008

I have a 3825 that is supposed to be in ROMMON mode (according to Cisco documentation), but, I'm not getting the rommon1> symbol, just random characters after hitting the Enter key.

The 'SYS' led on the front panel is flashing green.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
allan.thomas Wed, 10/22/2008 - 14:04

Just a suggestion, but the symptoms you describe suggest that it is possibly a problem with your terminal/console session settings?

If the console session settings are different to that what is configured on your network device, then random characters do appear.

Try changing your baud setting to 9600-8-N-1, if this fails gradually increase the speed.

HTH

Allan.

chris.stuntz Wed, 10/22/2008 - 14:10

Allan,

Yes, this is the setting I'm using. I was using this setting when I started having the problems I'm experiencing now. I will try increasing the rate as suggested...

chris.stuntz Wed, 10/22/2008 - 14:13

Allan,

No, changing the bits per second only changes the character(s) size...

allan.thomas Wed, 10/22/2008 - 14:19

When you make the change on the terminal setting do you disconnect and reconnect each time? I have a USB Console cable, and have to connect and reconnect everytime the session is interupted.

Also have you tried a different console cable?

Is this the first time you attempted to connect to the router via console? curious as to why you think it should be in rommon>

Try reload the router whilst connected via the console with the default baud settings and see if see any messages on the console during boot.

Allan.

chris.stuntz Wed, 10/22/2008 - 15:03

Allan,

The console cable is fine. When I initially booted the router, it was in rommon mode as the image wouldn't load. I tried transferring an image via tftp, but, kept getting errors. As it's been a few weeks, I do not remember the command I typed that brought the router to the current state.

According to the Cisco documentation, I should be in rommon mode as the 'SYS' led on the front panel is flashing green.

chris.stuntz Thu, 10/23/2008 - 04:50

No, neither suggestion works. When I hit i (or enter), I just get random characters (i.e.![fYd) whenever I hit any key.

As stated before, I'm not in rommon mode...I'm stuck in some other mode that I cannot get out of. As mentioned before, the 'SYS' led is flashing green on the front panel...this is the only fault indication I'm receiving.

allan.thomas Thu, 10/23/2008 - 05:43

Hi Chris, what image were you attempting to tftp at the time when you starting experiencing these issues?

Was it the IOS Software, or actual IOS ROMMON that was attempted?

If you attempted to upgrade the ROMMON and was successful, then the router will be reloaded automatically and either boot back into ROMMON or load the IOS depending on the conf-reg.

Allan.

chris.stuntz Thu, 10/23/2008 - 06:05

Well, this router already had an image before I attempted to configure this a few weeks ago, but, the image wouldn't load properly and I was forced into rommon. While in rommon, I attempted to tftp a known good image (c3825-advipservicesk9-mz.124-6.T7.bin, 35,859 KB), but, I was receiving a byte size error (or something to this affect...don't remember the exact error). I then made a change, but, honestly I don't remember what I did. I didn't make a conf-reg change, but, now, I cannot modify anything, so, I'm not sure what mode I'm in or how to change it…

allan.thomas Thu, 10/23/2008 - 06:45

If the gateway is failing to load the IOS image from flash and still does not fallback to ROMMON then your only option would be to RMA.

Incidentally where was the previous image booted from Compactflash or bootflash? Have you tried removing the compactflash and to see if will default to bootflash ?

HTH

Allan.

chris.stuntz Thu, 10/23/2008 - 09:19

Allan,

Good idea, but, removing the compact flash card doesn't change anything.

allan.thomas Thu, 10/23/2008 - 09:46

Unfortunately it would appear that an RMA is your only option here.

With the 3800 series there is no removeable flash, otherwise I would have suggested to try changing the flash with another 3800 series router if one was available to see if it would boot from it?

If it did then you would be able upload the image onto the compactflash and change boot settings in the configuration to boot from the compactflash instead.

Have tried another compactflash card if one is available?

The fact that the system light is blinking green as you said it can either mean that the router is in rommon or it could possibly still be trying boot?

Allan.

chris.stuntz Thu, 10/23/2008 - 09:51

Actually, I do have another compact flash card, but, I don't know what image it's loaded with. I will have to keep searching. Thanks.

shillyar Thu, 10/23/2008 - 10:41

Im missing some thing here if your box is stuck in rommon and you cant boot off the flash card have you tried xmodem of tftpdnld ? as if all that fails as well then your really stuck and will need the box replaced. Have you tried to change the conf register to try booting the boot image ?

thx

allan.thomas Thu, 10/23/2008 - 11:00

Hi Steve, Chris's issue is that he is not able to gain access to rommon> prompt. The console session returns strange characters, and he has already determined it is not the console cable or the baud rate.

So without getting to the rommon> prompt, it is difficult for him to initiate either xmodem or tftpdnld.

Allan.

chris.stuntz Thu, 10/23/2008 - 11:40

Allan,

Yes, thank you.

Also, I do have another operational 3825 that I can grab the flash card from and try to boot this router...

chris.stuntz Fri, 10/24/2008 - 08:37

Well, I've booted the router with the CF from the good router a few times and still no legible characters. The 'SYS' led has stopped flashing, and, the cursor scrolls across the screen like the image is loading, but, it's all blank (not the normal boot characters).

allan.thomas Fri, 10/24/2008 - 09:11

I assume that you able to connect to the working 3825 without any problem using the same console? This will confirm that it definately not the cable or terminal session.

If you can connect, then unfortunately Chris we appear to have run out of options here to try, the only alternative is for an RMA?

Allan.

chris.stuntz Fri, 10/24/2008 - 09:57

Yes, I just consoled into a 2811 (using same terminal and console cable) with no problems. I've also tried every speed setting (bps) in HyperTerm...

allan.thomas Fri, 10/24/2008 - 14:32

Sorry things didn't workout very perculiar problem I must say, all the best.

Allan.

Actions

This Discussion