Catalyst console port hung

Unanswered Question
Oct 23rd, 2008

Somehow my console port is hung. When I telnet to the server and do a show user and I see the following for the console.

Line User Host(s) Idle Location

0 con 0 172.20.201.35 22:04:14

172.20.205.35 22:02:07

172.20.201.34 22:01:29

172.20.1.2 21:45:05

172.20.205.31 21:25:53

172.20.205.31 20:41:39

How do I clear the connections on the console so I can access again, without having to reload the sup.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
MUHAMMAD SHAHEEN Thu, 10/23/2008 - 07:42

Hi,

the command is clear line vty x, where x is a number 0 to 15 for each session.

Hope this helps

Shaheen

rschwendeman Thu, 10/23/2008 - 07:53

these are not under the vty. all of these hosts are showing from the console. I had several ssh connections from the console and lost connection to the last device and now it is hung.

j.bourque Thu, 10/23/2008 - 11:17

What is the config under "line con 0"?

If you find a working solution please post.

Richard Burts Thu, 10/23/2008 - 11:33

Robert

I wonder if it would work if you clear by absolute line number instead of by relative line number (line vty 0 is a relative number, line 0 is the absolute line number for the console). So I wonder if clear line 0 would resolve your problem.

HTH

Rick

pkaretnikov Mon, 10/27/2008 - 17:56

run a 'sh host', it should look something like this:

Host Port Flags Age Type Address(es)

R2 2002 (perm, OK) 2 IP 1.1.1.1

R4 2004 (perm, OK) ** IP 1.1.1.1

R6 2006 (perm, OK) ** IP 1.1.1.1

BB1-2 2007 (perm, OK) 2 IP 1.1.1.1

Frame 2008 (perm, OK) ** IP 1.1.1.1

cat3550 2009 (perm, OK) ** IP 1.1.1.1

cat3560a 2010 (perm, OK) 78 IP 1.1.1.1

cat3560b 2011 (perm, OK) 49 IP 1.1.1.1

R1 2001 (perm, OK) ** IP 1.1.1.1

R3 2003 (perm, OK) ** IP 1.1.1.1

R5 2005 (perm, OK) ** IP 1.1.1.1

use 'clear line x', where x is the last number(s) under port.

to clear my R1 I type 'clear line 1'

edit: basicly drop the first part, 2001 -> 1

Hope that helps.

peterbe Tue, 10/28/2008 - 19:32

Maybe try connecting to the console again and use 6 x to returned to the prompt. Then do:

show sessions

to get session number and use:

disconnect (may require 'ssh' option?)

to disconnect session(s).

Actions

This Discussion