Switchport configuration examples for CUCM/Unity/MP/ etc

Answered Question
Oct 23rd, 2008

Hello!

Does anyone have a best practice from Cisco or what you use for QOS at the switchport where CUCM, Unity, MP, GK, GW, etc are plugged into? The Phones are pretty easy, but the servers, of course we have vlans for them, but what should I recommend for QOS at the switchports?

Cheers!

Correct Answer by allan.thomas about 8 years 3 months ago

The configuration would be dependent on the type of capabilities of the switchport such as input/output scheduling, queuing and whether it supported SRR or WRR?

Another important consideration is where you define your trust boundary? You not necessarily need trust dscp for CCM or Unity, you could configure a service-policy which classifies and marks CS3, EF etc. Which you could then apply on input for all vlan-based QoS.

When you enable mls qos on Sup720 for example, the default output queue mapping for COS is perfectly acceptable for CS3 and EF.

EF is placed automatically in the priority queue, and CS3 is placed in appropriate queue threshold above that of scavenging traffic CS1 and best-effort.

Ordinarily I would not expect congestion on these switchports, so the defaults would suffice.

CCM and Unity use DSCP marking therefore you can simply trust dscp on these switchport.

To give you an idea, the following document link details QoS configuration examples for various CallManager endpoints:-

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/srnd/6x/endpnts.html#wp1044556

Also take a look at this section from the same CUCM SRND for QoS in the network infrastructure:-

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/srnd/6x/netstruc.html

Below is a typical example of how I would configure a 3750 switchport connected to a CallManager:-

interface GigabitEthernet1/0/2

description CCM01

switchport access vlan 100

switchport mode access

srr-queue bandwidth share 10 10 20 60

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust dscp

auto qos voip trust

spanning-tree portfast

spanning-tree bpduguard enable

!

In this example the queue-set 2 buffer defaults and auto-qos defaults generated for input/output queue mappings are acceptable.

Although not applicable to CallManager/Unity switchports, the only aspect I have changed is the srr weights for queue 3 and 4.

Ordinarily Video in queue 3 is allocated more queue servicing to that of queue 4 for best-effort traffic. Therefore, I configure all access switchports where Video is not prevelant a higher percentage to queue 4.

HTH

Allan.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
allan.thomas Thu, 10/23/2008 - 10:53

The configuration would be dependent on the type of capabilities of the switchport such as input/output scheduling, queuing and whether it supported SRR or WRR?

Another important consideration is where you define your trust boundary? You not necessarily need trust dscp for CCM or Unity, you could configure a service-policy which classifies and marks CS3, EF etc. Which you could then apply on input for all vlan-based QoS.

When you enable mls qos on Sup720 for example, the default output queue mapping for COS is perfectly acceptable for CS3 and EF.

EF is placed automatically in the priority queue, and CS3 is placed in appropriate queue threshold above that of scavenging traffic CS1 and best-effort.

Ordinarily I would not expect congestion on these switchports, so the defaults would suffice.

CCM and Unity use DSCP marking therefore you can simply trust dscp on these switchport.

To give you an idea, the following document link details QoS configuration examples for various CallManager endpoints:-

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/srnd/6x/endpnts.html#wp1044556

Also take a look at this section from the same CUCM SRND for QoS in the network infrastructure:-

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/srnd/6x/netstruc.html

Below is a typical example of how I would configure a 3750 switchport connected to a CallManager:-

interface GigabitEthernet1/0/2

description CCM01

switchport access vlan 100

switchport mode access

srr-queue bandwidth share 10 10 20 60

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust dscp

auto qos voip trust

spanning-tree portfast

spanning-tree bpduguard enable

!

In this example the queue-set 2 buffer defaults and auto-qos defaults generated for input/output queue mappings are acceptable.

Although not applicable to CallManager/Unity switchports, the only aspect I have changed is the srr weights for queue 3 and 4.

Ordinarily Video in queue 3 is allocated more queue servicing to that of queue 4 for best-effort traffic. Therefore, I configure all access switchports where Video is not prevelant a higher percentage to queue 4.

HTH

Allan.

Tommer Catlin Thu, 10/23/2008 - 11:21

Great answer. I appreciate the time for explaining it a little bit more.

Cheers!

Actions

This Discussion