UCBE 6.1 and MGCP with 2811 Router and PRI

Unanswered Question
Oct 23rd, 2008

I am trying to setup UCBE and MGCP with a 2811 Router and PRI. The issue is that only 12 channels of the PRI are going to be active and MGCP keeps overwriting to using the full 24 channels again in the router. Where do I change the config so it only uses the first 12 channels?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Ayodeji oladipo... Thu, 10/23/2008 - 13:17

You need to manually configure your mgcp gateway. Remove the following commands..

ccm-manager config

ccm-manager config server ...

What is happening is that callmanager is automatically configuring the mgcp gateway because of this commands and callmanager will always configure the 24 channels unless you edit the service parameters and busy out some channels

For detail on configuring mgcp..look here


allan.thomas Thu, 10/23/2008 - 13:33

Further the good information provided by Deji +5, here is a little more detail.

Firstly Cisco stipulate that they do not support fractional PRI with MGCP, the alternative is to H.323.

However, it is possible to reconfigure the controller in order to restrict the number of timeslots, and ensure that CallManager does not reconfigure the controller back to 24.

If conserving DSPs is not a requirement for configuring transcoding, then you can simply leave the timeslots as configured, and then busy the timeslots that are not available within the CallManager service parameters under MGCP Settings:-

Take a look at this document for busy-out b-channels:-


Follow these steps to change controller if require:-

1. Go into the particular voice-port ?/?/?:? that was created and 'shutdown' the port

2. Go into the serial interface ?/?/?:? and do 'no mgcp bind-l3 ccm-manager'

3. Go into the Controller ?/?/? and 'shutdown'

4. Remove the pri-group, 'no pri-group timeslots 1-24 service mgcp' in the controller.

5. Enter 'pri-group timeslots 1-12 service mgcp' in the controller.

6. 'no shut' the controller.

7. Go back into the serial interface ?/?/?:?

and re-add the command 'isdn bind-l3 ccm-manager'.

8. Verify your isdn status.

9. Go into the voice-port and re-add the cptone ????

10. IMPORTANT, remove the command 'no ccm-manager config' Without this command the router will not attempt to download the configuration from CCM after a restart/reload.




This Discussion