Cisco 2821 Questions

Answered Question
Oct 23rd, 2008

Hello folks -


I have a Cisco 2821 router. Below is the sh version output. This router has a channelized T1/E1 WIC (2 ports). I want to configure a serial (T1) interface on this router but don't have the option to do it. Not sure what am I missing here.


In other words, from the config mode, I can't issue the command: interface serial xxx


Cisco 2821 (revision 53.51) with 249856K/12288K bytes of memory.

Processor board ID FTX1106A037

2 Gigabit Ethernet interfaces

2 Channelized (E1 or T1)/PRI ports

2 Virtual Private Network (VPN) Modules

DRAM configuration is 64 bits wide with parity enabled.

239K bytes of non-volatile configuration memory.

62720K bytes of ATA CompactFlash (Read/Write)


Configuration register is 0x2102


Correct Answer by Jon Marshall about 8 years 4 months ago

You need to tell your router about the card - see this link


http://www.cisco.com/en/US/docs/ios/interface/command/reference/ir_c1.html#wp1012287


Jon

Correct Answer by graemeporter about 8 years 4 months ago

Hi there,


You need to tell the card what mode it should operate in, using the "card type" command


i.e. you want to use it as an E1 card, use the command:


card type e1 0


(the 0 is for the slot number it is inserted into)


Once you do that, then you need to set the number of channels by configuring the controller :


controller e1 0 0

channel-group 0 timeslots 1-31


Note - you need to have enough DSP channels to cover the number of timeslots you are configuring. Also, the number of timeslots (31) is the maximum number available on an ISDN30e (E1) line; you need to set the number to match the number of channels you have subscribed to on your line.


Once you do that, then the router will add all the Serial interfaces you are looking for to the configuration.


Hope this helps!


Kind regards

Graeme

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
ksarin123_2 Thu, 10/23/2008 - 13:24

here is the output!!


ocol

GigabitEthernet0/0 76.227.198.139 YES manual up up

GigabitEthernet0/1 unassigned YES NVRAM up up

GigabitEthernet0/1.1 192.168.10.1 YES NVRAM up up

GigabitEthernet0/1.2 192.168.20.1 YES NVRAM up up

Group-Async0 unassigned YES unset down down

NVI0 unassigned NO unset up up

Correct Answer
graemeporter Thu, 10/23/2008 - 13:29

Hi there,


You need to tell the card what mode it should operate in, using the "card type" command


i.e. you want to use it as an E1 card, use the command:


card type e1 0


(the 0 is for the slot number it is inserted into)


Once you do that, then you need to set the number of channels by configuring the controller :


controller e1 0 0

channel-group 0 timeslots 1-31


Note - you need to have enough DSP channels to cover the number of timeslots you are configuring. Also, the number of timeslots (31) is the maximum number available on an ISDN30e (E1) line; you need to set the number to match the number of channels you have subscribed to on your line.


Once you do that, then the router will add all the Serial interfaces you are looking for to the configuration.


Hope this helps!


Kind regards

Graeme

ksarin123_2 Thu, 10/23/2008 - 13:47

Guys -


thanks for your prompt replies.


One final question. When I issue the command


card type t1 slot ? , I have options 0-2.


However, the WIC is in slot # 3 in the router. How should I get around this?


Thanks again!

Actions

This Discussion