Question on route-map for BSCI

Unanswered Question
Oct 24th, 2008

Hi, I am studying for BSCI and can't understand this route-map scenario. I have set up below scenario in my little home lab routers but cannot understand the output.

Router A has 3 interfaces to 3 routers. Rtr A connects to Rtr B with EIGRP 50 via serial 0. Rtr A connects to Rtr C with eigrp 100 via Serial 1. Rtr A connects to Rtr D with OSPF via serial 2.

1. If Rtr A has ospf redistribute into eigrp 100 with a route-map as such:

route-map abc permit 10

match ip address 1

access-list 1 permit 10.1.1.0 0.0.0.255

where 10.1.1.0/24 is the LAN subnet in Rtr D where Rtr D has advertised it within ospf.

So when I goto Rtr C and check my eigrp 100 table, I should expect to see this 10.1.1.0/24 as D EX. But I tested this with my lab routers, but I see from Rtr C 3 D EX routes. There are two LAN subnets in Rtr D. In Rtr C, I see both Rtr D's subnets and the serial interface subnet between A and D also. In Rtr A, there is no redistribute connected at all.

So my question is I have the route-map that suppose only allow 10.1.1.0/24 to redistributed into EIGRP 100, why do I see the other 2 subnets also (the /30 connected between A & D and the other LAN subnet in D).

I even modify the route-map to this:

route-map abc deny 10

match access-list 2

route-map abc permit 20

match access-list 1

access-list 1 permit 10.1.1.0 0.0.0.255

access-list 2 permit 172.16.1.0 0.0.0.255

I see from show access-list output that both access lists has a hit, so I expect 172.16.1.0 should be "denied" and won't be redistributed but yet, in Rtr C I still see it as D EX.

I must have misunderstand the use of route-map in redistribution then. My goal is to just redistributed 10.1.1.0 in eigrp 100. I know I can do distribute-list 1 out under eigrp 100 in Rtr A to filter it out. But my goal is to accomplish it via route-map instead of distribute-list.

My other puzzle is I test this same network with the match interface command.

So my route-map now is:

route-map abc permit 10

match interface serial 0

!! the serial 0 in Rtr A is the interface to Rtr B which is under eigrp 50. I am applying route-map abc under eigrp 100. My goal is I expect to see no routes being redistribute at all in eigrp 100 when I look at Rtr C. But to my surprise, in Rtr C, I still see all 3 D EX routes. It seems it doesn't matter what match interface I set it to, all 3 routes are shown in Rtr C.

thanks for your patience to read my message and your assistance.

Joyce

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
solpandor Mon, 10/27/2008 - 07:26

Joyce

please can you post config and of routers and also a diagram.

Also, on which interface did you apply the routemap and in which direction?

blackladyJR Mon, 10/27/2008 - 09:25

Thanks for your help. I have attached the sketch. It's very puzzled of why in Rtr C where I can see all 3 routes belonging to D as I only expect to see 1 route being redistributed. I purposely deny 130.1.1.0 and explicit allow 150.50.50.0 and purposely no mention to 192.165.1.0. So I expect only 150.50.50.0 get redistributed into eigrp 100 and shown in RTR C table. I assume 130.1.1.0 will get explicit deny and 192.165.1.0 will get implicit deny. But all 3 routes are in RTR C table.

As for match interface scenario, I purposely choose the interface connecting to RTR B which is not part of EIGRP 100 so I want to test to see if no routes are being redistributed.

Everything looks perfectly fine such as routing table in A is what expected. The only thing that really puzzled is the routing table in C of seeing all 3 routes.

As for route-map apply in or out, I don't think there is option to apply direction when redistributing into EIGRP. I know we do that in BGP route-map under neighbor statement. So when I apply route-map redistributing into eigrp, the assumption is inbound into the eigrp from ospf.

RTRC >sh ip ro

1.0.0.0/24 is subnetted, 1 subnets

C 1.1.1.0 is directly connected, Ethernet1/1

8.0.0.0/24 is subnetted, 1 subnets

C 8.1.1.0 is directly connected, Ethernet1/0

C 192.168.20.0/24 is directly connected, Serial1/0.202

130.1.0.0/24 is subnetted, 1 subnets

D EX 130.1.1.0 [170/40537600] via 192.168.20.2, 00:00:11, Serial1/0.202

D EX 192.165.1.0/24 [170/40537600] via 192.168.20.2, 00:00:11, Serial1/0.202

150.50.0.0/24 is subnetted, 1 subnets

D EX 150.50.50.0 [170/40537600] via 192.168.20.2, 00:00:31, Serial1/0.202

RTRA#sh run

!

interface Serial0/0

no ip address

encapsulation frame-relay

clockrate 64000

cdp enable

!

interface Serial0/0.103 point-to-point

ip address 192.168.20.2 255.255.255.0

frame-relay interface-dlci 103

!

interface Serial0/0.104 point-to-point

ip address 150.50.50.2 255.255.255.0

frame-relay interface-dlci 104 IETF

!

interface Serial0/0.201 point-to-point

ip address 172.16.10.2 255.255.255.0

frame-relay interface-dlci 201 IETF

!

interface Ethernet0/1

ip address 1.1.1.2 255.255.255.0

half-duplex

!

router eigrp 100

redistribute ospf 1 route-map qwe

! route-map abc provides same result in Rtr C table

network 192.168.20.0

default-metric 64 100 255 1 1500

no auto-summary

!

router eigrp 50

network 172.16.0.0

no auto-summary

!

router ospf 1

log-adjacency-changes

network 150.50.50.0 0.0.0.255 area 0

!

access-list 1 permit 130.1.1.0 0.0.0.255

access-list 2 permit 150.50.50.0 0.0.0.255

!

route-map abc deny 10

match ip address 1

!

route-map abc permit 20

match ip address 2

!

route-map qwe permit 10

match interface Serial0/0.201

!

RTRA# sh ip ro

1.0.0.0/24 is subnetted, 1 subnets

C 1.1.1.0 is directly connected, Ethernet0/1

172.16.0.0/24 is subnetted, 1 subnets

C 172.16.10.0 is directly connected, Serial0/0.201

8.0.0.0/24 is subnetted, 1 subnets

D 8.1.1.0 [90/2195456] via 192.168.20.1, 00:01:31, Serial0/0.103

C 192.168.20.0/24 is directly connected, Serial0/0.103

130.1.0.0/24 is subnetted, 1 subnets

O IA 130.1.1.0 [110/74] via 150.50.50.1, 00:01:11, Serial0/0.104

10.0.0.0/24 is subnetted, 1 subnets

D 10.1.1.0 [90/2195456] via 172.16.10.1, 00:02:22, Serial0/0.201

O E2 192.165.1.0/24 [110/20] via 150.50.50.1, 00:01:11, Serial0/0.104

150.50.0.0/24 is subnetted, 1 subnets

C 150.50.50.0 is directly connected, Serial0/0.104

RTRD>sh ip ro

1.0.0.0/24 is subnetted, 1 subnets

C 1.1.1.0 is directly connected, Ethernet1/1

130.1.0.0/24 is subnetted, 1 subnets

C 130.1.1.0 is directly connected, Ethernet1/0

C 192.165.1.0/24 is directly connected, Ethernet1/2

150.50.0.0/24 is subnetted, 1 subnets

C 150.50.50.0 is directly connected, Serial0/0.202

Attachment: 
blackladyJR Tue, 10/28/2008 - 10:17

it is working now, it's the IOS version with bug that prevents OSPF filter into eigrp. I have upgraded IOS and it works perfectly now. Case closed.

Actions

This Discussion