one phone going into srst

Unanswered Question
Oct 24th, 2008
User Badges:

Customer has a new CMBE 6.1. Network consists of 2-3560 switches and a 2851 router/gateway. The 2851 is running srst. Twice in the past 2 weeks, a single phone has gone into SRST mode while all other phones have remained registered to cmbe.

The phone in srst is connected to the core 3560 which also has the cmbe and the 2851 connected.

Both times customer has unplugged the phone and reconnected it and it then registers with cmbe.

Anyone have any idea what might be happening?

Switch ports look clean with no drops or buffer overruns.


Rob

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jbarcena Fri, 10/24/2008 - 12:46
User Badges:
  • Red, 2250 points or more

I strongly recommend you to connect the phone on a different port for test purposes, if possible also replace the cable. Since the problem is only with one phone we need to narrow down the problem.


How often is the problem happening?

rvincent Fri, 10/24/2008 - 13:09
User Badges:

It has happened 2x in the past 3 weeks and it was with different phones which would seem to eliminate the port/cable as being the issue.


Rob

CHRIS CHARLEBOIS Fri, 10/24/2008 - 12:50
User Badges:
  • Silver, 250 points or more

Is this phone getting DHCP addressing or static? Is it possible that it's IP address is being blocked by an ACL. And what does the config look like for that switch port? Are you using a seperate voice VLAN?

rvincent Fri, 10/24/2008 - 13:11
User Badges:

phone gets dhcp.

there are no acl's for phones.

there is a seperate voice vlan

typical port config:

interface GigabitEthernet0/35

switchport access vlan 10

switchport mode access

switchport voice vlan 14

switchport port-security maximum 3

switchport port-security aging time 2

switchport port-security violation restrict

switchport port-security aging type inactivity

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast



Rob

CHRIS CHARLEBOIS Fri, 10/24/2008 - 13:20
User Badges:
  • Silver, 250 points or more

I would be very leery of the port-security commands. That would explain how it happens after the phone has been working for a while. Does someone have a desktop switch or hub plugged into the PC port of this phone or a PC that is emulating multiple MAC addresses. I'm thinking the combination of secure MAC aging and limiting the MACs to 3 might be the cause.

rvincent Mon, 10/27/2008 - 06:17
User Badges:

Gys:


neither of the phones that went into srst were connected into a hub. In fact, the pc connected to the phone never lost network connectivity.

The gateway log shows the phone registering but there is nothing unusual in the switch log.


strange



Rob

Actions

This Discussion