CUCM 6.1 MOH Issue

Unanswered Question
Oct 25th, 2008

Hi all,

I've installed CUCM 6.1 for a customer. Everything is working except the MOH. I have done the following things:

1) Configured MOH server

2) Uploaded a couple of music files

3) Under device and Line I selected the MOH file to be played.

When a call is put on-hold, I hear nothing or sometimes I hear 3 very low tune like Tik Tik Tik and then it's quite.

I have restarted the Cisco IP Voice Media services and even re-start the CUCM but all in vain.

I hope someone call help me with this issue.

Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Chris Deren Sat, 10/25/2008 - 09:04

The tones inducate misoncfiguration, are you using Multicast or Unicast MOH?

Make sure you upload the MOH file to all the servers configured as MOH servers.

Make sure you put the MOH server under MRG/MRL/Device Pool of the devices

Chris

Chris Deren Sat, 10/25/2008 - 09:31

Is this device pool assigned to the phones and gateways? At GWs besides applying the device pool you need to explicitely assign the MRGL.

What codec is defined to be used between the held devices and the MOH server?

Is there only one server in the cluster?

Chris

ysanadiga01 Sat, 10/25/2008 - 09:40

Hi Chris,

There is only one server in this cluster. I have selected that G711 and G729 are used between device and the MOH server.

The gateway in another device pool than the devices. I did put them in the samen device pool, but it didn't help either.

Thanks.

Chris Deren Sat, 10/25/2008 - 09:46

By default G729 will not work with MOH until you enable it in service parameters. What is the codec set between the held device and MOH server? If you have them in the same device pool what is the codec within each region?

Chris

ysanadiga01 Sat, 10/25/2008 - 09:56

I have enabled G729 and G711 in the Service Parameters. The Codec between each region is G.711.

I've not tested the Default MOH. I will do that on monday. Is there a way that I can test that remote?

Thanks.

Chris Deren Sat, 10/25/2008 - 09:48

Also,have you tried using the default MOH source file to see if that works?

Chris

mcibanez Tue, 12/15/2009 - 01:05

Hi,

I'm running CMv6.1.4 and I'm facing almost the same issue.

One out of two calls gets no MoH. Well, to be honest, the second one gets just 2 or 3 seconds of the Cisco default MoH file and then silence.


I think the config is right because I did this before many times, so I'm pretty sure about it.

Did you ever find out what was happening?

Thanks,

Carmen

mcibanez Tue, 12/15/2009 - 03:43

Hi again,

In case it helps anyone, my issue was a bug in CMv6.1.4.

Here are the details:

CSCta10219 - Unicast Music on Hold May Not Play

Intermittently silence packets streamed from MOH &/or ANN Server
Symptom:
after invoking Music on Hold server several times, unicast moh did not play music on hold. Music on hold may be invoked by hold, transfer, conference, park, or other features.

Conditions:
UCM 6.1(4) and unicast music on hold server invoked several times.
ANN could be affected by this behavior as well

Workaround:
Upgrade to a version with fix for this issue.

Alternate Workaround:
(a) Configure each MOH audio source ID for multicast
and (b) Configure each MOH server to multicast
and (c) All Media Resource Groups (if any are defined) must NOT have multicast enabled

This should result in MOH servers sending out multicast but also able to send out unicast MOH on same MOH resources.

This would not require making any network (router) changes to forward multicast MOH packets as long as Media Resource Groups (MRG) are not configured to enable multicast MOH.

One Drawback:
The MOH servers will be transmitting multicast streams for each MOH source and MOH codec so this may add some network traffic to the local network. These multicast streams will be continuous and running at all times. The MOH server(s) will be sending the MC stream(s) to the local router but as long as the router is NOT configured to forward the moh multicast packets the lan traffic will be minimal. By default, routers do not forward multicast moh packets.

No workaround known for ANN issues.

Additional NOTE:
This defect is fixed in 6.1.4.1102-1 but is NOT in 6.1.4.2000
It is included in 6.1.4.2113.

Best regards,

Carmen

Actions

This Discussion