cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
409
Views
0
Helpful
2
Replies

Point-to-point MPLS

ssmithers
Level 1
Level 1

Hello everyone,

I would like to configure two routers back to back MPLS. Each router has 2 interfaces. One to face the "cloud" and one to face the customer. The cloud is nothing more than a VLAN in which there are no other routers. The 2 MPLS end points are one the same IP segment and actually CDP see each other. I would like to take everything from the customer facing interface, encapsulate it, send it to the neighbor router and strip the MPLS tag and push it out the other non-cloud interface.

Thoughts?

Any help would be appriciated.

Thank you,

Steve

1 Accepted Solution

Accepted Solutions

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello Steve,

it is really possible to do what you want.

First on the two routers you enable mpls

conf t

int loop1

desc MPLS router-id

ip address 1.1.1.1 255.255.255.255

mpls ip

mpls label protocol ldp

on common segment

int gi0/0

desc mpls backbone link to other PE

mpls ip

this provides the MPLS infrastructure.

Now to send traffic between the two customer sites the best is to use an MPLS VPN made of two VRF sites

ip vrf Customer1

rd 1:1

route-target both 1:1

int f0/1

desc VRF access link facing customer

ip vrf forwarding Customer1

router bgp 1

no bgp default ipv4-unicast

neighbor 1.1.1.2 remote-as 1

neighbor 1.1.1.2 update-source loop1

address-family vpnv4

neighbor 1.1.1.2 activate

neighbor 1.1.1.2 send-community both

address-family ipv4 vrf Customer1

no sync

no auto-summary

redistribute connected

Do the same on the second router that will use a different IP address for the loopback

There is no need for a P router between the two PE routers.

For penultimate hop popping MPLS VPN packets will be sent out with a single label the VPN label advertised by BGP multiprotocol in address-family vpnv4.

May be your question was only about the possibility to use MPLS VPN with two back to back PE the answer is yes.

Hope to help

Giuseppe

View solution in original post

2 Replies 2

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello Steve,

it is really possible to do what you want.

First on the two routers you enable mpls

conf t

int loop1

desc MPLS router-id

ip address 1.1.1.1 255.255.255.255

mpls ip

mpls label protocol ldp

on common segment

int gi0/0

desc mpls backbone link to other PE

mpls ip

this provides the MPLS infrastructure.

Now to send traffic between the two customer sites the best is to use an MPLS VPN made of two VRF sites

ip vrf Customer1

rd 1:1

route-target both 1:1

int f0/1

desc VRF access link facing customer

ip vrf forwarding Customer1

router bgp 1

no bgp default ipv4-unicast

neighbor 1.1.1.2 remote-as 1

neighbor 1.1.1.2 update-source loop1

address-family vpnv4

neighbor 1.1.1.2 activate

neighbor 1.1.1.2 send-community both

address-family ipv4 vrf Customer1

no sync

no auto-summary

redistribute connected

Do the same on the second router that will use a different IP address for the loopback

There is no need for a P router between the two PE routers.

For penultimate hop popping MPLS VPN packets will be sent out with a single label the VPN label advertised by BGP multiprotocol in address-family vpnv4.

May be your question was only about the possibility to use MPLS VPN with two back to back PE the answer is yes.

Hope to help

Giuseppe

Giuseppe,

Great response. Thank you. The only other line I added was ebgp-multihop. Maybe I don't need it. I will try it both ways. Either way, thank you.

Steve

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: